Linux Mint 8 RC1 Bug Thread

Releases and other announcements.
Please don't post support questions here
Forum rules
Section reserved for the team. You can reply to announcements here but not post new topics.Please do not add support questions to threads here,use the appropriate support forum instead
gorzka
Level 1
Level 1
Posts: 15
Joined: Wed Oct 31, 2007 1:42 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by gorzka »

Clem
Have LM8 the ACX111 driver? Ubuntu don't have the ACX111 module,

Thank you.
User avatar
Rovanion
Level 1
Level 1
Posts: 26
Joined: Tue Jun 02, 2009 6:57 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by Rovanion »

Ditto joebobwilson
The propitary drivers for my HD4850 did not download and install once Linux Mint was installed. I had to go over to ATi's website and download it from there. Tough the odd thing is that it did install on the LiveCD, tough I did not test if it actually worked since I had to restart X to do that.

More on the visual part. The log in menu is plain ugly. I'd much rather see a reuse of the LM 7 one. Or if you want something that uses a face explorer use something like this: http://www.gnome-look.org/content/previ ... +GDM-Walls
Along with that. What are those small ugly balls that are circling around when you log in and then freeze on the desktop until you are fully logged in. They do not appear anywhere else in the system. Inconsistency for no good.

The Community-maintaned packages available to pick from the Software Sources list in mintUpdater seems to be offline.

EDIT:
Is there any way to switch desktops by default other than dragging a window? Scroll on background is disabeled by default and if I drag a window to another desktop I'm stuck there.
Last edited by Rovanion on Fri Nov 13, 2009 1:25 pm, edited 1 time in total.
Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Linux Mint 8 RC1 Bug Thread

Post by Husse »

Rovanion and joebobwilson
It seems that you experienced the same problem as I did
Open a terminal an run apt update
I would not be surprised if you find that it is trying to use an IP of 1.0.0.0.0
Then the simple solution is found here
This is an old problem that has disappeared and now reappeared
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
User avatar
shane
Level 5
Level 5
Posts: 940
Joined: Sun Feb 25, 2007 11:15 pm
Contact:

Re: Linux Mint 8 RC1 Bug Thread

Post by shane »

Hi all!

[edit] Not a bug... PEBKAC

I am facing a problem with connecting to my WPA2 encrypted wireless network. It is similar to problems I encountered in the Kubuntu Jaunty release. However, this problem was fixed in the Kubuntu Karmic release and I managed to connect without problems. The Ubuntu Karmic release gave me no problems either. The network is detected but it simply does not connect. It seems the problem lies with network manager.

Code: Select all

$ lspci | grep Broadcom
00:0b.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

$ lsmod | grep b43
b43                   137208  0
mac80211              155756  1 b43
ssb                    46020  1 b43
cfg80211               90428  2 b43,mac80211
pcmcia                 36168  2 b43,ssb
led_class               4000  1 b43
pcmcia_core            35184  5 b43,ssb,pcmcia,yenta_socket,rsrc_nonstatic
The driver for my Broadcom card is closed source and the combination that worked perfectly before was the Hardy b43-fwcutter package + b43 drivers. Later Ubuntu versions didn't work until Karmic. I tried the Hardy version (installed from HD) and then also the Karmic version (chrooted from a working installation to install b43-fwcutter and drivers) but still it just tries to connect but fails.

From dmesg:

Code: Select all

b43 ssb0:0: firmware: requesting b43/ucode5.fw
b43 ssb0:0: firmware: requesting b43/pcm5.fw
b43 ssb0:0: firmware: requesting b43/b0g0initvals5.fw
b43 ssb0:0: firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Registered led device: b43-phy0::radio
Clocksource tsc unstable (delta = -94827061 ns)
wlan0: authenticate with AP 00:32:04:03:25:eb
wlan0: authenticated
wlan0: associate with AP 00:32:04:03:25:eb
wlan0: RX AssocResp from 00:32:04:03:25:eb (capab=0x411 status=0 aid=194)
wlan0: invalid aid value 194; bits 15:14 not set
wlan0: associated
padlock: VIA PadLock not detected.
wlan0: no probe response from AP 00:32:04:03:25:eb - disassociating
wlan0: authenticate with AP 00:32:04:03:25:eb
wlan0: authenticated
wlan0: associate with AP 00:32:04:03:25:eb
wlan0: RX ReassocResp from 00:32:04:03:25:eb (capab=0x411 status=0 aid=193)
wlan0: invalid aid value 193; bits 15:14 not set
wlan0: associated
wlan0: no probe response from AP 00:32:04:03:25:eb - disassociating
wlan0: authenticate with AP 00:32:04:03:25:eb
wlan0: authenticated
wlan0: associate with AP 00:32:04:03:25:eb
wlan0: RX ReassocResp from 00:32:04:03:25:eb (capab=0x411 status=0 aid=193)
wlan0: invalid aid value 193; bits 15:14 not set
wlan0: associated
Anyone else having this problem? I will try to find the solution and post back.

I also think the wallpaper could be better.

Seems to be a great release in the works! Great job Clem!
Last edited by shane on Sun Nov 15, 2009 11:17 pm, edited 1 time in total.
User avatar
gees
Level 1
Level 1
Posts: 27
Joined: Sun Jul 05, 2009 2:19 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by gees »

Tested the livecd on Dell Latitude E6400:

No show stoppers so far.

First message (boot count-down) misses hint to press any button to get the full menu!

The pulsating Mint Logo during boot (not in the installed version) is a very elegant finding!

The wallpaper is ugly! Please keep Mint Dew! This will be the first impression for new users...

Installation on an external USB HDD went smooth on a external USB-HDD to multiboot with other OS'es.
I use a special boot-partition and use GRUB chainloader
Consider to put the Mint tutorial and a tutorial for installation on the desktop of the livecd, too.

Nice slide show, Why not put a (broken) windows icon/jpeg in the win part instead of a big yellow star?

Thx for the release to the hardworking team!
"The web was made for sharing ..."
hamburn
Level 2
Level 2
Posts: 64
Joined: Tue May 27, 2008 5:48 am

Re: Linux Mint 8 RC1 Bug Thread

Post by hamburn »

@joebobwilson and Rovanion,

have you read "known issue?

looks like not.
That's a bug that came from UBUNTU. Look in "known issues, then look in known issues of ubuntu karmic.
There they say, you have to refresh the sources before you can install a proprietary hard ware driver.

Have fun

hamburn, writing this from Glorious Gloria again, waiting for the final
hoping to have a working and nice looking Hilarious Helena then, instead of this sad looking.

I think even for a RC1 this was to early. :(
for linux to be successful on the desktop for normal users, normal users have to feel comfortable with it.
The interesting users are your mother, your neighbor. Those are the people that will decide whether or not linux is accepted on the desktop.
M.B.
Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Linux Mint 8 RC1 Bug Thread

Post by Husse »

Hamburn you are right - it can be two things
The bcm drivers are missing - that's something that really needs to be fixed
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
scottjge
Level 4
Level 4
Posts: 250
Joined: Sun Sep 13, 2009 8:17 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by scottjge »

Mint 8 needs to have the broadcom driver included with LiveCd. I run the livecd of Mint 8 but can not connect to my network to get updates or to install the broadcom wireless driver. so if you only have one machine with Mint on it, there is no way to set everything up until you can connect to a network for update, drivers, software, etc.

Hope this helps. I guess I will have to wait until the updated release comes out.
User avatar
mati75
Level 2
Level 2
Posts: 66
Joined: Wed Jul 09, 2008 6:00 am
Location: Poland
Contact:

Re: Linux Mint 8 RC1 Bug Thread

Post by mati75 »

Why button 'Update all packages' in synaptic is remove?
Image
User avatar
shane
Level 5
Level 5
Posts: 940
Joined: Sun Feb 25, 2007 11:15 pm
Contact:

Re: Linux Mint 8 RC1 Bug Thread

Post by shane »

scotthge wrote:Mint 8 needs to have the broadcom driver included with LiveCd. I run the livecd of Mint 8 but can not connect to my network to get updates or to install the broadcom wireless driver. so if you only have one machine with Mint on it, there is no way to set everything up until you can connect to a network for update, drivers, software, etc.

Hope this helps. I guess I will have to wait until the updated release comes out.
AFAIK Mint cannot redistribute the Broadcom drivers on the CD legally. The next best thing is the b43-fwcutter tool that downloads the drivers and installs them. Hopefully we can get an open source driver in the future.
scottjge
Level 4
Level 4
Posts: 250
Joined: Sun Sep 13, 2009 8:17 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by scottjge »

How come Mint 7 found my wireless and let me connect off the livecd?
diego1188

Re: Linux Mint 8 RC1 Bug Thread

Post by diego1188 »

I might be wrong as I just tried KK a few times and Helena just once in live mode in virtualbox. Anyway: KK shows the desktop at startup just when it is fully loaded; Helena displays the desktop as usual, with background and icons and panels and menus appearing one at a time. I find the first one more "elegant".
Am I right?
primski
Level 1
Level 1
Posts: 24
Joined: Fri Nov 13, 2009 1:22 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by primski »

Hello,

installed Mint 8 RC 1 today on Inspiron 1525 and have a problem with grep

Code: Select all

pjerse@pjerse-laptop ~ $ ps ax | grep firefox
 grep: command not found
pjerse@pjerse-laptop ~ $ grep
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
It's a clean install, altough i left my Home partition from previous install. Could be some hidden file, i deleted most of them prior to installing though. .bashrc is empty.
User avatar
shane
Level 5
Level 5
Posts: 940
Joined: Sun Feb 25, 2007 11:15 pm
Contact:

Re: Linux Mint 8 RC1 Bug Thread

Post by shane »

I am not sure, but it probably used the older bcm43xx (or something like that) driver which is being replaced with the newer b43 driver... I think the bcm43xx driver has been removed from the kernel in favor of b43. My Broadcom card never worked with the old driver, but it works with b43. Anyway, I am not sure about the whole thing.... I could be wrong. All I know is that the b43 driver cannot be redistributed.
User avatar
shane
Level 5
Level 5
Posts: 940
Joined: Sun Feb 25, 2007 11:15 pm
Contact:

Re: Linux Mint 8 RC1 Bug Thread

Post by shane »

primski wrote:Hello,

installed Mint 8 RC 1 today on Inspiron 1525 and have a problem with grep
grep is installed here. No problems...
primski
Level 1
Level 1
Posts: 24
Joined: Fri Nov 13, 2009 1:22 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by primski »

shane wrote:
primski wrote:Hello,

installed Mint 8 RC 1 today on Inspiron 1525 and have a problem with grep
grep is installed here. No problems...
nono, it *is* installed on my system too, no problem there. just piping doesnt work.

or better, i found this thread

http://ubuntuforums.org/showthread.php?t=903177

and if i do 'ps ax |grep firefox' it works just fine (note no space after pipe)

it seems it's a problem with locale. i think i have deafult locale set, language is english, i only selected keyboard layout as Slovenian and CET timezone.

Seems like a bug though.

edit: here's the bug report https://bugs.launchpad.net/ubuntu/+bug/218637
Last edited by primski on Fri Nov 13, 2009 1:47 pm, edited 1 time in total.
scottjge
Level 4
Level 4
Posts: 250
Joined: Sun Sep 13, 2009 8:17 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by scottjge »

Thanks for the info Shane. I guess I will stay with Mint 7.
User avatar
gees
Level 1
Level 1
Posts: 27
Joined: Sun Jul 05, 2009 2:19 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by gees »

Not all real bugs, but nevertheless: I tested the installed version on Dell Latitude E6400 on external USB-HDD :

1) Pressing "enter" in boot-menu to start the highlighted choice (mint8) takes a few minutes wait and nothing visible happens.

2) The text in the welcome screen shifts when this screen is switched from background to foreground when multiple windows are opened.

The login screen is plain ugly and some functions, like restart etc., are now "hidden" in the lower right corner of the screen.
The rotating small balls... please get rid of them. I know, some stuff is coming from karmic and has to be dealt with.
I proudly demonstrated Gloria to windows user, who mostly then installed Mint Gloria, but this looks bad, sorry to say.
I'm missing elegance.
"The web was made for sharing ..."
User avatar
shane
Level 5
Level 5
Posts: 940
Joined: Sun Feb 25, 2007 11:15 pm
Contact:

Re: Linux Mint 8 RC1 Bug Thread

Post by shane »

After a few reboots wireless works! I didn't modify any settings... this time I logged in, it asked for the passphrase, tried to connect, failed, tried again and connected. It didn't do this before. It would directly try to connect and fail... then I would mess around with it. Oh well, false alarm I suppose. My bad.
User avatar
belovedmonster
Level 5
Level 5
Posts: 640
Joined: Thu Dec 21, 2006 12:34 pm

Re: Linux Mint 8 RC1 Bug Thread

Post by belovedmonster »

Why is Xchat in the favourites list but Pigeon is not? 'Average' computer users are going to be much more interested in IMing their buddies than hanging out in an IRC channel, and those who do wanna go in IRC know where to find Xchat.
Locked

Return to “Releases & Announcements”