Page 1 of 2

Linux Mint 8 x64 RC1 Bug Thread

Posted: Sat Dec 05, 2009 1:33 pm
by clem
This thread is dedicated to bug reports on Linux Mint 8 x64 Helena RC1. Please report bugs here and include necessary steps to reproduce the problems you describe.


Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Sun Dec 06, 2009 6:19 am
by johonunu
Here is what I found:
I don't like how gnome panels autohide. It's just like in Gloria. In Ubuntu 9.10 the autohide is much faster.
Also there are no bookmarks in firefox to linuxmintart, planet,...

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Sun Dec 06, 2009 7:22 pm
by BopNiblets
I think the theme of the login/gdm screen is wrong, it looks like the "Raleigh" control set.

Here's what it looks like:

I've also noticed the mintMenu getting stuck open sometimes clicking outside of it, but it's difficult to replicate, possibly when you change a Favourites menu item, like add a new one it gets stuck open.

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Sun Dec 06, 2009 9:05 pm
by milkyspit
Installed Linux Mint 8 x64 RC1 on my laptop, a Compaq Presario F572US with Nvidia GO 6100 integrated graphics and 3GB installed RAM. All in all, not bad. Here's what I've found so far, ranked highest to lowest in importance to me...

1. Suspend/resume doesn't quite work. If I close the laptop lid, wait a bit, then open it again, everything eventually wakes up (though it's slow doing so) but the display backlight comes on at minimum brightness, not the brightness it had been prior to suspend! If I have to readjust the backlight manually every time the laptop wakes from suspend, I'm going to go crazy... more importantly, I'll look for another distro that doesn't do that, or even revert to (gasp!) XP or Windows 7. (Note: I am not an OS zealot. Reasonably content with Mint, Ubuntu, CentOS, XP, and Windows 7, among others... but only if the OS plays nice with my hardware, and is fast and stable!)

2. I leave the hardware wireless switch on my laptop in the OFF position most of the time as I generally use a wired network... but Mint does not recognize this fact and turns on my wireless every time I restart, etc. Similar annoyance to #1 though not quite as annoying. If I have wireless switched off, I want the OS to remember it's supposed to be off! I need Mint to remember this detail, again to keep me from slowly going crazy.

3. Hung Software Manager while clicking quickly on a number of entries to look at their descriptions. Don't have a specific recipe on how to reproduce, sorry. Anyway, had to force quit the app.

4. Window borders are too touchy/narrow to grab and drag easily using a touchpad. Typically I have to attempt to grab the edge of the window 3-4 times as the cursor changes to the grab indicator, then as I'm in the process of clicking, changes back to the arrow pointer. This is annoying because the missed click usually ends up bringing the window beneath that one to the front of the z-order, then I have to bring the intended one back to the front... then repeat this process a few more times until I actually do manage to grab the window border to resize. Can this be made easier? Shouldn't require surgical precision to resize a window.

I very much want to see the above items addressed ASAP because I'd like to run Mint 8 x64 on this laptop! The above notwithstanding, there's a lot to like here, you guys have done a great job. Please fix my issues and I'll be a very happy camper!

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Mon Dec 07, 2009 2:16 am
by inchkape
j30d wrote:I have just installed Linux Mint 8 x64 RC1 i had 2 problems but it's no big problems when i was installing the extra gnome icon themes the package manager keep closing out on me i had install one package at a time , and the other bug is the system lock the system update keeps breaking the lock without any updates. This happens every time i open up the package manager.

Fresh Custom Build

Intel (Stoughton) G965 Motherboard
IntelĀ® GMA X3000 onboard graphics subsystem
8-channel (7.1) audio subsystem using the SigmaTel STAC9271D audio codec and Dolby Home Theater certification
Intel Pentium 4 3.4Ghz s775 Processor
6.5 GB of ram
320 GB Hard Drive
Isn't this normal behaviour? I believe an open padlock means there are updates available, but a broken padlock means the update manager couldn't check if there were updates available. This happens as a matter of course when either there is no internet connection OR when updatemanager can't access the package database. If you have the synaptic package manager open or the GDebi installer open (or are installing anything via apt-get) this will automatically be the case as two package installers can't be allowed simultaneous access.

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Mon Dec 07, 2009 5:50 am
by gripped

Upgraded from Mint 7 x64 with no major problems. Used the command line and at one point something , I think mint-meta-x64 depended on moonlight-silverlight-something :) but it was not going to be installed. I install the moonlight-silverlight-something and continued. All was well.

I like the Shiki-Wise theme but it makes Firefox, particularly the URL / awesome bar dropdown look ugly. blue text on a grey background. No Thanks!.

I have found a partial fix here:

Changes the dropdown background to white. A better solution would be to keep the background but change the colour of the blue 'link' text.

btw brilliant job.

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Mon Dec 07, 2009 6:31 am
by Silare Alvreon VI
Hi, all. I just installed the Linux Mint 8 Helena x64 RC on my Dell Inspiron 1520. So far, the following bugs have been sighted:

[01] [SOLVED] My trackpad goes completely unresponsive for about two seconds after I type anything into a textbox. If I type and then try to move my cursor on my screen with my trackpad, it will go unresponsive and I'll have to wait about two seconds before I can move my cursor again. This problem was also evident in Ubuntu Karmic.

Thanks to help from proxima_centauri from the Mint IRC channel however, this was solved. By typing the following Terminal command, the trackpad/cursor behaviour returns to normal:

syndaemon -t -i 0.00000000001 -d

(If it doesn't, lower the value of the number after -i and before -d.)

[02] I have no sound coming from my speakers anymore. They aren't muted in alsamixer, but they have no sound. I can get sound by plugging in headphones, but even that causes problems to a certain level. This problem seems exclusive to Mint Helena.

[03] When I do have sound, it only exists through headphones. In this case though, I have to turn my sound up to about 1/3 before I can hear anything, and by then it blasts into my ears really loudly. Any configurations I make in alsamixer get automatically reverted to the original if I touch the audio buttons at the bottom of my laptop or if I touch the master volume at all. The only way I can remedy this is to turn every sound setting for every app I use down, which is really a pain to do. This problem was also evident in Ubuntu Karmic.

[04] My GDM looks Windows 98-ish in terms of the GTK widgets being drawn. Is there a way I can configure how I want my login window to look (not just how it behaves, a la Login Screen from the mintMenu)?

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Mon Dec 07, 2009 7:39 am
by Husse
I think there will be a fix for the GDM problem


Posted: Mon Dec 07, 2009 2:05 pm
by JanG

- Not possible to close Frostwire
- Printscreen button on keyboard does not work

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Mon Dec 07, 2009 2:43 pm
by Seventh Reign
The Frostwire issue is common with ALL Linux Distros. You must go to your options and switch it to "Shutdown Immediately" instead of "Shutdown when Transfers are Complete". Its a Linux bug that has existed for several years, that hasnt been fixed yet.

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Mon Dec 07, 2009 2:48 pm
by vmeiste

I have a Dell Isspiron 1501 (AMD Turon 64 x2) laptop. For the most part this release is very stable on my system. One bug I've found is the Suspend/Resume function. The system suspends fine, but when trying to resume, the resume screen will display requesting my password. After entering the password the cursor changes to a "busy" status and the system does not do the resume/signon. It just sits there locked up with the cursor in a busy status. My disk activity light does not blink. No disk activity. The same situation occurs when I try to hibernate and then resume. This happens every time. All key strokes are ignored. The only way out of the locked system with the busy cursor is to power cycle the system.


Installation Issue

Posted: Tue Dec 08, 2009 2:24 am
by Johnny_Kage
I am running the install through a USB Flash drive.

I had Mint 7 x64 installed on sda with customized partitions. I had sdb as a backup drive. So I copied my Home folder to sdb.

sda and sdb are Seagate SATA 2 500 gb 7500 rpm hard drives. The motherboard is a zotac with nVidia 8100 chipset. I have 4GB 1GHz ram. The processor is AMD Phenom x4 64-bit

When I first installed Mint i set up the two hard drives to be a mirror raid in the bios, but kept getting a grub error, so i changed the control back to eide and removed the second drive from the raid settup.

Now when I try to install mint 8 either through a direct install at the first menu, or from within the live version, i cannot install onto sda. When it gets to the gpartition (step 4) it doesn't have the pull down menu. I cannot select anything other than sdb. At first i thought this was because Mint 7 was on sda, so i used gparted within Live to wipe it and set up new tables... still nothing. i've even tried with it totally blank and no partitions set up. I've tried with the drives mounted and not mounted... nothing. It only sees sdb. Even when i choose custom in step 4, it doesn't allow me to select another drive. :cry:

______________UPDATE: 12/08/2009______________________________________________________________________
Since you suggested the issue was with Ubuiquity, I searched the Ubuntu support forum and found that there are others with the problem ... hard+drive

Here is the suggested fix:

1) Boot into live session with Live CD (without installing)
2) Open a Terminal and run "sudo apt-get remove dmraid"
3) Exit the Terminal and start the Installer by double-clicking on its icon

I will try this tonight and let you know.

___2nd Update________________________________________________________________________________________
Bad news and good news. The above suggestion did not work...

However, I went into gparted and formated the drive as ntfs. Then ran the install program and WALA! it showed up. WOO HOO! :D

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Tue Dec 08, 2009 5:36 am
by Husse
I have seen this behavior reported for the 32 bits version in the most recent case no partitions at all were seen - seems to be a bug with Ubuiquity

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Tue Dec 08, 2009 3:22 pm
by Mutiny32
Well, on the update manager, I'm getting a failure to hit a lot of the mint apt repos, I can't rember what the exact name of the repository on your servers it was failing on, but I want to say "Romeo" or something along that line. Also, I am getting some issues with icons; the seem to be reverting to the Windows 3.1-ish style of plain gray icons as well as gnome menus. I haven't rebooted yet, so that may be it.

May I ask what exactly the "Gnome Composting" checkbox does in the Desktop Configuration Tool? Should that option be visible with other things handling desktop effects?

And may I suggest that you allow reviews to be made directly in the Software Manager as well as include the description on the main window when any given software package is selected? As of now, you have to click More Info to see what a lot of the stuff actually does. That really reduces user appeal and increases the annoyance factor for users when they have to click another button to see what a lot of software does.

Oh, and your backgrounds don't look pretty on dual-monitor configurations as the logo or text gets split in half, but that's not a really "fixable" issue.

Otherwise, keep up the great work! Perhaps using something like Launchpad could help in identifying problems better. If you use something other than these forums already, excuse my ignorance. :D

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Tue Dec 08, 2009 4:30 pm
by dlowe
I've never tried Linux Mint before, but I've got a lot of experience with various other distributions of Linux. I attempted to install the x64 RC version onto a Dell M1330 by burning to a CD. Booting failed at ISOLINUX complaining about not finding the kernel 'linux'. Typing casper/vmlinuz resulted in a 'Corrupt or missing kernel' message. I never got past that.

The BIOS configuration didn't have any relevant-looking options. The burned CD and the ISO file had matching checksums. I'm pretty stumped. :/

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Tue Dec 08, 2009 7:47 pm
by Husse
That must be an error in the CD one way or the other.....

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Tue Dec 08, 2009 7:58 pm
by Johnny_Kage
Husse wrote:I have seen this behavior reported for the 32 bits version in the most recent case no partitions at all were seen - seems to be a bug with Ubuiquity
The bizarre thing is that it saw all the partitions for sdb and would even let me customize them if I desire...

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Tue Dec 08, 2009 8:14 pm
by Husse
Unfortunately this is a part where we rely heavily on Ubuntu
Ubiquity is a good installer but has always (?) had problems in the partitioning sector

Re: Linux Mint 8 x64 RC1 Bug Thread

Posted: Wed Dec 09, 2009 1:46 am
by distro hopper
I've noticed a problem with using Synergy to share a keyboard and mouse between 2 computers. The Mint 8 x64 machine is running the server, the other machine is running a custom-minimal Ubuntu 9.10 with X.

Ever since I upgraded to Mint 8 x64 RC1, I have had problems with my shift keys and arrow keys when using them on the client computer. The shift keys don't seem to work, and when I use the UP Arrow in a terminal to scroll through my command history it types a capital A.

I have tried this with a Kubuntu 9.10 (x64) install and not had this problem. It seems to be mint-specific.

Mouse Freezes

Posted: Wed Dec 09, 2009 5:58 am
by Johnny_Kage
At random times the mouse will freeze up. Only way I know to solve it is to close everything vai the keyboard and then ctrl-alt-del restart.


Zotac AMD MB with nVidia 8100 chipset
4GB 1GHZ ram
AMD Phenom x64 Quad 2.3 MHZ processor
(2) Seagate Sata 2 500 GB 7500 RPM Hard Drives
Dell USB Wired Mouse
Dell Keyboard

I had this problem in Mint 7 x64, only it appeared to happen worse (mpre often). It also happened with two different mice.