webcam not working

Forum rules
Before you post please read how to get help
leandro.cassa
Level 1
Level 1
Posts: 2
Joined: Wed Sep 04, 2013 8:06 am

webcam not working

Postby leandro.cassa » Wed Sep 04, 2013 8:52 am

Hi Folks,

I've been seeking a solution for 2 days now regarding my webcam. My conclusion until now is that the module for uvcvideo and gspca are just not there, but lets start from the beginning.
I went to gstreamer-properties on the video tab and tried to click on test, this is the error I get "Video for Linux 2 (v4l2): Cannot identify device '/dev/video0'."
On the terminal I get:

Code: Select all

Cannot identify device '/dev/video0'. [v4l2_calls.c(493): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src1:
system error: No such file or directory]


So I thought my driver was in trouble and I ran lsusb to see if the camera was there:

Code: Select all

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Bus 001 Device 004: ID 04f2:b221 Chicony Electronics Co., Ltd integrated camera
Bus 002 Device 003: ID 17ef:1003 Lenovo Integrated Smart Card Reader

As you can see it is an integrated camera, I checked a bunch of forums and it seems there was some people with problems due to their kernel version, so just FYI:

Code: Select all

uname -r
3.2.0-4-686-pae


I learned that uvcvideo and gspca are the generic drivers for webcams so I tried:

Code: Select all

modprobe uvcvideo
libkmod: ERROR ../libkmod/libkmod-module.c:174 kmod_module_parse_depline: ctx=0xb92b6008 path=/lib/modules/3.2.0-4-686-pae/kernel/drivers/media/video/videodev.ko error=No such file or directory
libkmod: ERROR ../libkmod/libkmod-module.c:174 kmod_module_parse_depline: ctx=0xb92b6008 path=/lib/modules/3.2.0-4-686-pae/kernel/drivers/media/video/videodev.ko error=No such file or directory
ERROR: could not insert 'uvcvideo': Unknown symbol in module, or unknown parameter (see dmesg)

and

Code: Select all

modprobe gspca
FATAL: Module gspca not found.

Although

Code: Select all

locate gspca
/usr/src/linux-headers-3.2.0-2-486/include/config/usb/gspca
/usr/src/linux-headers-3.2.0-2-486/include/config/usb/gspca.h
/usr/src/linux-headers-3.2.0-2-486/include/config/usb/gspca/benq.h
/usr/src/linux-headers-3.2.0-2-486/include/config/usb/gspca/conex.h
/usr/src/linux-headers-3.2.0-2-486/include/config/usb/gspca/cpia1.h
/usr/src/linux-headers-3.2.0-2-486/include/config/usb/gspca/etoms.h
/usr/src/linux-headers-3.2.0-2-486/include/config/usb/gspca/finepix.h
<the list goes on and on...>



Code: Select all

locate uvcvideo
/usr/include/linux/uvcvideo.h
/usr/src/linux-headers-3.2.0-2-common/include/linux/uvcvideo.h
/usr/src/linux-headers-3.2.0-4-common/include/linux/uvcvideo.h


Since I was missing videodev.ko, then I tried:

locate videodev.ko
No results here...

Well, I'm not an expert but it seems to me the module files related to the webcam support are missing. Can someone help me out here?

gordintoronto
Level 3
Level 3
Posts: 106
Joined: Sat Aug 01, 2009 11:58 pm

Re: webcam not working

Postby gordintoronto » Thu Sep 05, 2013 9:26 pm

What version of Mint are you using? I run Mint 13, and my kernel is 3.2.0-52.

If you are using Mint 12, it expired several months ago. If you are using Mint 13, you should keep it updated.

leandro.cassa
Level 1
Level 1
Posts: 2
Joined: Wed Sep 04, 2013 8:06 am

Re: webcam not working

Postby leandro.cassa » Tue Sep 24, 2013 4:44 pm

I'm running 13 I guess...

$ cat /etc/issue
Linux Mint Debian Edition \n \l

$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:core-4.1-ia32:core-4.1-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:cxx-4.1-ia32:cxx-4.1-noarch:security-4.0-ia32:security-4.0-noarch:security-4.1-ia32:security-4.1-noarch
Distributor ID: LinuxMint
Description: Linux Mint Debian Edition
Release: 1
Codename: debian

$ cat /etc/lsb-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=1
DISTRIB_CODENAME=debian
DISTRIB_DESCRIPTION="Linux Mint Debian Edition"

I'm not 100% sure though, and I just did a big upgrade and my kernel version is still the same and no efforts I did got my camera working.

Thanks in advance

gordintoronto
Level 3
Level 3
Posts: 106
Joined: Sat Aug 01, 2009 11:58 pm

Re: webcam not working

Postby gordintoronto » Tue Sep 24, 2013 5:09 pm

I'm sorry, I have never used Linux Mint Debian Edition. I think it is a semi-rolling release, so Mint's version numbers do not apply.

I'm surprised the kernel stayed the same, it's very old. I was going to suggest a method to upgrade, but first I Googled: lmde kernel upgrade. I didn't find anything encouraging.

You might try running Mint 15 from a LiveUSB or DVD, and see if Cheese will display your mug.


Return to “Others”

Who is online

Users browsing this forum: No registered users and 1 guest