How do I switch to Gnome in Mint 17?

Forum rules
Before you post please read how to get help
Post Reply
Raident
Level 1
Level 1
Posts: 42
Joined: Sat Jan 28, 2012 9:48 pm

How do I switch to Gnome in Mint 17?

Post by Raident » Mon Jun 23, 2014 4:14 am

One of the first things I noticed after upgrading from Mint 13 to 17 is that the login screen no longer has an option to change sessions. How do I switch from Cinnamon to Gnome 3?

User avatar
txba516
Level 3
Level 3
Posts: 197
Joined: Fri Aug 10, 2007 11:57 am
Location: Atlanta, GA

Re: How do I switch to Gnome in Mint 17?

Post by txba516 » Mon Jun 23, 2014 12:09 pm

Hi Raident,

Mint 17 set a couple of defaults for the login screen that hide the session selection and the user list (if more than one user exists). I tested undoing these auto-defaults and this allows you to then choose the user and the session type (Desktop environment) at the login screen again.

In the Menu -> Administration -> Login Window app, go to the Options tab and uncheck the two boxes for "Default Session" and "Automatically select last logged in user".
Click the Close button. When you next log out of Mint or restart it, the login screen will list the configured users on the box and next to the country flag (for language) there is now a gear sprocket icon. Click on it and choose your desktop to use for this login session.

Cheers!
LM17.2 x64 Cinnamon
Help the forums get answers faster! Mark your fixed problem thread as [SOLVED]

Raident
Level 1
Level 1
Posts: 42
Joined: Sat Jan 28, 2012 9:48 pm

Re: How do I switch to Gnome in Mint 17?

Post by Raident » Tue Jun 24, 2014 1:20 am

Hmm, I unchecked the 2 checkboxes and then rebooted. Now, when I click on the gear icon, nothing happens. If I then select a username from the list, the gear icon changes to a Greek lambda symbol. Not sure what's going on...

Raident
Level 1
Level 1
Posts: 42
Joined: Sat Jan 28, 2012 9:48 pm

Re: How do I switch to Gnome in Mint 17?

Post by Raident » Tue Jun 24, 2014 1:30 am

Ok, so after forcing Cinnamon to run in software rendering mode, the gear icon on the login screen is now clickable - except that the only options are "Last", "Run Xclient script", "Cinnamon" and "Cinnamon (Software Rendering)".

Is Gnome 3 no longer included with Mint? What package(s) do I need to install to get it back?

Riko
Level 3
Level 3
Posts: 129
Joined: Fri Dec 09, 2011 9:10 am
Location: Hamburg, Germany

Re: How do I switch to Gnome in Mint 17?

Post by Riko » Tue Jun 24, 2014 2:56 am

installing gnome-shell and gnome-session should do the trick!

Post Reply

Return to “Others”