LXDE screen "locks" with square cursor unlocks with click

Forum rules
Before you post please read how to get help
Post Reply
k1ypp
Level 1
Level 1
Posts: 24
Joined: Fri Aug 15, 2014 11:45 am

LXDE screen "locks" with square cursor unlocks with click

Post by k1ypp » Tue Feb 09, 2016 5:17 pm

I can't really describe this properly. I've installed LXDE on an older Toshiba Satellite A45-S150 and everything looks good. However, if I let it sit a while with an application running (haven't tried it without yet) after some time, maybe 1/2 hour, the screen "locks" and changes the mouse cursor. The application (FLdigi) appears to keep running fine. All I have to do is click the mouse and the application windows slightly resizes and everything is running normally. Note: this is an update to the original posting: It does not seem to exhibit this behavior when there are no applications running. I've never seen this behavior on any of my other Linux versions or systems, so I don't think it is application related. I'll try another app, just to be certain.

It almost acts as if there is some sort of screen saver or power saver feature running and it times out. When the cursor changes it changes to a small square with an "X" inside. The application looks as if it resizes to fill the screen up to the task panel. I've included a screen shot I took with my camera. I've turned off the screen saver, at least I think I have, the menus seem to have several things that could shut the display off. In any case, none has stopped this behavior. Any ideas?
Image

Desktop Environment LXDE (Lubuntu)
Distribution Ubuntu 14.04.3 LTS
Kernel: Linux 3.13.0-77-generic (i686)
Dennis

k1ypp
Level 1
Level 1
Posts: 24
Joined: Fri Aug 15, 2014 11:45 am

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by k1ypp » Wed Feb 10, 2016 9:15 am

The application doesn't seem to matter. I left the printer add program up on the screen and when it timed out, it expanded it to full screen and then went into the pseudo lock mode. I need to time exactly how long it takes before it kicks in.

Dennis

k1ypp
Level 1
Level 1
Posts: 24
Joined: Fri Aug 15, 2014 11:45 am

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by k1ypp » Thu Feb 11, 2016 12:10 am

Incidentally, I have tried a dozen times to register and log into the http://lxde.org/ forum and have never been successful. Is that forum/site actually running and in use?
I originally wanted to ask the question I've posed here but was never able to activate my account and do so.

Dennis

Hoser Rob
Level 11
Level 11
Posts: 3660
Joined: Sat Dec 15, 2012 8:57 am

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by Hoser Rob » Thu Feb 11, 2016 2:03 pm

According to your first post you are running Lubuntu 14.04. I used LXDE until recently on my netbook which now has 17.3 Xfce. But I installed lxde as a package via synaptic ... there is no officially supported LXDE version of Mint.

Have you tried ubuntuforums?

User avatar
daveinuk
Level 7
Level 7
Posts: 1545
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.
Contact:

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by daveinuk » Thu Feb 11, 2016 2:22 pm

This won't help . . . . . . but I've had exactly the same thing happen on an old Dell Inspiron and no one here knew, I was pointed to the LXLE forums by folks here and from an LXLE facebook group, I've tried all screensaver settings off and all power management settings off and still the thing happens, I really didn't want to have to sign to yet another forum to get 1 question answered and never visit again, so if you cure it, please post back and put me out of my misery lol :lol:

k1ypp
Level 1
Level 1
Posts: 24
Joined: Fri Aug 15, 2014 11:45 am

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by k1ypp » Thu Feb 11, 2016 4:33 pm

First of all, thanks to both of you for responding. I was starting to feel like that tree in the forest: Did anyone hear it fall?

Hoser Rob: I suspect you have unveiled that fact that I am a total novice in the world of Linux. I didn't realize that the LXDE version wasn't even part of Linux Mint. The complex web of varieties of Linux is bewildering and I'm never certain of which version goes with which flavor. The lines of demarcation are not clear. Can you suggest an Ubuntu forum that would best suit this question? I'll gladly take it there.

daveinuk: It is comforting to know that I am not alone, someone else has actually seen this. Truly, it is a weird symptom. Like yourself, I've looked for every timer that I could think of and to no avail. It would seem obvious, like a power battery saver timer or screen saver timer. It doesn't seem to kick in unless there is something actually running on the desk top. That "something" doesn't appear to matter, it can be some resident app that comes with the install, such as a tool to control the network connections, or an installed app, such as the FLdigi ham radio app that I'm using.

If I do eventually find a solution I will make note of it here.

Again, thanks to both of you.

Dennis

k1ypp
Level 1
Level 1
Posts: 24
Joined: Fri Aug 15, 2014 11:45 am

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by k1ypp » Thu Feb 11, 2016 11:04 pm

Incidentally, I should have included the screen shot of what the cursor looks like when it goes into this state. I had to take this with a camera since I cannot click on the screen to do a screen shot.

Image

http://dennisandjane.org/photos/20160209_150248-320.jpg

I don't know why but the Image code isn't working.

The square in the open space is the cursor. Once clicked on, it changes back to the normal arrow cursor.

Dennis

k1ypp
Level 1
Level 1
Posts: 24
Joined: Fri Aug 15, 2014 11:45 am

Solve: LXDE screen "locks" with square cursor unlocks with c

Post by k1ypp » Fri Feb 12, 2016 11:54 am

Victory! I finally figured it out. I started the Task Manager, in the System Tools. Looking over the processes running, I saw that Xscreensaver was still running, even though I had selected "disable." Something told me that wasn't the problem, if didn't act like a screen saver and the default was set to 45 minutes (grayed out). The screen would "lock" in about ten minutes.

Further down, I saw a process called XAutolock. That sounded suspicious. I hunted around on Google and found that it is supposed to be a tool to allow the owner to "lock" the screen so a password can be used to allow access to the system. It appears that by default this process runs and sorta locks the screen, but a simple mouse click unlocks it. Worthless? Yes

I right clicked on the process in Task Manager and selected "stop." The problem ceased. Of course the next time the system is booted the process will start again.

To remedy this, I went into the Synaptics Package Manager and searched on "XAutolock," and right clicked on it and told it to totally remove it. I suppose I could have done the partial remove as well, but figured I never need it again.

It fixed the problem, no more phantom locks.

Thanks everyone for the help. I feel like Einstein coming up with the Theory of Relativity. Such is the realm of a newbie.

Habitual
Level 13
Level 13
Posts: 4871
Joined: Sun Nov 21, 2010 8:31 pm
Location: 0.0.0.0

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by Habitual » Fri Feb 12, 2016 12:09 pm

Good job and well done!

User avatar
daveinuk
Level 7
Level 7
Posts: 1545
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.
Contact:

Re: LXDE screen "locks" with square cursor unlocks with clic

Post by daveinuk » Fri Feb 12, 2016 12:10 pm

** Rushes off to shed to kill the process on the laptop! **

You sir are the greatest noob that ever graced the forums lol !

I'm gonna hold my hands up and say that it never occurred to me to go poking around processes and I was too lazy to join the forum to ask one question as that laptops just in the shed outside and only ever gets used when the weathers nice enough for tinkering, everywhere I've mentioned it I've been met with funny looks like I've made it up or made an improper suggestion so I'm glad it wasn't my imagination! All credit to you for having a good poke around, you're a star! Cheers :lol:

Post Reply

Return to “Others”