[Solved] LXDE missing from session options in MDM

Forum rules
Before you post please read how to get help
User avatar
ginjabunny
Level 3
Level 3
Posts: 144
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

[Solved] LXDE missing from session options in MDM

Postby ginjabunny » Sat Oct 15, 2016 9:48 am

Hi,

Rather than install Lubuntu-desktop (and all the baggage that comes with it) I thought I'd have a look at vanilla LXDE for and older PC, so I installed Mint 18 Cinnamon 64bit, installed all the updates, then LXDE from the software manager, when I logout/reboot I cannot choose LXDE at logon as it does not appear in the pull down list of sessions on MDM. I checked the Login Window control app anf it's not listed in there either, I presume there is a config file somewhere that's hasn't been added to and as I don't know the syntax of what to add I'm at a bit of a loss.

I tried it on my laptop too and that is the same.

Any idea how to get it added?
Last edited by ginjabunny on Sat Oct 15, 2016 2:32 pm, edited 2 times in total.

User avatar
Flemur
Level 13
Level 13
Posts: 4639
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: LXDE missing from session options in MDM

Postby Flemur » Sat Oct 15, 2016 10:54 am

This might help:
viewtopic.php?t=225089
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
ginjabunny
Level 3
Level 3
Posts: 144
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

Re: LXDE missing from session options in MDM

Postby ginjabunny » Sat Oct 15, 2016 11:36 am

@Flemur, there is nothing in that post to help me, is says the same as mine but with no resolution.

Been hunting around and I think there should be some .desktop files for LXDE and/or Openbox in /usr/share/xsessions, just need to find out what they should be.

User avatar
ginjabunny
Level 3
Level 3
Posts: 144
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

Re: LXDE missing from session options in MDM

Postby ginjabunny » Sat Oct 15, 2016 2:19 pm

Figured it out, it seems just installing LXDE from Software Manager does not install everything, importantly things like openbox and lxsession are missing, so I uninstalled lx* everything via Software Centre then closed it, started synaptic and picked the lx* packages that looked important, when I picked lxde-common (which wasn't installed with lxde in software manager) and it said it was also installing openbox, this created the missing xsession files that appear in mdm, so logged in using lxde session and it all seems to be working


Return to “Others”