Page 1 of 1

LightDM failing to start (until manually restarted)

Posted: Thu Sep 14, 2017 1:17 pm
by Dakiraun
I have Mint 18.2 running on a bunch of systems at work and home. They were all upgrade from Mint 18.1. When upgrading, Mint continues to use the MDM display manager, and I wanted to switch them to using LightDM. I saw this post ( viewtopic.php?f=208&t=253632&p=1365999& ... M#p1365761 ) mentions how to get LightDM and its required components installed and switch.

I did this for three systems so far, but it only worked on one. The other both do the same thing - fail to load up LightDM, remaining only on the text based terminal. If you log into the terminal and restart the lightDM service ("sudo service lightDM restart"), then it comes up just fine. The question is, why doesn't it come up correct the first time?

In troubleshooting it, I have tried deleting the /etc/conf/lightdm/lightdm.conf file (didn't help) as well as checking the log output from LightDM in the /var/logs/lightdm directory. Problem is... it doesn't write any logs at all until the service is restarted.

Hardware wise, the three machines are very different - one's an old Pentium M with an IDE SSD (that's the one that works), one is a 3rd gen i5 Ultrabook with two SSDs, and the last is a 2nd gen i5 notebook with a 500g mechanical drive. I don't think hardware plays into this for the most part, other than the one significant difference being that the old Pentium M system is 32 bit, whereas the others are 64 bit.