X-Server Fails on Switch User

Forum rules
Before you post please read how to get help
ShadowMessiah
Level 1
Level 1
Posts: 18
Joined: Fri Nov 24, 2017 11:53 am
Location: Everywhere

X-Server Fails on Switch User

Postby ShadowMessiah » Fri Nov 24, 2017 12:04 pm

Everytime I try to switch users, I get a notification that states: "The X Server Failed. Perhaps it is not configured properly". Any ideas why?

I also have problems logging back in after I log-out a user. I have to reboot. It will state that the password is bad, but shutting down and rebooting, then logging in with the same password works fine.

I'm using the fglrx driver for AMD. I'm using a R7 370. Specifically because the x-server driver offers awful resolutions. It also fails to detect my second monitor as anything more then a generic monitor offering it only a max resolution of 1024 x 768. I specifically need resolutions of 1600 x 900 and 1440 x 900 for my two monitors.

P.S. I'm on Mint 17.3.

ShadowMessiah
Level 1
Level 1
Posts: 18
Joined: Fri Nov 24, 2017 11:53 am
Location: Everywhere

Re: X-Server Fails on Switch User

Postby ShadowMessiah » Sun Nov 26, 2017 10:40 am

So no way to fix this? Other than to stop using Mint.

User avatar
administrollaattori
Level 12
Level 12
Posts: 4391
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: X-Server Fails on Switch User

Postby administrollaattori » Sun Nov 26, 2017 1:33 pm

Change the login window to bare GTK.

mdmsetup.png

ShadowMessiah
Level 1
Level 1
Posts: 18
Joined: Fri Nov 24, 2017 11:53 am
Location: Everywhere

Re: X-Server Fails on Switch User

Postby ShadowMessiah » Mon Nov 27, 2017 12:24 pm

Unfortunately, there seems to be little change. It'll work for about 2 hours, but still reverts back to the same problem after about 2 hours.


Return to “Others”