Overhead projected screen shows only wallpaper

Forum rules
Before you post please read how to get help
Post Reply
frisket
Level 1
Level 1
Posts: 11
Joined: Thu Dec 07, 2017 7:26 pm

Overhead projected screen shows only wallpaper

Post by frisket » Tue Jan 16, 2018 4:16 pm

I took a new Dell XPS 15 into class today to use in teaching. It's running Cinnamon (no MS Windows), and has XFCE and Enlightenment as well. I plugged it into the projector cable, as I have done for years with a variety of other laptops old and new, using the Dell-supplier VGA connector, and the projector picked up the signal OK and displayed...the wallpaper. No icons, no applications, no dock, no shelf, no taskbar, and when I fired up Chromium, it started on the laptop screen but nothing appeared on the projected image. Very pretty wallpaper, but nothing else.

I logged out and switched to the other window managers in turn and got exactly the same results, so it appears to be independent of the WM. I'm not an expert in computer-to-projector connection except that experience shows that projectors are the worst-designed and most obtuse interfaces in existence :-) which is why I was pleasantly surprised that it even recognised the laptop.

But I have no clue why nothing else was visible: I thought the signal sent down a VGA output was a composite video-style signal, in effect a bitmap of the screen, so the projector needs no intelligence, and simply has to reproduce the coloured dots. Clearly I am missing something here, but I don't know what.

User avatar
all41
Level 13
Level 13
Posts: 4857
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Overhead projected screen shows only wallpaper

Post by all41 » Tue Jan 16, 2018 4:18 pm

Try this,
Navigate to settings for Display and enable Same image in all monitors
Proud to be a supporter and monthly contributor to Mint.

User avatar
AndyMH
Level 5
Level 5
Posts: 738
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Overhead projected screen shows only wallpaper

Post by AndyMH » Tue Jan 16, 2018 5:17 pm

Alternatively, press fn + F7 (or it might be F8 - varies by laptop, look at the little blue icons on the function keys). This will then enable you to toggle between:
  • laptop or projector only
    laptop and projector (same screen)
    projector as an extension to laptop (which is what it sounds like you've got).
If you go for both showing the same screen you will only get the resolution of the lowest res device.
Homebrew i5-8400+GTX1080 Cinnamon 19, Thinkpad T430 i7-3632 Cinnamon 19, Thinkpad T420 Cinnamon 18.3, Thinkpad T410 Cinnamon 17.3, Thinkpad T60 19.0 Mate

frisket
Level 1
Level 1
Posts: 11
Joined: Thu Dec 07, 2017 7:26 pm

Re: Overhead projected screen shows only wallpaper

Post by frisket » Tue Jan 16, 2018 7:23 pm

Thanks for the suggestions. Unfortunately ‘same in all monitors’ is already enabled, and pressing F8 had no effect.

rpbrown1952
Level 1
Level 1
Posts: 9
Joined: Mon Jun 06, 2016 12:55 am

Re: Overhead projected screen shows only wallpaper

Post by rpbrown1952 » Fri Nov 16, 2018 11:51 am

Have you been able to solve this problem? I've had the exact same experience with two different laptops; a Dell E6500 Latitude and a Toshiba Satellite. The Dell has an INVIDIA graphics adapter , the Toshiba has Intel graphics. I've got Mint 18.3 installed on both and I get the same thing you do. Pretty wallpaper, no desktop. I'm a teacher and have converted my entire classroom to Linux with the exception of a Win10 machine that I am forced to use for all my lessons, lectures, etc because of this issue with Mint and projectors. Very frustrating & I wish someone could help us figure this one out. I've already tried the suggestions shown here, they don't work.

User avatar
Flemur
Level 16
Level 16
Posts: 6191
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Overhead projected screen shows only wallpaper

Post by Flemur » Fri Nov 16, 2018 12:35 pm

rpbrown1952 wrote:
Fri Nov 16, 2018 11:51 am
The Dell has an INVIDIA graphics adapter
See if you can fix that one with

Code: Select all

sudo nvidia-settings
You might have to install it.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Post Reply

Return to “Others”