Mint 19 with GNOME 3.28 keyboard layout changes in non system apps

Forum rules
Before you post please read how to get help
Post Reply
URNAdream
Level 1
Level 1
Posts: 1
Joined: Sun Jul 01, 2018 3:37 pm

Mint 19 with GNOME 3.28 keyboard layout changes in non system apps

Post by URNAdream » Mon Jul 02, 2018 1:30 am

When I reboot or login and start non system apps they don't recognize my colmak layout and instead they revert qwerty. I have observed this happening in the following apps, google-chrome, firefox, VS Code, Spotify. This does not effect what I'm calling system apps like such as Nemo, Nautilus, gnome terminal, software manager or the search in the gnome activities overview. Any help?

I started chrome via terminal and recorded the output. I get errors in gnome and did not get them in cinnamon.

pelacables
Level 1
Level 1
Posts: 3
Joined: Fri Oct 19, 2018 8:15 am

Re: Mint 19 with GNOME 3.28 keyboard layout changes in non system apps

Post by pelacables » Tue Dec 11, 2018 4:54 pm

Hi URNAdream,

I'm facing the very same issue in my fresh installed LM19 Gnome 3.28. Thunderbird and firefox don't use the system layout whihc makes the system quite unusable. System defaults point to es layout:

Code: Select all

~$ localectl
   System Locale: LANG=es_ES.UTF-8
                  LANGUAGE=es_ES:ca:en_GB:en
       VC Keymap: n/a
      X11 Layout: es
       X11 Model: pc105
     X11 Variant: cat
     X11 Options: lv3:ralt_switch,terminate:ctrl_alt_bksp
~$ setxkbmap -query
rules:      evdev
model:      pc105
layout:     es
variant:    cat
options:    terminate:ctrl_alt_bksp
Did you find a solution/workaround to the issue?

Best,
Arnau

Post Reply

Return to “Others”