Tara: Low resolution when switching users

Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Sun Jun 10, 2012 5:17 am

Tara: Low resolution when switching users

Post by ithilion » Wed Sep 19, 2018 2:41 pm

Hello everyone!
My PC has two user accounts. Usually we work in turns without logout, simply switching our sessions via Ctrl+Alt+F7/F8. This worked well in Linux Mint 18 Cinnamon (Sarah gradually upgraded to Sylvia without re-installation) but not now.
Now I've installed LM 19 Tara Cinnamon (a clean installation, not an upgrade). When one starts a new session one sees a very low-res login screen (must be 640×480) and, after logging in, the second session starts with the same tiny display resolution and Cinnamon immediately crashes.
At the same time switching back to the first session (on tty7) restores it in FullHD resolution as it was left.
If the first user logs out completely, then the login screen remains FullHD and the second user can log in and work ok. So it is not user account but display management that fails. Somehow the normal display is reserved only for tty7 and all other sessions (tty8, tty9) start in a virtual display with only basic settings.

Here are xrandr outputs and display settings for the first and the second user session running in parallel:


(sorry for cropping, I don't get how to attach images larger than 640×480)

As you see in the second session the normal monitor is unavailable (the title 'Ноутбук' means 'Laptop', yet it's the same desktop PC with the same Samsung monitor attached) and so its resolution cannot be changed.
(I use Nvidia GT 240 GPU with the recommended driver, nvidia-340 (340.106-0ubuntu3) if it matters)

So I believe the problem is in LightDM. Previously I installed Sarah with MDM and during the upgrades it must have stayed in place.

So, the question. Is it a known problem? And can one fix it without bringing back MDM?

P.S. Previously, when I started Sylvia for the last time before re-installation I saw the same low-res desktop for the first user. I didn't bother to fix it as it was all ready for re-installation. Dunno what it has to do with the new installation.

Level 15
Level 15
Posts: 5838
Joined: Sun Aug 09, 2015 10:00 am

Re: Tara: Low resolution when switching users

Post by deepakdeshp » Wed Sep 19, 2018 5:09 pm

Please paste output of

Code: Select all

 inxi -Fxz
in code tags here.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Level 1
Level 1
Posts: 4
Joined: Sun Jun 10, 2012 5:17 am

Re: Tara: Low resolution when switching users

Post by ithilion » Wed Sep 19, 2018 5:13 pm

Code: Select all

System:    Host: cerebrum Kernel: 4.15.0-34-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Gigabyte product: H55M-USB3 serial: N/A
           Mobo: Gigabyte model: H55M-USB3 v: x.x serial: N/A
           BIOS: Award v: F10 date: 08/25/2010
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Performance MX status: Discharging
CPU:       Dual core Intel Core i3 540 (-MT-MCP-) 
           arch: Nehalem rev.2 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12265
           clock speeds: max: 3059 MHz 1: 2717 MHz 2: 2831 MHz 3: 2869 MHz
           4: 2728 MHz
Graphics:  Card: NVIDIA GT215 [GeForce GT 240] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) driver: nvidia
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GT 240/PCIe/SSE2
           version: 3.3.0 NVIDIA 340.106 Direct Render: Yes
Audio:     Card-1 NVIDIA High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 5 Series/3400 Series High Def. Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: ce00 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 3160.6GB (49.9% used)
           ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
           ID-2: /dev/sdb model: WDC_WD20EARX size: 2000.4GB
           ID-3: /dev/sdd model: SAMSUNG_HD160JJ size: 160.0GB
Partition: ID-1: / size: 37G used: 9.3G (27%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 197G used: 135G (73%) fs: ext4 dev: /dev/sdb1
           ID-3: swap-1 size: 10.20GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.0C mobo: N/A gpu: 0.0:62C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 243 Uptime: 4:19 Memory: 3328.7/7904.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Level 1
Level 1
Posts: 4
Joined: Sun Jun 10, 2012 5:17 am

Re: Tara: Low resolution when switching users

Post by ithilion » Sat Oct 06, 2018 2:48 pm

Hello again. I still have no solution but some updates.
That low resolution, 640×480, is the same in all TTYs, including tty1-6 in text mode.
To set TTY resolution one should edit GRUB config.
vbeinfo tells me that my PC doesn't support VBE compatible modes higher than 1280×1024
So when I set GRUB to 1280 x 1024 x 32 the resolution of my second session also increased to 1280×1024.
One more update. The problem disappears when using Nouveau driver instead of proprietary. Both sessions start in correct resolution and xrandr shows the correct display and settings. Yet it's not an option for me as nouveau works terribly on my PC.
Updating my drivers from ppa:graphics-drivers doesn't change a thing.

Post Reply

Return to “Others”