Cinnamon launcher only works with context 'open' command

Forum rules
Before you post please read how to get help
Post Reply
bobbalou135711
Level 1
Level 1
Posts: 5
Joined: Thu Apr 18, 2019 4:50 pm

Cinnamon launcher only works with context 'open' command

Post by bobbalou135711 » Thu Apr 18, 2019 5:13 pm

After an update of cinnamon on 3/28 my desktop launchers no longer respond to clicking (system launchers as well). They function if I use the context-menu 'open' command.

I tried another login on the system and those launchers still function normally. The functioning desktop is using out-of-box settings. I have reset the malfunctioning desktop to use the same settings but saw no change in behavior.

I have tried deleting and recreating a launcher. Same behavior.

I checked the .xsession-errors. I don't see anything associated with my 'click'ing. Does anyone have advice on how to troubleshoot?

Thanks in advance. :)

--Bob

User avatar
smurphos
Level 11
Level 11
Posts: 3721
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Cinnamon launcher only works with context 'open' command

Post by smurphos » Thu Apr 18, 2019 11:54 pm

Hi Bob,

First report the output of inxi -Fxz run in a terminal. Copy the output from the terminal and paste into your reply in between [code][/code] tags.

Second, open the Desktop folder in your File manager, right click on a problematic launcher and select open-with text editor copy the contents and paste back also between [code][/code] tags.

Is it all desktop launchers affected or just some? A list of which desktop launchers are affected may well be helpful.

You may as-well share your ~/.xsession-errors content aswell. Do it after a fresh login, click a few non-working launchers and then report the whole output. (again in between [code][/code] tags)
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

bobbalou135711
Level 1
Level 1
Posts: 5
Joined: Thu Apr 18, 2019 4:50 pm

Re: Cinnamon launcher only works with context 'open' command

Post by bobbalou135711 » Fri Apr 19, 2019 4:59 pm

Hi and thanks!

Code: Select all

bbowman@fandango ~ $ inxi -Fxz
System:
  Host: fandango Kernel: 4.18.0-17-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Gigabyte product: Z97X-SOC v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z97X-SOC-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F7 date: 09/18/2015 
CPU:
  Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 63855 
  Speed: 2395 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 2358 2: 2357 
  3: 2360 4: 2320 5: 2356 6: 2393 7: 2309 8: 2324 
Graphics:
  Device-1: NVIDIA vendor: Gigabyte driver: nvidia v: 418.43 bus ID: 02:00.0 
  Display: x11 server: X.Org 1.19.6 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 
  direct render: Yes 
Audio:
  Device-1: Intel 9 Series Family HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus ID: 02:00.1 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 3-6.4.2:10 
  Device-4: Logitech type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 3-6.4.3:11 
  Sound Server: ALSA v: k4.18.0-17-generic 
Network:
  Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 3.64 TiB used: 292.97 GiB (7.9%) 
  ID-1: /dev/sda vendor: Crucial model: CT256MX100SSD1 size: 238.47 GiB 
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  ID-3: /dev/sdc vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB 
  ID-4: /dev/sdd type: USB vendor: Seagate model: Expansion size: 931.51 GiB 
  ID-5: /dev/sde type: USB vendor: Samsung model: HD502HI size: 465.76 GiB 
Partition:
  ID-1: / size: 18.21 GiB used: 11.24 GiB (61.7%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 214.49 GiB used: 39.90 GiB (18.6%) fs: ext4 
  dev: /dev/sda4 
  ID-3: swap-1 size: 1.58 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 44 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 270 Uptime: 2m Memory: 15.58 GiB used: 1.17 GiB (7.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27
  

Code: Select all

bbowman@fandango ~/Desktop $ cat 'NetBeans (another copy).desktop'
[Desktop Entry]
Encoding=UTF-8
Name=Thunderbird Mail
Comment=Send and receive mail with Thunderbird
GenericName=Mail Client
Keywords=Email;E-mail;Newsgroup;Feed;RSS
Exec=/home/bbowman/netbeans/bin/netbeans
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=face-smile-big
Categories=Application;Network;Email;
MimeType=x-scheme-handler/mailto;application/x-xpinstall;
StartupNotify=true
Actions=Compose;Contacts
Name[en_US]=NetBeans
Comment[en_US]=Develop Software
GenericName[en_US]=Java IDE

[Desktop Action Compose]
Name=Compose New Message
Exec=thunderbird -compose
OnlyShowIn=Messaging Menu;Unity;

[Desktop Action Contacts]
Name=Contacts
Exec=thunderbird -addressbook
OnlyShowIn=Messaging Menu;Unity;
Yes all desktop launchers are affected. Toolbar works fine.

Code: Select all

bbowman@fandango ~ $ cat .xsession-errors
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
dbus-update-activation-environment: setting LANG=en_US.UTF-8
dbus-update-activation-environment: setting GDM_LANG=en_US
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting JAVA_HOME=/home/bbowman/java/jdk1.8.0_161
dbus-update-activation-environment: setting MANDATORY_PATH=/usr/share/gconf/cinnamon.mandatory.path
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/bbowman
dbus-update-activation-environment: setting USER=bbowman
dbus-update-activation-environment: setting DESKTOP_SESSION=cinnamon
dbus-update-activation-environment: setting DEFAULTS_PATH=/usr/share/gconf/cinnamon.default.path
dbus-update-activation-environment: setting PWD=/home/bbowman
dbus-update-activation-environment: setting HOME=/home/bbowman
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/cinnamon:/usr/share/gnome:/home/bbowman/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=cinnamon
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting IM_CONFIG_PHASE=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting SHLVL=1
dbus-update-activation-environment: setting LANGUAGE=en_US
dbus-update-activation-environment: setting MANPATH=/opt/OpenPrinting-Gutenprint/man:/opt/OpenPrinting-Gutenprint/man:/usr/local/man:/usr/local/share/man:/usr/share/man
dbus-update-activation-environment: setting GDMSESSION=cinnamon
dbus-update-activation-environment: setting LOGNAME=bbowman
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bq8dkwYPeg,guid=f605a6b4644493316962b21d5cba3424
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting XAUTHORITY=/home/bbowman/.Xauthority
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting XDG_CONFIG_DIRS=/etc/xdg/xdg-cinnamon:/etc/xdg
dbus-update-activation-environment: setting PATH=/home/bbowman/bin:/home/bbowman/.local/bin:/opt/linuxtrack/bin:/opt/OpenPrinting-Gutenprint/sbin:/opt/OpenPrinting-Gutenprint/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
dbus-update-activation-environment: setting _=/usr/bin/dbus-update-activation-environment
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
cinnamon-session[2297]: WARNING: t+0.02024s: Gsettings key org.gnome.Vino enabled could not be found!
Unknown option --size
[cinnamon-settings-daemon-smartcard] Failed to start: no suitable smartcard driver could be found
[cinnamon-settings-daemon-smartcard] Failed to start: no suitable smartcard driver could be found
cinnamon-session[2297]: WARNING: t+7.70599s: Failed to start app: Unable to start application: Failed to execute child process “dropbox” (No such file or directory)
cinnamon-session[2297]: WARNING: t+7.70779s: Failed to start app: Unable to start application: Failed to execute child process “/home/bbowman/Downloads/pcloud” (No such file or directory)
cinnamon-session[2297]: WARNING: t+7.70901s: Failed to start app: Unable to start application: Failed to execute child process “/usr/lib/nvidia-prime-applet/nvidia-prime” (No such file or directory)

** (nemo-desktop:2784): WARNING **: 16:48:43.890: Current gtk theme is not known to have nemo support (Cinnamox-Kashmir-Blue) - checking...

(nm-applet:2787): Gtk-WARNING **: 16:48:43.945: Can't set a parent on widget which has a parent
Cjs-Message: 16:48:43.995: JS LOG: About to start Cinnamon
Cjs-Message: 16:48:44.106: JS LOG: [LookingGlass/info] Cinnamon.AppSystem.get_default() started in 108 ms
Cjs-Message: 16:48:44.109: JS LOG: [LookingGlass/info] loading user theme: /home/bbowman/.themes/Cinnamox-Kashmir-Blue/cinnamon/cinnamon.css
Cjs-Message: 16:48:44.118: JS LOG: [LookingGlass/info] added icon directory: /home/bbowman/.themes/Cinnamox-Kashmir-Blue/cinnamon
Cjs-Message: 16:48:44.252: JS LOG: [LookingGlass/info] PlacesManager: Updating devices
St-Message: 16:48:44.257: cogl npot texture sizes SUPPORTED
Cjs-Message: 16:48:44.263: JS LOG: [LookingGlass/info] loaded at Fri Apr 19 2019 16:48:44 GMT-0400 (EDT)
Cjs-Message: 16:48:44.263: JS LOG: Cinnamon started at Fri Apr 19 2019 16:48:44 GMT-0400 (EDT)
Cjs-Message: 16:48:44.287: JS LOG: [LookingGlass/info] ExtensionSystem started in 2 ms
Cjs-Message: 16:48:44.287: JS LOG: [LookingGlass/info] SearchProviderManager started in 0 ms
openGL version 3.1 detected (GL3 Cogl Driver)
** Message: 16:48:44.368: nemo-desktop: session is cinnamon, establishing proxy
Cjs-Message: 16:48:44.414: JS LOG: [LookingGlass/info] Loaded applet user@cinnamon.org in 38 ms
Cjs-Message: 16:48:44.431: JS LOG: [LookingGlass/info] Loaded applet removable-drives@cinnamon.org in 16 ms
Cjs-Message: 16:48:44.438: JS LOG: [LookingGlass/info] Loaded applet show-desktop@cinnamon.org in 8 ms
Cjs-Message: 16:48:44.464: JS LOG: [LookingGlass/info] Loaded applet calendar@cinnamon.org in 26 ms
Cjs-Message: 16:48:44.504: JS LOG: [LookingGlass/info] Loaded desklet photoframe@cinnamon.org in 38 ms
Cjs-Message: 16:48:44.522: JS LOG: [LookingGlass/info] Loaded applet keyboard@cinnamon.org in 18 ms
Cjs-Message: 16:48:44.522: JS LOG: [LookingGlass/info] DeskletManager started in 238 ms
Cjs-Message: 16:48:44.530: JS LOG: [LookingGlass/info] Role locked: tray
Cjs-Message: 16:48:44.531: JS LOG: [LookingGlass/info] Loaded applet systray@cinnamon.org in 8 ms
Cjs-Message: 16:48:44.536: JS LOG: [LookingGlass/info] Role locked: notifications
Cjs-Message: 16:48:44.546: JS LOG: [LookingGlass/info] Loaded applet notifications@cinnamon.org in 16 ms
Cjs-Message: 16:48:44.591: JS LOG: [LookingGlass/info] Role locked: panellauncher
Cjs-Message: 16:48:44.594: JS LOG: [LookingGlass/info] Loaded applet panel-launchers@cinnamon.org in 48 ms
Cjs-Message: 16:48:44.608: JS LOG: [LookingGlass/info] Loaded applet power@cinnamon.org in 14 ms
Cjs-Message: 16:48:44.617: JS LOG: [LookingGlass/info] Loaded applet window-list@cinnamon.org in 8 ms

(csd-power:2426): power-plugin-CRITICAL **: 16:48:44.634: abs_to_percentage: assertion 'max > min' failed
Cjs-Message: 16:48:44.667: JS LOG: [LookingGlass/info] Loaded applet sound@cinnamon.org in 50 ms
Cjs-Message: 16:48:44.681: JS LOG: [LookingGlass/info] Loaded applet network@cinnamon.org in 12 ms
Cjs-Message: 16:48:44.985: JS LOG: [LookingGlass/info] Loaded applet menu@cinnamon.org in 304 ms
Cjs-Message: 16:48:44.986: JS LOG: [LookingGlass/info] AppletManager started in 724 ms
Cjs-Message: 16:48:44.987: JS LOG: [LookingGlass/info] Cinnamon took 992 ms to start
Cjs-Message: 16:48:44.999: JS LOG: Unknown network device type, is 14
Cjs-Message: 16:48:45.263: JS LOG: [LookingGlass/info] Hiding systray: network
Cjs-Message: 16:48:49.481: JS LOG: [LookingGlass/info] Adding systray: blueberry-tray.py (24x24px)
Cjs-Message: 16:48:49.481: JS LOG: [LookingGlass/info] Resized blueberry-tray.py with normalized size (24x24px)

** (nemo:3121): WARNING **: 16:49:28.018: Current gtk theme is not known to have nemo support (Cinnamox-Kashmir-Blue) - checking...
--Bob

User avatar
smurphos
Level 11
Level 11
Posts: 3721
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Cinnamon launcher only works with context 'open' command

Post by smurphos » Sat Apr 20, 2019 1:28 am

Does net beans open OK from the terminal?

E.g. running this command in the terminal

Code: Select all

/home/bbowman/netbeans/bin/netbeans
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

bobbalou135711
Level 1
Level 1
Posts: 5
Joined: Thu Apr 18, 2019 4:50 pm

Re: Cinnamon launcher only works with context 'open' command

Post by bobbalou135711 » Sat Apr 20, 2019 5:26 pm

Yes. They all work if I right click and select 'open'. They don't work if I double-click on them. The launchers high-light but do not fire.

User avatar
smurphos
Level 11
Level 11
Posts: 3721
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Cinnamon launcher only works with context 'open' command

Post by smurphos » Sun Apr 21, 2019 12:52 am

Mmm, a tricky issue.

A few more trouble-shooting steps.

Can you make a new launcher via right click on desktop > Create a new Launcher here and confirm the same thing happens with a fresh launcher (note the 4.10 Cinnamon update was solely to fix the bug that prevented this function working).

Does double click on any of the 'default' icons (.e.g. Home, Trash etc) work as expected?

Does find $HOME ! -user $USER -print run in a terminal produce any results?

Finally can you create a temporary new user account and check if that account has the same issue.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

bobbalou135711
Level 1
Level 1
Posts: 5
Joined: Thu Apr 18, 2019 4:50 pm

Re: Cinnamon launcher only works with context 'open' command

Post by bobbalou135711 » Sun Apr 21, 2019 1:13 am

Good evening,

I successfully created a new launcher called 'test' which starts NetBeans if I use the context 'open' command. Clicking has no effect.

The Trash and Network launchers behave the same way. Only function when using the context 'Open' menu.

Code: Select all

bbowman@fandango ~ $ find $HOME ! -user $USER -print
/home/bbowman/.rpmdb
/home/bbowman/.rpmdb/Sigmd5
/home/bbowman/.rpmdb/Recommendname
/home/bbowman/.rpmdb/Providename
/home/bbowman/.rpmdb/Packages
/home/bbowman/.rpmdb/Requirename
/home/bbowman/.rpmdb/Triggername
/home/bbowman/.rpmdb/Supplementname
/home/bbowman/.rpmdb/Transfiletriggername
/home/bbowman/.rpmdb/__db.002
/home/bbowman/.rpmdb/Suggestname
/home/bbowman/.rpmdb/Conflictname
/home/bbowman/.rpmdb/Filetriggername
/home/bbowman/.rpmdb/Obsoletename
/home/bbowman/.rpmdb/Group
/home/bbowman/.rpmdb/Enhancename
/home/bbowman/.rpmdb/Dirnames
/home/bbowman/.rpmdb/Name
/home/bbowman/.rpmdb/.dbenv.lock
/home/bbowman/.rpmdb/__db.003
/home/bbowman/.rpmdb/Basenames
/home/bbowman/.rpmdb/Installtid
/home/bbowman/.rpmdb/Sha1header
/home/bbowman/.rpmdb/__db.001
/home/bbowman/.cache/dconf
find: ‘/home/bbowman/.cache/dconf’: Permission denied
I created a new account. The desktop performs normally. I am sure it is a problem related to something I did that does not play well with the update. Just can't see any indication of what it might be. I really appreciate your patience.

--Bob

bobbalou135711
Level 1
Level 1
Posts: 5
Joined: Thu Apr 18, 2019 4:50 pm

Re: Cinnamon launcher only works with context 'open' command

Post by bobbalou135711 » Sun Apr 21, 2019 1:37 am

Found it! I have a suspicion how this may have happened...

About the same time the update came out I had installed an IOGear KVM switch that caused my mouse to be erratic so I uninstalled it. No software was involved.

Anyways, I was thinking about that KVM... and poked around and found the mouse settings dialogue. Noticed a 'mouse double-click timeout' setting...

It was set to all the way to the left 'short'. Slid it right about a quarter of the way right and voila. Launchers work.

<8/ What kind of caffeine crazed lunatic needs a double-click that fast! After setting it back to 'short' I tried crazily clicking the 'test' button. Can't do it.

:) So... mystery issue was account mouse settings... Again thanks for your patience and keep up the great work here on the forum.

User avatar
smurphos
Level 11
Level 11
Posts: 3721
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Cinnamon launcher only works with context 'open' command

Post by smurphos » Sun Apr 21, 2019 1:48 am

Glad you sorted it out, the mouse settings would have been my next suggestion once you'd confirmed the default icons were not working either.

By the way that find command identified those files listed as not being owned by your user. In general that's a bad thing for files in your home directory. To fix run

Code: Select all

sudo chown -Rc $USER:$USER $HOME
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

Post Reply

Return to “Others”