beryl has no window borders

Forum rules
Before you post please read how to get help
Post Reply
User avatar
poision
Level 3
Level 3
Posts: 143
Joined: Mon Jun 18, 2007 10:59 am
Location: India

beryl has no window borders

Post by poision »

hi i installed cassendra on my compaq laptop(v3000z) everything working fine..i installed nvidia with using envy n started beryl but i found that beryl is not having widows border like minimize,maximize and close buttons..everythins seems like full screenn and i m also unable to change beryl theme..pls help me..is there any problem in my harware i m having nvidia go6150 chipset in laptop...i want to my beryl work finely pls help me
Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse »

This is a common problem - it either depends on that you have a theme without these window decorations or that beryl is not configured properly.
Start emerald (from the menu) to get some themes or check this sticky howto:
http://www.linuxmint.com/forum/viewtopi ... ryl&t=1036
or the wiki
http://www.linuxmint.com/wiki/index.php ... Linux_Mint
The thing that's different with Cassandra is that Beryl is already installed
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
frank392
Level 4
Level 4
Posts: 363
Joined: Wed Nov 22, 2006 1:29 pm

Post by frank392 »

Hi Poision,
I had the same problem. just follow this instructions and fix it:
http://www.linuxmint.com/forum/viewtopi ... ryl&t=2864
good luck
User avatar
poision
Level 3
Level 3
Posts: 143
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Post by poision »

frank392 wrote:Hi Poision,
I had the same problem. just follow this instructions and fix it:
http://www.linuxmint.com/forum/viewtopi ... ryl&t=2864
good luck
hi frank I followed your link n append those lines in xorg.conf but then my xcrashed.I recovered my x with backup but now nvidia n beryl both are not working.It says there is some error at line number 117 which is unable to parsing Pls help me to solve this is anything wrong with my system or mint.I ve compaq v3000z laptop. Waiting for your reply.
Thanks alot
frank392
Level 4
Level 4
Posts: 363
Joined: Wed Nov 22, 2006 1:29 pm

Post by frank392 »

Hi Poision,
I'm sorry is not working for you. just in case, the only line that you need to ad is :

Option "AddARGBGLXVisuals" "True"

take a look at the last part of the link that I pointed to you.
User avatar
poision
Level 3
Level 3
Posts: 143
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Post by poision »

frank392 wrote:Hi Poision,
I'm sorry is not working for you. just in case, the only line that you need to ad is :

Option "AddARGBGLXVisuals" "True"

take a look at the last part of the link that I pointed to you.
hi buddy i tried that too then i uninstalled my nvidia driver n installed new drivers from envy.Then i wrote those lines in xorg but still not getting window menu.Then i wrote all lines in device section which i borrowed from those forums but still no use my beryl is still window menuless.I think some prob in my hardware or installation of mint.Or i ve to wait for celena.
User avatar
poision
Level 3
Level 3
Posts: 143
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Post by poision »

shydy wrote:Hi poision,
I have had the same problem and i resolved it with an installation of the original nvidia driver.
I've a guide but in italian. I can to try translate it:

Warning Print this guide, because you will have to arrest the server x and GUI.

1) First control which are that just for your card video here:
http://www.nvidia.com/object/IO_32667.html #(old).
http://www.nvidia.com/object/IO_18897.html #(new)
2) Download driver (http://www.nvidia.com/object/unix.html
3) Install and support library:
sudo apt-get install binutils build-essential linux-headers-$(uname -r) pkg-config xserver-xorg-dev #(all on the same line)
4) Remove old driver on your computer:
sudo apt-get --purge remove nvidia-glx-new nvidia-glx nvidia-settings nvidia-glx-legacy #(all on the same line)
5) Open and edit linux-restricted-modules:
sudo gedit /etc/default/linux-restricted-modules-common
6) You add to the line DISABLED_MODULES="nv nvidia_new"
If it doesn't exist, to create it.
7) To press the keys CTRL+ALT+F1 to stop server X and go to the virtual terminal tty1. You write the user login and password. Now stopping Gnome:
sudo /etc/init.d/gdm stop
If you have kde, write:
sudo /etc/init.d/kdm stop
8) You go to the directory where you have save the driver nvidia installer (you council to use the home directory, therefore you will not have yourself to be moved).
9) Write commando:
sudo sh your nvidia driver-pkg1.run -a -n -N
10)To the term of the process the installer ask you if you want that it configure your xorg.conf file, answer y (yes).
11)Restart the server X:
gnome:
sudo /etc/init.d/gdm restart
or if you have kde:
sudo /etc/init.d/kdm restart
12) you control that in your file xorg.conf it's all right:
sudo gedit /etc/X11/xorg.conf
In the section Module delete (if they exist) the lines:
Load "dri"
Load "GLCore"

And you add if not there is
Load "glx"

If not there is, in the section Device change the line:
Driver "nv"
(o Driver "vesa")
(o Driver "fbdev")

with
Driver "nvidia"

In the section screen add:
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
and control that DefaultDepth is 24

DefaultDepth 24

Add at the end of file:
Section "Extensions"
Option "Composite" "Enable"
EndSection


Save and go.

Try this, it's the best way that i tried.
bye :wink:
hi shydy your script seems confident i ll try tonight but i didnt get one thing that if i uninstall nvidia envy drivers then i ll install manually those new drivers.I already have backup of current driver xorg.conf shall paste it directly after installation of new set of drivers?Pls reply after your reply i ll try that.Thanks for guide.
User avatar
poision
Level 3
Level 3
Posts: 143
Joined: Mon Jun 18, 2007 10:59 am
Location: India

Post by poision »

Hi shydy thanks buddy i installed new driver set but again i got same prob.But later on i compared my xorg with xorg send by merlwiz i found my default color depth is 16 so i changed it to 24.Now its working very well.Thanks to ya for nice script well can ya tell me from where i can get more plugin for beryl like fire n desktop animation etc.Thanks again for all for helping me.
Post Reply

Return to “Others”