Page 1 of 1

**SOLVED** Suspend/Hibernate not working

Posted: Mon Oct 18, 2010 12:32 pm
by MysticGold04
I just did a clean install of LM9 Flux to my laptop this past weekend, and have a question about suspend/hibernate. They both worked in LM9 Gnome edition, but do not work in Flux. I did a manual partition scheme, because I reformatted my entire drive to use ext4, prior my / was ext4 and /home was ext3. Anyhow, when I click on either, my laptop does nothing. No errors, just sits there.

I've read that not being able to suspend/hibernate depends on a functioning swap partition, which I do believe I have, but how do I double check??

Thanks in advance!

Re: Suspend/Hibernate not working

Posted: Mon Oct 18, 2010 1:33 pm
by shane
You can check the status of your swap partitions by running

Code: Select all

swapon -s
To check if suspend is working run

Code: Select all

sudo pmi action sleep
If that doesn't work, make sure you have this package installed: powermanagement-interface If it isn't, this could be a bug in the package. Surprising no one has mentioned it so far.

Post back here to let us know if you've solved the problem or not.

**SOLVED**Re: Suspend/Hibernate not working

Posted: Mon Oct 18, 2010 11:46 pm
by MysticGold04
well... swap was good... I had to install the package you mentioned, because it wasn't installed. Once I installed the powermanagement-interface package, suspend and hibernate now work correctly.

Thanks for the help!!

Re: **SOLVED** Suspend/Hibernate not working

Posted: Tue Oct 19, 2010 12:22 am
by shane
Thanks for the feedback. This is a bug. That package should be a dependency.