Tap to click keeps turning back on

Forum rules
Before you post please read how to get help
Post Reply
tygoef
Level 1
Level 1
Posts: 4
Joined: Thu Sep 15, 2011 5:18 pm

Tap to click keeps turning back on

Post by tygoef » Thu Sep 15, 2011 5:38 pm

I have LXDE installed on my Asus Eee PC 1005PE Netbook, and, for the most part, think it works great. I have a bit of a noob issue, as I'm a noob, with Tap To Click though. I find it very annoying. I turn it off in the graphical interface, and then I'm happy. The problem occurs when I re-boot the netbook, Tap To Click is automatically turned on every time.

When it comes to the terminal, I'm a complete noob, so if instructions to turn Tap To Click off can be broken down to the most simplistic term, it would be greatly appreciated.

I decided to post here instead of the noob forum, because it seems not much is directed toward LXDE there.

Kendall
Level 6
Level 6
Posts: 1120
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA
Contact:

Re: Tap to click keeps turning back on

Post by Kendall » Thu Sep 15, 2011 5:56 pm

Can you please post the contents of the ~/.linuxmint/sms file both before and after attempting to change the settings?
I'm on Twitter: @kendalltristan
My website: kendalltristan.com
My blog: blog.kendalltristan.com

tygoef
Level 1
Level 1
Posts: 4
Joined: Thu Sep 15, 2011 5:18 pm

Re: Tap to click keeps turning back on

Post by tygoef » Fri Sep 16, 2011 4:15 pm

I would, if I had the first idea where to find that information.

tygoef
Level 1
Level 1
Posts: 4
Joined: Thu Sep 15, 2011 5:18 pm

Re: Tap to click keeps turning back on

Post by tygoef » Fri Sep 16, 2011 4:58 pm

I think I finally figured out where to find it.

Before any changes:
#!/bin/sh
#Autogenerated script - Do not edit
synclient TouchPadOff=0
synclient VertEdgeScroll=1
synclient HorizEdgeScroll=0
synclient TapButton1=0
xmodmap -e "pointer = 1 2 3"
xset m 2 2
After changes:
#!/bin/sh
#Autogenerated script - Do not edit
synclient TouchPadOff=0
synclient VertEdgeScroll=1
synclient HorizEdgeScroll=0
synclient TapButton1=0
xmodmap -e "pointer = 1 2 3"
xset m 2 2

Kendall
Level 6
Level 6
Posts: 1120
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA
Contact:

Re: Tap to click keeps turning back on

Post by Kendall » Fri Sep 16, 2011 6:14 pm

The script seems correct so there is likely something else at work here. I'll post a link to a patched version of lxsession when I get home. When I do, Install it and see if the issue persists.
I'm on Twitter: @kendalltristan
My website: kendalltristan.com
My blog: blog.kendalltristan.com

tygoef
Level 1
Level 1
Posts: 4
Joined: Thu Sep 15, 2011 5:18 pm

Re: Tap to click keeps turning back on

Post by tygoef » Sun Sep 18, 2011 10:40 am

OK, thanks

Anymouse
Level 1
Level 1
Posts: 25
Joined: Mon May 16, 2011 2:25 am

Re: Tap to click keeps turning back on

Post by Anymouse » Wed Sep 21, 2011 11:06 pm

I am having the same problem. Has a resolution been found?

Anymouse
Level 1
Level 1
Posts: 25
Joined: Mon May 16, 2011 2:25 am

Re: Tap to click keeps turning back on

Post by Anymouse » Fri Sep 23, 2011 10:10 pm

If there was a script that could automate our menu selection at boot that would be a solution.

ajgreeny
Level 4
Level 4
Posts: 330
Joined: Mon Nov 19, 2007 3:27 pm

Re: Tap to click keeps turning back on

Post by ajgreeny » Wed Sep 28, 2011 4:00 pm

You can do it with a simple command

Code: Select all

synclient MaxTapTime=0
which you can make into a shell script which is run as a startup application. I could not get gpointing-device-settings to work in my Lubuntu 11.04 on a netbook or my old laptop for some reason or another, but the synclient command did the job, so I see no reason why it will not in LM LXDE.

Anymouse
Level 1
Level 1
Posts: 25
Joined: Mon May 16, 2011 2:25 am

Re: Tap to click keeps turning back on

Post by Anymouse » Wed Sep 28, 2011 9:00 pm

Thanks! This worked for me. I created a script called TapOff, made it executable and added the line "TapOff &" without quotes to my /home/user/.profile startup script.

Post Reply

Return to “Others”