auto login on LXDE 11, how?

Forum rules
Before you post please read how to get help
Post Reply
User avatar
gychang
Level 3
Level 3
Posts: 138
Joined: Tue Dec 09, 2008 12:24 pm

auto login on LXDE 11, how?

Post by gychang »

On previous versions, by modifying the file /etc/lxdm/default.conf, it would work but not with the latest.

anyone have a solution?

thanks,

gychang
--
cruising the desert
--
User avatar
tdockery97
Level 14
Level 14
Posts: 5059
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: auto login on LXDE 11, how?

Post by tdockery97 »

Found this. I know I had it working, but have forgotten how. This sounds right:

SciFiDude79 wrote:
This threw me for a loop also but I spent a while on it last night and finally figured it out. I've been using Peppermint, Kendall's other distro, since September, so I knew what to look for, I just wasn't expecting to have to fix 3 files to get auto-login working.

/etc/xdg/lxdm/lxdm.conf
/etc/lxdm/lxdm.conf
/etc/lxdm/default.conf

Do what you did for Mint 9, change autologin=____ to autologin=your login name and get rid of the pound (#) signs in front of the first two lines in all 3 files. Then auto-login will work. I found that if you only change 1 or 2 of the files it doesn't work.
Mint Cinnamon 20
User avatar
gychang
Level 3
Level 3
Posts: 138
Joined: Tue Dec 09, 2008 12:24 pm

Re: auto login on LXDE 11, how?

Post by gychang »

on my PC, there is no /etc/lxdm/lxdm.conf file, I changed the other 2 and does NOT work.

gychang
tdockery97 wrote:
/etc/xdg/lxdm/lxdm.conf
/etc/lxdm/lxdm.conf
/etc/lxdm/default.conf

Do what you did for Mint 9, change autologin=____ to autologin=your login name and get rid of the pound (#) signs in front of the first two lines in all 3 files. Then auto-login will work. I found that if you only change 1 or 2 of the files it doesn't work.
--
cruising the desert
--
Ikem
Level 1
Level 1
Posts: 49
Joined: Tue Oct 25, 2011 12:29 am
Contact:

Re: auto login on LXDE 11, how?

Post by Ikem »

gychang wrote:[Auto login] on previous versions [worked] by modifying the file "/etc/lxdm/default.conf".

It [doesn't] work [anymore].
Linux Mint 11 LXDE isn't using LXDM anymore. It's using GDM3.
gychang wrote:Anyone have a solution?
I see two solutions:

1. You configure GDM3 auto login.
2. You reinstall [url=apt://lxdm]LXDM[/url].
Last edited by Ikem on Tue Feb 07, 2012 4:50 pm, edited 1 time in total.
jaqian
Level 2
Level 2
Posts: 68
Joined: Tue Jun 30, 2009 8:25 am
Location: Dublin, Ireland
Contact:

Re: auto login on LXDE 11, how?

Post by jaqian »

Hi I reinstalled LXDM as suggested, edited the newly installed lxdm.conf file and made no difference to the login. I do not have /etc/gdm3 just /etc/gdm. Any other suggestions? I love Mint LXDM as is much faster than the bloat that has become Ubuntu but the auto login not working is a real pita. Thanks.
.
..
...
Computers: Desktop> Dell Dimension 8400 | Netbook> MSI U135DX
Distros: Mint LXDE 11

--------------------------------------------------------
Camera: Sony Alpha α100 (Silver) | Minolta 50mm f1.7
User avatar
Bob E
Level 4
Level 4
Posts: 366
Joined: Sun May 01, 2011 9:45 am
Location: Directly above the center of the Earth.

Re: auto login on LXDE 11, how?

Post by Bob E »

On Linux Mint 11 LXDE, from the main menu go to System Tools > Login Screen. You will get a GUI to set the system to auto-login.

-----------------
@tdockery97 ~ New cat in the house?
jaqian
Level 2
Level 2
Posts: 68
Joined: Tue Jun 30, 2009 8:25 am
Location: Dublin, Ireland
Contact:

Re: auto login on LXDE 11, how?

Post by jaqian »

Bob E wrote:On Linux Mint 11 LXDE, from the main menu go to System Tools > Login Screen. You will get a GUI to set the system to auto-login.
Thanks but doesn't work
.
..
...
Computers: Desktop> Dell Dimension 8400 | Netbook> MSI U135DX
Distros: Mint LXDE 11

--------------------------------------------------------
Camera: Sony Alpha α100 (Silver) | Minolta 50mm f1.7
Ikem
Level 1
Level 1
Posts: 49
Joined: Tue Oct 25, 2011 12:29 am
Contact:

Re: auto login on LXDE 11, how?

Post by Ikem »

jaqian wrote:I reinstalled LXDM as suggested, edited the newly installed lxdm.conf file and made no difference
Please upload your lxdm.conf to pastebin.com and post the link to it here.
seppalta
Level 4
Level 4
Posts: 386
Joined: Wed Jun 08, 2011 12:08 pm

Re: auto login on LXDE 11, how?

Post by seppalta »

On Linux Mint 11 LXDE, from the main menu go to System Tools > Login Screen. You will get a GUI to set the system to auto-login.
This worked on multiple installs for me. Maybe you need updates.
User avatar
nunol
Level 9
Level 9
Posts: 2636
Joined: Sun Mar 06, 2011 9:25 pm
Location: Portugal

Re: auto login on LXDE 11, how?

Post by nunol »

tdockery97 wrote:...
/etc/lxdm/lxdm.conf
/etc/lxdm/default.conf
For Mint 12 LXDE RC the autologin option in the installer doesn't work but editing these two files solves the problem.
silver_moon
Level 1
Level 1
Posts: 5
Joined: Sat Jun 29, 2013 9:38 am
Contact:

Re: auto login on LXDE 11, how?

Post by silver_moon »

What are all of you trying to do ?
Auto login into lxde ?

Following the instructions give here

https://wiki.archlinux.org/index.php/Li ... _Autologin

You may not need the second step of adding user to that group.
User avatar
nunol
Level 9
Level 9
Posts: 2636
Joined: Sun Mar 06, 2011 9:25 pm
Location: Portugal

Re: auto login on LXDE 11, how?

Post by nunol »

silver_moon wrote:What are all of you trying to do ?
Auto login into lxde ?
Not to LXDE but to Linux Mint 11 (and 12) LXDE, both are EOL.
silver_moon wrote:Following the instructions give here

https://wiki.archlinux.org/index.php/Li ... _Autologin

You may not need the second step of adding user to that group.
Good to know but Mint 12 LXDE uses lxdm, not LightDM and recent Mint editions use mdm.
Post Reply

Return to “Others”