Mint Menu Disappeared in Gnome 3

Forum rules
Before you post please read how to get help
Post Reply
plutosams
Level 1
Level 1
Posts: 5
Joined: Wed Dec 29, 2010 4:46 pm

Mint Menu Disappeared in Gnome 3

Post by plutosams »

I am running Lisa RC. When I was placing the mouse into the hotspot in the top left, I then clicked on the mint-menu (with the overview open). This caused gnome-shell to crash needing a restart. Upon restart the mint-menu has disappeared and I cannot get it to return. Any ideas?

JordanV0712
Level 1
Level 1
Posts: 40
Joined: Sat Apr 09, 2011 9:11 am

Re: Mint Menu Disappeared in Gnome 3

Post by JordanV0712 »

I don't even remember having the Mint Menu. Are you talking about the one from LM11?
Linux Mint 12 KDE

User avatar
bimsebasse
Level 7
Level 7
Posts: 1692
Joined: Fri Nov 11, 2011 10:21 am
Location: Scandinavia

Re: Mint Menu Disappeared in Gnome 3

Post by bimsebasse »

Check if the mint menu extension is still activated. Launch Advanced Settings, under "Shell Extensions", see if "Menu Extension" is turned on (they shouldn't turn themselves off, though). Have you restarted your session or just Gnome shell?
Thank you for this thread. That’s all I can say. You most definitely have made this forum into something special. You clearly know what you are doing, you’ve covered so many bases. Thanks!

plutosams
Level 1
Level 1
Posts: 5
Joined: Wed Dec 29, 2010 4:46 pm

Re: Mint Menu Disappeared in Gnome 3

Post by plutosams »

The menu extension is now set to off in advanced settings (gnome tweak). When turning it on no menu appears. I have also restarted the computer and the menu extension stays off in advanced settings.

Looking through the forums I think it might be related to Bug #890805. He reports using crossover and this did occur roughly around the time that I installed Wine.

HorrorCode
Level 3
Level 3
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Re: Mint Menu Disappeared in Gnome 3

Post by HorrorCode »

bump

can anyone else confirm this and has anyone seen mention of a solution to it, it could simply be an incompatibility between another currently installed extension from what I;ve read but I cant seem to figure out if it should work once the clashing extension is disabled or if they both have to be removed and then add this one again?

st0kes
Level 1
Level 1
Posts: 2
Joined: Sun Nov 30, 2008 12:39 pm

Re: Mint Menu Disappeared in Gnome 3

Post by st0kes »

I've got the same problem. I reported it a few days before the OP: http://forums.linuxmint.com/viewtopic.php?f=205&t=86584

I also have Crossover installed. So it looks like this is related to the bug you mentioned.

HorrorCode
Level 3
Level 3
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Re: Mint Menu Disappeared in Gnome 3

Post by HorrorCode »

st0kes wrote:I've got the same problem. I reported it a few days before the OP: http://forums.linuxmint.com/viewtopic.php?f=205&t=86584

I also have Crossover installed. So it looks like this is related to the bug you mentioned.
Postby plutosams on Sun Nov 13, 2011 5:17 pm<<the original posting time, but no worries, I've posted many times without searching first, hell sometimes when you search the results aren't even displayed properly or by the correct date, anyways...

I have this problem WITHOUT having crossover or wine or anything to do with wine installed, so I can confirm that it's not JUST a wine issue, even if wine causes some problems, it didn't create my problem, and I have still not figured out a solution except to live without it or keep bumping this lol.

Same issue, enable it and nothing, restart gs, and no longer enabled...

HorrorCode
Level 3
Level 3
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Re: Mint Menu Disappeared in Gnome 3

Post by HorrorCode »


stevhorn
Level 1
Level 1
Posts: 13
Joined: Mon Nov 28, 2011 12:43 pm

Re: Mint Menu Disappeared in Gnome 3

Post by stevhorn »

I have this problem WITHOUT having crossover or wine or anything to do with wine installed, so I can confirm that it's not JUST a wine issue, even if wine causes some problems, it didn't create my problem, and I have still not figured out a solution except to live without it or keep bumping this lol.

Same issue, enable it and nothing, restart gs, and no longer enabled...
Same with me. I'm kinda sorry I updated....LM11 was working great. :(

Daniel4lm
Level 2
Level 2
Posts: 90
Joined: Tue May 24, 2011 7:14 am

Re: Mint Menu Disappeared in Gnome 3

Post by Daniel4lm »

Maybe it's a bit stupid but did you tried manually copy the menu extension from /usr/share/gnome-shell/extensions/ in the Home folder /.local/share/gnome-shell /extensions/. Restart Shell and then try again

Corrected bug preventing menu from loading when some applications are…
https://github.com/linuxmint/MGSE/tree/master/mgse-menu

stevhorn
Level 1
Level 1
Posts: 13
Joined: Mon Nov 28, 2011 12:43 pm

Re: Mint Menu Disappeared in Gnome 3

Post by stevhorn »

Latest update fixed it for me:

mgse-menu 1.1.3

HorrorCode
Level 3
Level 3
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Re: Mint Menu Disappeared in Gnome 3

Post by HorrorCode »

Daniel4lm wrote:
Maybe it's a bit stupid but did you tried manually copy the menu extension from /usr/share/gnome-shell/extensions/ in the Home folder /.local/share/gnome-shell /extensions/. Restart Shell and then try again

Corrected bug preventing menu from loading when some applications are…
https://github.com/linuxmint/MGSE/tree/master/mgse-menu

Pretty sure I have tried all 3 directories but I'll try again just to be sure.

Also I did happen to see that bug fix and I went ahead and updated the entire extension but that made no difference, so lets see if using a different directory might.

One thing I've been trying to figure out that you may have seen is where the looking glass error logs or any other looking glass logs are stored on disk? I can't seem to find a mention of them anywhere especially not from looking glass, but it's not so hard to take screenshots I guess.

HorrorCode
Level 3
Level 3
Posts: 137
Joined: Mon Sep 20, 2010 12:39 am

Re: Mint Menu Disappeared in Gnome 3

Post by HorrorCode »

stevhorn wrote:Latest update fixed it for me:

mgse-menu 1.1.3
Okay so I updated to that after you mentioned it and installed and restarted and...

OMG OMG OMG! Ty XXXXXXXXXXXXXXXXXXXXXXX

It's friggin working and gnome 3 just became my new love <3

Wtg devs and ty OP for reporting the fix! Closing bug report.

User avatar
Roken
Level 5
Level 5
Posts: 738
Joined: Fri Nov 19, 2010 4:55 pm
Location: Warrington, UK

Re: Mint Menu Disappeared in Gnome 3

Post by Roken »

Don't forget to mark the thread here as "Solved" too - edit your first post to add SOLVED to the title.
Kernel Linux Tex 4.8.13-1-ARCH (64 bit) xfce , burg
Arch
GTX680 4Gb
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz
8Gb RAM

Post Reply

Return to “Others”