computer is not show in lan

Questions about cabled networking
Forum rules
Before you post please read how to get help
offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

computer is not show in lan

Post by offir » Mon Feb 11, 2019 1:15 am

I have a computer running Linux Mint 19

I'm trying to share folders on this computer with the rest of the computers on the network
But it's not working

I chose a folder
I clicked Share option
I marked v in both boxes
and Create share

The computer does not even appear on the network


In addition
I do not see Windows computers on my computer

I see a network called windows network
But I do not have access to it
i get this error

Code: Select all

unable to mount location failed to retrieve share list from server: no such file or directory

deepakdeshp
Level 13
Level 13
Posts: 4938
Joined: Sun Aug 09, 2015 10:00 am

Re: computer is not show in lan

Post by deepakdeshp » Mon Feb 11, 2019 4:04 am

You have to setup samba
viewtopic.php?f=42&t=23169
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Mon Feb 11, 2019 4:43 am

I did what was written there
Open Nemo
Right click on the directory you own that you wish to share
Select "Sharing Options"
Select "Share this Folder"

Now you have some decisions to make.

(1a) If you want your users ( or guests ) to have write access then:
Select "Allow other people to write in this folder"

(1b) If you want everyone in your home network to have access to that shared folder:
Select "Guest Access"

(1c) When you click on Create Share a dialog box pops up and asks you if you want it to add permissions automatically - you do.

NOTE 1: If you allow "guest access" you're done. You can skip the rest of
this document ( except for note B mentioned at the end ). Everyone on the
network will be able to Read and/or Write from/to that folder. If you don't
want guest access then you will have to create users with passwords
And it does not work
That's the only thing I did

qbit
Level 2
Level 2
Posts: 79
Joined: Thu Jan 10, 2019 12:14 pm

Re: computer is not show in lan

Post by qbit » Mon Feb 11, 2019 7:32 am

Do you get this or something like that when you are entering "samba" at the console?
$ samba
[2019/02/11 12:21:52.362818, 0] ../lib/util/debug.c:1053(reopen_logs_internal)
Unable to open new log file '/var/log/samba/log.%m': Permission denied
[2019/02/11 12:21:52.363022, 0] ../source4/smbd/server.c:448(binary_smbd_main)
samba version 4.7.6-Ubuntu started.
Copyright Andrew Tridgell and the Samba Team 1992-2017
If not, you have to install samba first, then configure it and when your network is working well, you will get what you want.

altair4
Level 19
Level 19
Posts: 9576
Joined: Tue Feb 03, 2009 10:27 am

Re: computer is not show in lan

Post by altair4 » Mon Feb 11, 2019 7:38 am

Mint 19 and Samba File Sharing Changes: viewtopic.php?f=42&t=270442
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Mon Feb 11, 2019 11:04 am

just try that
Exactly what you said

Code: Select all

[2019/02/11 17:03:14.926614,  0] ../lib/util/debug.c:1053(reopen_logs_internal)
  Unable to open new log file '/var/log/samba/log.%m': Permission denied
[2019/02/11 17:03:14.926654,  0] ../source4/smbd/server.c:448(binary_smbd_main)
  samba version 4.7.6-Ubuntu started.
  Copyright Andrew Tridgell and the Samba Team 1992-2017

qbit
Level 2
Level 2
Posts: 79
Joined: Thu Jan 10, 2019 12:14 pm

Re: computer is not show in lan

Post by qbit » Mon Feb 11, 2019 2:05 pm

on this computer with the rest of the computers on the network
Is this network working, can you verify connections between the computers via the ping command?

Unfortunately, I do not know a single, really simple guide for setting up a small network (it used to be on Linux a long time ago), although many are published online.
There a many things like ad hoc or client mode, hotspot etc. and sometimes tons of cryptic security protocol settings, firewalling
But maybe here in this forum and be patient.

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Mon Feb 11, 2019 2:20 pm

Is this network working
What do you mean?
All computers have internet access
And can access their shares

Except for my computer with the Linux
can you verify connections between the computers via the ping command?
i can ping to the computers on the lan

altair4
Level 19
Level 19
Posts: 9576
Joined: Tue Feb 03, 2009 10:27 am

Re: computer is not show in lan

Post by altair4 » Mon Feb 11, 2019 2:23 pm

Are you having a problem following my link?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Tue Feb 12, 2019 1:55 am

Partly yes
The link you gave leads to another link that leads to another link
There's a lot of information there
I did not quite understand what to do

the other computers are win10 and win7

Before I wrote the post in the forum I tried that
add this line

Code: Select all

client max protocol = NT1
to smb.conf
that did not help

altair4
Level 19
Level 19
Posts: 9576
Joined: Tue Feb 03, 2009 10:27 am

Re: computer is not show in lan

Post by altair4 » Tue Feb 12, 2019 7:42 am

the other computers are win10 and win7
That's going to be a problem. Accessing a WIn10 machine from Linux and accessing a Win7 machine from Linux will be different.

For host discovery and access to a Win7 machine you would need in smb.conf the following lines in the [gloabl] section:

Code: Select all

client max protocol = NT1
name resolve order = bcast host lmhosts wins
There is one other paramater that you may need to fix and that is your host name. Run this command:

Code: Select all

hostname
Count the number of characters. If it's more than 15 your machine is invisible to netbios so you will need to fix that by adding one more line to smb.conf under the ones above:

Code: Select all

netbios name = a-name-shorter-than-15-characters-long
Then reboot your Mint machine.

The clinet max protocol = NT1 line that works for Win7 will be a problem for Win10 since it disables SMBv1 ( i.e., NT1 ). You will be able to see the Win10 machine but you won't be able to access it.

And remember that to access the Mint machine from either Windows machine you can always do it explicitly on Explorer:

By ip address: \\192.168.0.100
By hostname: \\mint-host-name
And for Windows 10 by it's mDNS qualified host name: \\mint-host-name.local

You do have one other side issue and that's this - you cannot see your own machine:
The computer does not even appear on the network
You should always be able to see your own machine on the network - outside the Windows Network folder - becase of avahi. The only thing that would stop it would be if it's not running:

Code: Select all

sudo service avahi-daemon status
Now I'm going to make this as clear as I can. Right now it doesn't matter if avahi isn't working since you don't have any other Linux or MacOS machines in your network. But should you start adding more Linux machines to your network and you cannot get avahi to work you need to stop using Mint.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Tue Feb 12, 2019 8:08 am

I added these two lines like this

Code: Select all

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP
   client max protocol = NT1
   name resolve order = bcast host lmhosts wins
Or I should have done that ?

Code: Select all

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP

# client max protocol = NT1
   name resolve order = bcast host lmhosts wins

Code: Select all

hostname 
give me this linux-mint

Code: Select all

sudo service avahi-daemon status
give this

Code: Select all

● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
   Loaded: loaded (/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-02-11 06:12:58 IST; 1 day 7h ago
 Main PID: 796 (avahi-daemon)
   Status: "avahi-daemon 0.7 starting up."
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/avahi-daemon.service
           ├─796 avahi-daemon: running [linux-mint.local]
           └─815 avahi-daemon: chroot helper

Feb 11 06:12:58 linux-mint avahi-daemon[796]: Registering new address record for ::1 on lo.*.
Feb 11 06:12:58 linux-mint avahi-daemon[796]: Registering new address record for 127.0.0.1 on lo.IPv4.
Feb 11 06:12:58 linux-mint systemd[1]: Started Avahi mDNS/DNS-SD Stack.
Feb 11 06:12:59 linux-mint avahi-daemon[796]: Server startup complete. Host name is linux-mint.local. Local service cookie is 979947082.
Feb 11 06:13:03 linux-mint avahi-daemon[796]: Joining mDNS multicast group on interface enp3s0.IPv6 with address fe80::abf:4547:f4b6:9dfc.
Feb 11 06:13:03 linux-mint avahi-daemon[796]: New relevant interface enp3s0.IPv6 for mDNS.
Feb 11 06:13:03 linux-mint avahi-daemon[796]: Registering new address record for fe80::abf:4547:f4b6:9dfc on enp3s0.*.
Feb 11 06:13:11 linux-mint avahi-daemon[796]: Joining mDNS multicast group on interface enp3s0.IPv4 with address 192.168.1.2.
Feb 11 06:13:11 linux-mint avahi-daemon[796]: New relevant interface enp3s0.IPv4 for mDNS.
Feb 11 06:13:11 linux-mint avahi-daemon[796]: Registering new address record for 192.168.1.2 on enp3s0.IPv
it says host name is linux-mint.local

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Tue Feb 12, 2019 8:14 am

added these two lines and restart did not help

altair4
Level 19
Level 19
Posts: 9576
Joined: Tue Feb 03, 2009 10:27 am

Re: computer is not show in lan

Post by altair4 » Tue Feb 12, 2019 8:29 am

Then I can't help you. I would suggest Ubuntu or something in the Ubuntu family.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Tue Feb 12, 2019 9:04 am

i had ubuntu
I changed to Linux Mint because of a more convenient gui

altair4
Level 19
Level 19
Posts: 9576
Joined: Tue Feb 03, 2009 10:27 am

Re: computer is not show in lan

Post by altair4 » Tue Feb 12, 2019 9:29 am

Did it work when you used Ubuntu?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Tue Feb 12, 2019 10:10 am

Yes
But Ubuntu's interface is not easy to use (for me)

qbit
Level 2
Level 2
Posts: 79
Joined: Thu Jan 10, 2019 12:14 pm

Re: computer is not show in lan

Post by qbit » Thu Feb 14, 2019 9:37 am

Did you carefully check the firewall settings of all your machines? Especially the allow rules?, i.e. exceptions for home computers etc..

Recently i had a similar problem, i simply had forgotten to check the firewalls, they were to hard configured without exceptions.

offir
Level 2
Level 2
Posts: 83
Joined: Wed Sep 21, 2016 7:37 am

Re: computer is not show in lan

Post by offir » Thu Feb 14, 2019 9:48 am

Yes, I checked
The network works among other computers
Each computer has two or three shared folders that I can access

Could there be something blocking it in Linux?

qbit
Level 2
Level 2
Posts: 79
Joined: Thu Jan 10, 2019 12:14 pm

Re: computer is not show in lan

Post by qbit » Thu Feb 14, 2019 10:17 am

Yes, this is exactly my thought, the private data communication is for an internet capable computer an additional security problem, therefore the allow-rules

A very simple way to check if the problem is firewall is to disable firewall for a very short time on the linux machine and on the other ones as well. But keep in mind that this is a security risk! However if file sharing between windows and linuxb then is workig, turn on firewall and study the allow rules.

Post Reply

Return to “Ethernet”