Page 1 of 1

Network card is not being detected

Posted: Thu Sep 06, 2012 1:25 am
by zahidcseku
Hi

I have been using windows OS for last 15 years. I am now trying to switch to Linux and I installed Linux mint maya cinnamon 64bit edition. For the last 2 days I have been trying to get my wired internet connection working. I figured my network card is not being detected. Can any body help me please? I am quiet frustrated now. FYI: my network card is integrated to the motherborad and I do not know the make or model of the NIC. Any help will be highly appreciated. Thanks in advance.

Z

Re: Network card is not being detected

Posted: Thu Sep 06, 2012 1:57 pm
by remoulder
zahidcseku wrote:do not know the make or model of the NIC
The forums rules are meant to help you provide the information, however open a terminal and copy/paste with the right mouse menu the output of

Code: Select all

lspci

Re: Network card is not being detected

Posted: Thu Sep 06, 2012 3:05 pm
by zahidcseku
Hi remoulder
Thanks for your reply. I am travelling now. So I wont be able to upload the output until Sunday. However I tried lspci command earlier but I did not show any information regarding my NIC.

Re: Network card is not being detected

Posted: Thu Sep 06, 2012 5:14 pm
by remoulder
If it's not being detected it's either not enabled or faulty. However without the output it's not possible to say. Please only post when you have access to the machine.

Re: Network card is not being detected

Posted: Fri Sep 07, 2012 2:25 am
by joness31
There are several factors that determine our destiny, which means that we must be in the know of our internal selves.

Re: Network card is not being detected

Posted: Fri Sep 07, 2012 10:39 am
by Oscar799
joness31,
Your strange post has absolutely nothing to do with the topic of the thread - please don't fill the forum with nonsense

Re: Network card is not being detected

Posted: Mon Sep 10, 2012 4:11 am
by zahidcseku
hello guys
Here is the output of lspci command. I am sure the network card is enabled in the bios as I was able to use the same internet connection in windows. Please help me, I do not wanna go back to windows.


zahid@zahid-desktop ~ $ lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
zahid@zahid-desktop ~ $

Re: Network card is not being detected

Posted: Mon Sep 10, 2012 8:42 am
by remoulder
Have you checked again that it's enabled in the BIOS? Other than that does it still work if you boot into Windows or a live disc? If not then it may be faulty.

Re: Network card is not being detected

Posted: Sun Dec 16, 2012 8:14 pm
by kteach
I am also having this problem. I had Windows 7 on this computer. It is based on this mother board

GA-78LMT-USB3 (rev. 4.1) AMD 760G + SB710 Chipset

Which is a different board than this user, but I too have no network card. It was not detected, nor does it show up on the list when I issue the lspci command. I believe it is a realtek on board NIC, but I do not know the specific one. I downloaded drivers from the realtek site, but I do not know how to install. Thoughts?

Links? anything would help, thanks.

Re: Network card is not being detected

Posted: Sun Dec 30, 2012 4:30 pm
by billmc
You can use the lshw (list hardware) command, in a terminal. You want to look for the section labeled *-network.

sudo lshw

Here is the output from my system:

*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: 06
serial: 50:e5:49:3c:cb:3d
size: 1Gbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=192.168.1.7 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
resources: irq:43 ioport:ce00(size=256) memory:fdfff000-fdffffff memory:fdff8000-fdffbfff

With this information, you should be able to determine which hardware you have. Most likely, the drivers are available. The "lsmod" command will tell you which drivers you have loaded. You may need to determine which driver you need and load that module -> sudo modprobe xxxx

My lsmod output shows;
.
.
crc_itu_t 12707 1 firewire_core
r8169 61650 0
pata_atiixp 13204 0