Set Static IP, KDE Mint 17

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
zero-sum
Level 1
Level 1
Posts: 15
Joined: Wed Feb 08, 2012 11:41 pm

Set Static IP, KDE Mint 17

Post by zero-sum »

Working on KDE Mint-17, 64 bit, Intel DP55KG board. Trying to do a clean install from 32 bit Maya 13 to 64 bit Qiana. Network is static IP (15 other devices need static Ips) Everything worked fine under Maya.

Did the Qiana install using LAN DCHP connectivity. Everything worked fine. Ran into trouble trying to go from DHCP operation to static ip operation. System Settings → Network Settings appears to be totally useless due to lack of any static IP functionality. Clicking on the panel network icon → wrench symbol brings up the Connection Editor. Highlighting Wired Connection 1 (eth0?) and clicking on Edit, Manual, brings up an Edit panel where I can enter everything under IPv4 and do an ifconfig eth0 up but nothing happens.

After a simple reboot, Connection Editor shows Wired Connection 2 with everything back to DHCP and no static IP addresses showing.

Ref. http://forums.linuxmint.com/viewtopic.php?f=46&t=173686

I could find no such panel widget. This appears to be a KDE problem? Any enlightenment much appreciated. Can I bypass the KDE GUI stuff and write directly to appropriate files. Would this then be stable.
zero-sum
Level 1
Level 1
Posts: 15
Joined: Wed Feb 08, 2012 11:41 pm

Re: Set Static IP, KDE Mint 17

Post by zero-sum »

I gave up on KDE Qiana 64 bit. Close as I got was turning off network-manager and using the cli hot-plug command to activate eth0. I could ping the world but no internal apps would work. I read where many sys. admin and server guys hate any type of automated network management and the first thing they do is remove it and go back to manual basics.

Thats what I tried. Tried to totally remove it and then nothing would work. Tried to disable it and then write the usual data into /etc/network/interfaces and that didn't work either. It's a very simple machine, no wireless, with a single Ethernet connection to the outside world. In the past, it's only taken a minute or two to write the connection data into the appropriate files and everything would come up totally solid and just work.

Went back to KDE Maya 64 bit. Network-manager works a little better but is not as solid as the 32 bit version. I would much prefer an option during the op. sys. load process where you could op out of any wireless stuff and any automatic network-manager stuff. Life would be much simpler and nice.
WoodLark
Level 1
Level 1
Posts: 25
Joined: Tue Oct 21, 2014 1:25 pm

Re: Set Static IP, KDE Mint 17

Post by WoodLark »

I'm running Mint 17 XFCE. I too gave up on the connections editor. I finally edited this file directly: /etc/network/interfaces. This is what mine looks like:

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.20
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 192.168.1.1
I can't guarantee it will work for you too, but we can hope! If your system uses something other than eth0 to identify your network card, use that . I have another system where it was eth1.
Post Reply

Return to “Ethernet”