eth0 doesn't bring up during boot in linmint xfce and fluxb

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Windows
Level 1
Level 1
Posts: 14
Joined: Tue Nov 04, 2008 2:56 pm

eth0 doesn't bring up during boot in linmint xfce and fluxb

Post by Windows »

Hi! I've installed linux mint on 8 computers. For Gnome LinuxMint - allright, but for the some computers with xfce and fluxbox there are some problems: eth0 doesn't bring up during boot time. But when I try in console # ifconfig eth0 down and then # ifconfig eth0 xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx up - eth0 works fine.

lsmod shows that all modules are present.
/etc/network/interfaces is checked.

What can I do to have normal netcard initializing?
Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: eth0 doesn't bring up during boot in linmint xfce and fluxb

Post by Husse »

The main thing is that it works, but I agree that this is bloody annoying
What NIC does the offending boxes have - if you are uncertain lspci is there to help you
If my memory serves me right both fluxbox and xfce use WICD not Network Manager which is used by main and kde
So a change could help you - wicd is good at wireless but maybe not at wired connections
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Windows
Level 1
Level 1
Posts: 14
Joined: Tue Nov 04, 2008 2:56 pm

Re: eth0 doesn't bring up during boot in linmint xfce and fluxb

Post by Windows »

Husse wrote:The main thing is that it works, but I agree that this is bloody annoying
What NIC does the offending boxes have - if you are uncertain lspci is there to help you
If my memory serves me right both fluxbox and xfce use WICD not Network Manager which is used by main and kde
So a change could help you - wicd is good at wireless but maybe not at wired connections
# lspci
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)

# lsmod | grep rhine
via_rhine 26632 0
mii 6400 1 via_rhine

I've found network-admin on my linmint fluxbox computer (gnome-network-admin).
And when I start it, eth0 is down up! Yes! That is the reason!
I'll try to turn it off...
Windows
Level 1
Level 1
Posts: 14
Joined: Tue Nov 04, 2008 2:56 pm

Re: eth0 doesn't bring up during boot in linmint xfce and fluxb

Post by Windows »

I turn off the wired interface in preference of wicd manager by typing None in its field.
And now eth0 bring up while booting!!! Thanks a lot!

Could you tell me, how can I turn off wicd at all?
Husse
Level 23
Level 23
Posts: 18677
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: eth0 doesn't bring up during boot in linmint xfce and fluxb

Post by Husse »

Could you tell me, how can I turn off wicd at all?
Unless you installed something else you (probably) still use it
If not to begin with you could try

Code: Select all

echo "blacklist wicd" | sudo tee -a /etc/modprobe.d/blacklist 
If all is good you can uninstall wicd - synaptics is perhaps the simplest way to use
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Post Reply

Return to “Ethernet”