Page 2 of 2

Re: no wi fi connection linux mint 18

Posted: Sat Nov 19, 2016 7:47 am
by OssiL
JeremyB wrote:Lets try a module parameter to set the name as it is in iwconfig

Code: Select all

echo "options r8712u ifname=wlx801f02b35c9d" | sudo tee /etc/modprobe.d/r8712u.conf

I am new to here and also with Mint.
I switched to Mint to avoid any extra maintenance tuning, but apparently it can't be avoided with Mint either...
This post helped me to get around this similar problem, but I must say that this is quite annoying and depressing.

What I do not get and understand if wireless works fine with live USB, why it doesn't do that on after installation to SDD?
It had all the configurations ready, but it just didn't work.
And basically only thing to get it work was (after a longish series of other attempts, debugging and ripping hair off my bald):

Code: Select all

modprobe -r r8712u
modprobe r8712u
If needed, I can probably reproduce the problem and paste stuff here.


Re: no wifi connection linux mint 18

Posted: Sat Nov 19, 2016 8:06 am
by JeremyB
You may have an issue with wifi powersave being enabled

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 7:07 am
by mintage
Same problem, but I did not understand the above very much & figure I'd need some help picking which commands to use.

What i DO know is I messed around and disabled wi-fi when i left the NEW hp machine dual-boot Serena MATE 18.1 / win(ce)10 unattended. Everything was relatively fine before that. I've been learning about rfkill and how it shows the names of some things that are blocked or not; my 0: acer-wireless: wireless LAN is soft blocked, not hard blocked. Whereas there is no blockage at all 1: hci0: Bluetooth or 2:phy0: Wireless LAN.

The Network Connections taskbar icon has the top 4 greyed out options Ethernet Network/disconnected/Wi-Fi Networks/Wi-Fi is disabled. And i seem to recall "Wi-Fi is disabled" is where an ill-fated active "Disable Wi-Fi" option once was. I'm pretty sure if it was working before, i shouldn't need to load some driver i didn't have before, is that right? Soft blocked seems to me that i should not have touched that disable wi-fi button because now; even though i have active Enable Networking & Enable Wi-Fi both selected, it just doesn't. I can ping and that is it.

I completely reinstalled Serena because i did foolishly think that i might play a computer game or two, but they aren't for me. No change with live SDCard mode or after install.

It looks like if I could just get that wi-fi button to work, I could then deal with loading my java class program, figuring out what to do with the dual boot that requires action to invoke and that mysterious not shutting off shut down feature.

Since it is a new laptop, i figured the fn key combo that controls airplane mode would fix it. But nothing i could think to try changed the Network Connections icon in the taskbar, or enabled WiFi.

My live 16GB SD card was generated from Linux Live USB Creator downloaded from a Mac, onto a USB drive. Transferred to new win10 machine to create mint SD card to reboot onto, SAID machine.

What can be done to enable wi-fi? It was working, and i loaded updates and tried some games, disabled wi-fi, and wi-fi never came back. Even after a complete reinstall. :mrgreen:

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 7:22 am
by JeremyB
So you have a HP laptop that has acer-wireless in the rfkill results? I would

Code: Select all

echo " blacklist acer-wmi" | sudo tee /etc/modprobe.d/acer-wmi.conf

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 12:56 pm
by mintage
Correct you are, sir. However; there has been a development.

Repeatedly rebooting last night, no change. Sitting overnight and rebooting, Enabled Wi-Fi for a lark and presto - asked for password and brought wi-fi online. ARRG!

I enabled wi-fi and a notification came up about "wi-fi networks are available, you should configure them". Since I got so much practice last night, I did that, it had the SSID from last night and all the other settings, just no password. Put that in and here I am online. Network icon on taskbar is showing other SSID's and the not so user-friendly Disconnect option that I am never going to use again. Interestingly enough the checkbox next to Enable Networking is set, but the checkbox next to Enable W-Fi is clear.

Connection Information
Active Network Connection
Herman (default)
Interface: 802.11 WiFi(wlo1)
Hardware Address: 58:00:E3:AC:25:87
Driver: rtl8723be
Speed: 72Mb/s
Security: WPA/WPA2

IP Address:
Broadcast Address:
Subnet Mask:
Default Route:
Primary DNS:

IP Address: fe80::386a:d350:51e4:7ae9/64

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 1:18 pm
by mintage
I tried a variant of
:idea: echo " blacklist acer-wmi" | sudo tee /etc/modprobe.d/acer-wmi.conf
before the 2nd install, but the problem was there is no acer-wmi.conf in the modprobe.d folder, even though I had instructions to create it - nothing changed so fortunately the instructions also said basically "well that didn't work, erase and reboot, this is looking like Windows".

echo " blacklist acer-wmi" | sudo tee /etc/modprobe.d/acer-wmi.conf
[sudo} password for mintage:
blacklist acer-wmi

I hope nothing broke. The acer-wmi.conf file exists now. Rebooting.

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 1:28 pm
by JeremyB
Another issue with HP's with the rtl8723be is that some only use one antenna, we can see if one antenna performs better than the other with

Code: Select all

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=1
iwlist scan | egrep -i 'ssid|quality'
Then we check the second option to find which one works better

Code: Select all

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2
iwlist scan | egrep -i 'ssid|quality'
If you notice no difference, then you likely have 2 antennas connected


Posted: Sat Dec 31, 2016 3:18 pm
by mintage
It seems to be working. I have a few reboots to do for GRUB issue checks so we will be seeing if the Wi-Fi holds out, but for now...I understand I am now running on antenna two. the output of iwlist scan | egrep -i 'ssid|quality'

for antenna one
lo Interface doesn't support scanning.
enpls0 Interface doesn't support scanning.
Quality=70/70 Signal Level=-30dBm
internet connectivity functional

for antenna two
lo Interface doesn't support scanning.
enpls0 Interface doesn't support scanning.
Quality=36/70 Signal Level=-74dBm
internet connectivity functional

I am assuming I need put both antennas back up with modprobe somehow?

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 3:47 pm
by JeremyB
You could try it with the default setting to compare with

Code: Select all

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be
iwlist scan | egrep -i 'ssid|quality'
As I would think that it will match the ant_sel=2 setting

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 4:34 pm
by mintage
The weaker antenna information is displayed, but the Network Connection icon in the taskbar is considerably more responsive. Instead of freezing the loopy circle and repeatedly notifying me that I am now offline every 7 seconds as previously observed (but not reported), it now animates the loopy circle and then shows an animated signal strength icon.
But the main thing here is that it is connecting - so good job. I don't know what fixed it, but I've rebooted every which way I can and will rely hopefully on that last set of commands to cycle the antennas if it happens again.

Thank you for taking the time to wrangle this ghost. 8)

Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 4:47 pm
by JeremyB
We can make that setting automatic with

Code: Select all

echo "options rtl8723be ant_sel=1 fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
The fwlps=N will disable some of the power management for wifi and should help with disconnects

[SOLVED]Re: no wifi connection linux mint 18

Posted: Sat Dec 31, 2016 5:21 pm
by mintage
Hooray! Thank you some more :!:

Re: no wifi connection linux mint 18

Posted: Mon Dec 04, 2017 1:02 pm
by beacon
I am very embarrassed to be posting this. I began the topic last year when I was having problems, and had a great deal of help with eventual success. I have just installed Linux Mint 18.3 and am having much the same difficulty as before. I have gone over all the help I was offered last time, but with no luck. I have also checked other web sites before coming back here. Using the first command suggested to me gives:
System: Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: Mobo: Gigabyte model: GA-MA78LMT-US2H v: x.x
Bios: Award v: F10 date: 03/10/2011
CPU: Triple core AMD Athlon II X3 455 (-MCP-) cache: 1536 KB
flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 19888
clock speeds: max: 3300 MHz 1: 800 MHz 2: 2100 MHz 3: 2100 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS780L [Radeon 3000]
bus-ID: 01:05.0
Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
GLX Renderer: Gallium 0.4 on AMD RS780 (DRM 2.49.0, LLVM 3.8.0)
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD/ATI] RS780 HDMI Audio [Radeon (HD) 3000 Series]
driver: snd_hda_intel bus-ID: 01:05.1
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Sound: Advanced Linux Sound Architecture v: k4.10.0-40-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: de00 bus-ID: 02:00.0
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 240.1GB (8.1% used)
ID-1: /dev/sda model: KINGSTON_SV300S3 size: 240.1GB
Partition: ID-1: / size: 213G used: 11G (6%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 472M used: 173M (39%) fs: ext2 dev: /dev/sda1
ID-3: swap-1 size: 8.05GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 32.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 214 Uptime: 1 min Memory: 934.9/7474.1MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
I have a wired connection, but when I go to Network Settings only the wired one is shown, and no option for wireless. I have added a wireless connection under Network Connections, but nothing works.

I may not have given enough information, but I hope someone can help me once again.