Remote /home with NFS

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
User avatar
NixaFinalFantasyFour
Level 1
Level 1
Posts: 4
Joined: Sun Apr 22, 2007 6:58 pm

Remote /home with NFS

Post by NixaFinalFantasyFour » Sun Apr 22, 2007 10:57 pm

I was attemping to set up my brother's Mint system to connect to my server and use the home folder there through NFS, but I noticed that Mint seems to have major issues with NFS...

First of all, autofs doesn't seem to mount NFS partitions properly. I suspect this is actually an Ubuntu bug, but no matter...

When I changed it to use fstab to mount, I noticed that KDE started up and ran HORRIBLy slow...

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Sun Apr 22, 2007 11:37 pm

I have used this before to speed up nfs.

http://www.higs.net/85256C89006A03D2/we ... erformance

It is a bit old and I was for a 2.4 kernel system but only 2 years ago!

oh yes and your system runs yuck if you cant read/write to your home in a speedy mannor. ie if there is a network problem

:D
Image
Now where was i going? Oh yes, crazy!

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Sun Apr 22, 2007 11:47 pm

Oh now i remember the slow network problem...

make sure both systems are running their networking at full duplex (or both at half duplex).
remember a network hub can only run at half-duplex but network switch can run at full-duplex (and half). BTW wireless is a hub.

If one is running at full duplex and one at half duplex the network is a pig and you get the exact problems you mentioned.

:D
Image
Now where was i going? Oh yes, crazy!

User avatar
NixaFinalFantasyFour
Level 1
Level 1
Posts: 4
Joined: Sun Apr 22, 2007 6:58 pm

Post by NixaFinalFantasyFour » Mon Apr 23, 2007 2:39 am

make sure both systems are running their networking at full duplex
I always run all the wired clients at full duplex. In this case, I know it's not the hardware, because I had them both the client and the server running Fedora Core, and both running openSUSE, and didn't get slowdown. I suspect it may be the settings, but I figured I'd bring it up here in case it's something buried in the packages.

Post Reply

Return to “Ethernet”