Mint to Mint LAN problems

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Level 3
Level 3
Posts: 106
Joined: Mon Jul 29, 2013 1:05 pm
Location: San Francisco

Mint to Mint LAN problems

Post by CliveMcCarthy »

I'm using a mixture of Mint 17.1 and 17.3 with Mate and Avahi / Samba. My machines are unable to gain access to the shared folders on one another. There are no Windows machines on the network, but there is one Mac. All was working fine and I went away for a few days, came back and things are not fine. Ostensibly nothing changed. I have done the obvious stuff such as rebooting the DHCP server; disconnecting all the WiFi APs; rebooting the machines but still nothing. The message I get is "Failed to retrieve share list from server: Connection refused" even from the shared directory on the same machine! My laptop was connecting successfully to another Mint-to-Mint network of mine while I was away. It, like the other machines, now cannot connect to any other machine.

The DHCP server shows that the machines all have IP addresses and they all are able to connect to the internet. I used a tool to locate devices on the network and they all show up as they should.

Does anyone have any ideas what I might try next? Have the machines gone into a snit because they were lonely while I was away? Are they simply tired from playing poker for Carnegie Mellon?

Supplemental: after some while (this is normal) the Windows share & Workgroup is working and I can get to the shared folders on other Linux Mint machines. The Avahi (Bonjour) method is still not working on any of the machines on the entire network.

I have gone to each machine and ran sudo service avahi-daemon restart and things returned to normal. It remains a serious puzzle why the Avahi daemon quit on ALL the machines on the network? If there had been 100 machines running it would have been a nightmare for an admin. I currently only have five but it has taken half a day to get things back to normal.
First program written in Algol for a KDF9 (just look up KDF9 on Wikipedia).

User avatar
Level 3
Level 3
Posts: 197
Joined: Fri Aug 10, 2007 11:57 am
Location: Atlanta, GA

Re: Mint to Mint LAN problems

Post by txba516 »

Hi Clive,

Not quite sure why avahi would quit on all of the systems like that. Have you considered using NFS instead of Samba though? It runs faster and is native for both the Mint and Mac systems.
The error message does indicate that either the service is not running and therefore not listening on the network (as you confirmed with the service restart) or the inbound traffic is being blocked by local firewalls on each Mint system.

LM17.2 x64 Cinnamon
Help the forums get answers faster! Mark your fixed problem thread as [SOLVED]

Post Reply

Return to “Ethernet”