Nemo not showing network

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
linux-cb
Level 1
Level 1
Posts: 9
Joined: Fri Jul 26, 2013 10:01 am
Location: Texas, USA

Nemo not showing network

Post by linux-cb » Tue Jun 20, 2017 6:57 pm

I upgraded from mint 17.3 to 18.1 cinnamon today.
My home network includes my Linux machine and several Windows 10 machines. Everything connects fine through samba. My Windows machines all see the Linux machine, and I can share files in both directions.
The problem is that the Nemo file manager shows "Windows Network", but does not show the MSHOME. It also does not show the Linux machine. All of this worked ok the the 17.3 version.

Thanks for any help on this.

Here is a copy of the global and networking sections of samba:

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of

# old workgroup = WORKGROUP

workgroup = MSHOME

name resolve order = bcast host lmhosts wins

# server string is the equivalent of the NT Description field
server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
# wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
; wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
dns proxy = no

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
; interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself. However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
; bind interfaces only = yes
Last edited by linux-cb on Wed Jun 21, 2017 2:34 pm, edited 2 times in total.

linux-cb
Level 1
Level 1
Posts: 9
Joined: Fri Jul 26, 2013 10:01 am
Location: Texas, USA

Re: Nemo not showing network

Post by linux-cb » Tue Jun 20, 2017 7:42 pm

Update.
Nemo shows my other computers now, not sure what happened as it didn't work all afternoon after multiple re-boots.

I had transferred a bunch of files from one of my Windows machines to Linux. During one transfer Nemo locked up. When I re-booted everything seems to work perfectly.

I hope the fix sticks!

linux-cb
Level 1
Level 1
Posts: 9
Joined: Fri Jul 26, 2013 10:01 am
Location: Texas, USA

Re: Nemo not showing network

Post by linux-cb » Wed Jun 21, 2017 2:38 pm

Well, the fix didn't stick. Nemo stopped showing anything on the network after a re-boot. No settings had been changed. Re-booted a number of times and it just won't show the network. File shares work, just can't do it through Nemo.

I'm out of ideas.

Post Reply

Return to “Ethernet”