Cannot Access LAN [Solved]

Questions about cabled networking
Forum rules
Before you post please read how to get help
rlsj
Level 1
Level 1
Posts: 16
Joined: Thu Mar 16, 2017 4:23 pm

Re: Cannot Access LAN

Postby rlsj » Sun Jul 30, 2017 5:10 pm

Always something else!

Bookmarking lets Nemo show, under Bookmarks, the line, "c on 192.168.1.2." After a restart, however, clicking on that bookmark results in a dialog box displaying,
"Enter password to unlock your login keyring / The login keyring did not get unlocked when you logged into your computer. / Password ?"

A keyring? What's that on a computer? Supplying my user_id password removes the dialog box. If I then click on the bookmark once more, I finally get to see items on the Windows machine. Is this only a disguised demand to see my password at login? This at every power-up?

Where can I suggest that some enterprising programmer kindly supply a common way to disable _all_ Linux security? For a private installation I can't believe hackers could cause half the grief involved in keeping them at bay! The firewall on the Internet modem, refusal to bite tempting bait and telephone confirmation of inquiries are sufficient protection.

Again after a restart, ignoring the new "bookmark," I invoke the terminal and key
nemo smb.//192.168.1.2

A dialog box appears requiring a WORKGROUP password. Yes, "none" works. Must I supply some kind of password at every login to access the network?

No.

From the tone of previous discussion I gather none of you gentlemen can suggest a way to avoid this. It seems all that remains is to try another distro.

rlsj
Level 1
Level 1
Posts: 16
Joined: Thu Mar 16, 2017 4:23 pm

Re: Cannot Access LAN

Postby rlsj » Sun Jul 30, 2017 5:13 pm

Always something else!

Bookmarking lets Nemo show, under Bookmarks, the line, "c on 192.168.1.2." After a restart, however, clicking on that bookmark results in a dialog box displaying,
"Enter password to unlock your login keyring / The login keyring did not get unlocked when you logged into your computer. / Password ?"

A keyring? What's that on a computer? Supplying my user_id password removes the dialog box. If I then click on the bookmark once more, I finally get to see items on the Windows machine. Is this only a disguised demand to see my password at login? This at every power-up?

Where can I suggest that some enterprising programmer kindly supply a common way to disable _all_ Linux security? For a private installation I can't believe hackers could cause half the grief involved in keeping them at bay! The firewall on the Internet modem, refusal to bite tempting bait and telephone confirmation of inquiries are sufficient protection.

Again after a restart, ignoring the new "bookmark," I invoke the terminal and key
nemo smb.//192.168.1.2

A dialog box appears requiring a WORKGROUP password. Yes, "none" works. Must I supply some kind of password at every login to access the network?

No.

From the tone of previous discussion I gather none of you gentlemen can suggest a way to avoid this. It seems all that remains is to try another distro.

rlsj
Level 1
Level 1
Posts: 16
Joined: Thu Mar 16, 2017 4:23 pm

Re: Cannot Access LAN

Postby rlsj » Sun Jul 30, 2017 5:21 pm

I apologize for repeating the previous post. Failing to see the graduation to Page 2, I assumed it had fallen through the cracks. Now I learn that this board does not permit deleting posts, despite offering a "Delete Post" button while editing. Unfortunately two screw-ups don't fix a mistake.

altair4
Level 18
Level 18
Posts: 8783
Joined: Tue Feb 03, 2009 10:27 am

Re: Cannot Access LAN

Postby altair4 » Sun Jul 30, 2017 5:31 pm

I gather none of you gentlemen can suggest a way to avoid this.

Yes there is another way and it's one I suggested above in my link.

Let's do it step by step.

[1] Create a mount point for the Windows share:

Code: Select all

sudo mkdir /media/Win10C

It doesn't have to be under /media. It can be in your home directory. But it has to be one of those.
[2] Edit /etc/fstab:

Code: Select all

gksu xed /etc/fstab

[3] Add this line to the end of the file:

Code: Select all

//192.168.1.2/c /media/Win10C cifs guest,uid=1000,noauto,user 0 0

Or, if you ended up passing a user name ( xxxx ) and password ( yyyy ) this line:

Code: Select all

//192.168.1.2/c /media/Win10C cifs username=xxxx,password=yyyy,uid=1000,noauto,user 0 0

Then save the file.

When you open Nemo you should have on the side panel - under Network - something labelled Win10C. When you click on it it will go to fstab, read the line you just added for instructions on how to mount, mount the C share on 192.168.1.2 as guest or the supplied credentials in fstab without prompting for a password, and display it's contents. You will also see a little mount icon next to the Win10C label that you can use to unmount the share.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

rlsj
Level 1
Level 1
Posts: 16
Joined: Thu Mar 16, 2017 4:23 pm

Re: Cannot Access LAN [Solved]

Postby rlsj » Sun Jul 30, 2017 11:21 pm

That did it, altair4. Thank you very much! Now I have, immediately after boot, a "Win10D" icon on my desktop. Double-clicking it brings up a Nemo window showing the Windows-10 D-drive -- with no mention of a password. Wonderful! I'll enjoy playing with this technique to make the C drive and drives on other machines similarly accessible.

Thanks again!


Return to “Ethernet”