Strangest issue with my ethernet connection

Questions about cabled networking
Forum rules
Before you post please read how to get help
florienb
Level 1
Level 1
Posts: 1
Joined: Sun Aug 13, 2017 1:11 pm

Strangest issue with my ethernet connection

Postby florienb » Sun Aug 13, 2017 1:16 pm

I am having the most annoying and strangest issue of all. My ethernet connection is intermittently dropping without any kind of notification: the internet just goes down without errors or anything.

The issue isn't originating from my LAN/WAN. WiFI and other wired devices connected via the same router are working just fine. My machine - 18.2 Sonya dual boot + win10, is the only one having this issue. I have to either restart the machine or bring down my primary eth interface with: sudo ifconfig enp2s0 downp and then ifconfig enp2s0 up

my eth configuration is:

Code: Select all

~ $ ifconfig
enp2s0    Link encap:Ethernet  HWaddr 20:cf:30:ae:58:47 
          inet addr:192.168.100.105  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::b07d:825:c034:3d0a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:582027 errors:0 dropped:0 overruns:0 frame:0
          TX packets:308665 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:695718503 (695.7 MB)  TX bytes:45127010 (45.1 MB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6926 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6926 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:500616 (500.6 KB)  TX bytes:500616 (500.6 KB)

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 
          inet addr:10.100.0.126  P-t-P:10.100.0.125  Mask:255.255.255.255
          inet6 addr: fe80::4d9b:187f:bad4:8105/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:979 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1195 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:517659 (517.6 KB)  TX bytes:409469 (409.4 KB)


The system is up to date too. Thank you for your help everyone.

User avatar
Lanser
Level 4
Level 4
Posts: 255
Joined: Mon Mar 08, 2010 5:12 am
Location: Salzburg AUT or Perth AUS or Somewhere in the Middle

Re: Strangest issue with my ethernet connection

Postby Lanser » Tue Aug 15, 2017 12:27 am

florienb. As a test, try downgrading network manager and see if the connection becomes stable.

Code: Select all

sudo apt-get install network-manager=1.2.2-0ubuntu0.16.04.4

Lanser
Please Don't Charge the Particles. It Only Gets Them Excited.

User avatar
trytip
Level 5
Level 5
Posts: 865
Joined: Tue Jul 05, 2016 1:20 pm

Re: Strangest issue with my ethernet connection

Postby trytip » Tue Aug 15, 2017 1:07 am

are you saying your win10 has the same issue? what is output

Code: Select all

iwconfig
create a new user with admin rights and try that out for a few hours to see if it's hardware or your mint profile (you can delete the user later)
I love Windows, they give my walls personality.

User avatar
jimbobs
Level 2
Level 2
Posts: 98
Joined: Sun Sep 25, 2016 10:50 am
Location: Toronto, Canada

Re: Strangest issue with my ethernet connection

Postby jimbobs » Sat Aug 19, 2017 9:56 am

trytip wrote:are you saying your win10 has the same issue? ...


My first question as well! If so, I would look towards BIOS or hardware issue/s.
Dell Inspiron 1525 Linux Mint 18.3 Sylvia Cinnamon 3.4.6


Return to “Ethernet”