recovery mode dns fails

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 1
Level 1
Posts: 48
Joined: Mon May 13, 2013 11:21 pm
Location: Pittsburgh, Pennsylvania U.S.A.

recovery mode dns fails

Post by Couch_Potato » Tue Sep 05, 2017 11:27 pm

Greetings again my fellow minters.

My recently purchased e6220 barebones (no os, no hdd) from a local Goodwill Store is having some issues. Sometimes when I attempt to perform a shutdown it sits and hangs. But I am hampered in my troubleshooting efforts due to revocery mode name resolution not working. I cannot easily fix broken packages or install new software. I am able to boot into recovery mode, but when I attempt to enable networking I get error messages that /etc/resolv.conf was not found, even though I can list them using ls there is no content. I tried running updatedb and ldconftig. to try and verify that resolv.conf was not there.

Code: Select all

I tried:  touch /etc/resolv.conf 

Code: Select all

 echo "nameserver name of server and ip address"  > /etc/resolv.conf

Code: Select all

echo "domain Home" >> /etc/resolv.conf

Apparently, systemd did not want to start up the resolver:

Code: Select all

systemctl start resolvconf.service 
would just hang.

I realize that it might be that recovery mode networking is only suppose to work over ethernet connection. But that is what I am trying to do. I get an ip address from my verizon router. I just cannot get dns resolving to function. Can anybody shed some light on this issue for me. I have be searching this site surprisingly noone that I can find gets these errors.

Your Couch_Potato
AMD FX-9380 8 Cores
Gigabyte 990FXA-UD3
2x8GB Corsairs 1600 mhz
Linux Mint Serena 18.1 Fresh
Dell e6220
8GB DDR3 320GB 7mm HDD
I5 2540m 2.60 Ghz
Linux Mint Sonya 18.2

Level 9
Level 9
Posts: 2998
Joined: Sun Aug 09, 2015 10:00 am

Re: recovery mode dns fails

Post by deepakdeshp » Wed Sep 06, 2017 9:04 am

Here is my resolve.conf

Code: Select all

cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
During installation time all these files are generated correctly rather than trying to generate them later,
The man page is

Code: Select all
You can see manpage of your system with

Code: Select all

man resolv.conf
Good luck
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18.3 Cinnamon 64 bit with AMD processor . Memory 8GB

Post Reply

Return to “Ethernet”