Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Sat Aug 12, 2017 6:28 pm


Post by schmeig » Sat Sep 09, 2017 7:28 pm

I have a HP laptop running 18.2 and the WIFI & LN gets around 4-7mbps at best. I have 100mbps internet. My older HP running 17.2 works fine on both and gets around 70mbps on WIFI and 98mbps on LAN. below is my system info. Anyone has any options or a better driver I should be using?

System: Host: Ballzzzz3 Kernel: 4.8.0-45-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm Distro: Linux Mint 18.2 Sonya
Machine: System: HP product: HP Notebook v: Type1ProductConfigId Chassis: type: 10
Mobo: HP model: 80C5 v: 97.32 Bios: Insyde v: F.11 date: 07/23/2015
CPU: Quad core Intel Pentium N3700 (-MCP-) cache: 1024 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12800
clock speeds: min/max: 480/2400 MHz 1: 2400 MHz 2: 2400 MHz 3: 955 MHz 4: 972 MHz
Graphics: Card: Intel Device 22b1 bus-ID: 00:02.0 chip-ID: 8086:22b1
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.32hz
GLX Renderer: Mesa DRI Intel HD Graphics 405 (Braswell)
GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio: Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:2284
Sound: Advanced Linux Sound Architecture v: k4.8.0-45-generic
Network: Card-1: Broadcom BCM43142 802.11b/g/n driver: wl bus-ID: 02:00.0 chip-ID: 14e4:4365
IF: wlp2s0 state: up mac: <filter>
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8136
IF: enp3s0 state: down mac: <filter>
Drives: HDD Total Size: 1320.3GB (31.0% used)
ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB serial: JA108NSB01GHRR
ID-2: USB /dev/sdb model: FreeAgent_Go size: 320.1GB serial: 6VD14Y41
Partition: ID-1: / size: 913G used: 81G (10%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 4.15GB used: 0.56GB (13%) fs: swap dev: /dev/sda3
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 52.0C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list.d/gezakovacs-ppa-xenial.list
deb http: // xenial main
deb-src http: // xenial main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http: // sonya main upstream import backport #id:linuxmint_main
deb http: // xenial main restricted universe multiverse
deb http: // xenial-updates main restricted universe multiverse
deb http: // xenial-backports main restricted universe multiverse
deb http: // xenial-security main restricted universe multiverse
deb http: // xenial partner
Info: Processes: 219 Uptime: 5 days Memory: 2203.9/3810.7MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Unknown python2.7 client inxi: 2.2.35

User avatar
Level 17
Level 17
Posts: 7774
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Slow WIFI & LAN

Post by catweazel » Mon Sep 11, 2017 2:56 am

Have you tried rebooting your router?
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Level 1
Level 1
Posts: 2
Joined: Sat Aug 12, 2017 6:28 pm

Re: Slow WIFI & LAN

Post by schmeig » Tue Sep 12, 2017 9:54 am

The gateway was rebooted. I actually reset it to defaults and reconfigured it as well. I had an older HP that was in this new laptop's place hard wired and it got speeds of 80mbps+. The laptop did all of a sudden speed up hard wired. I have no clue what the difference was and why it is working hardwired but the wireless is still getting 7mbps at best. My cell phone gets close to 50mbps at all times on the home network. I also tried all 3 drivers for the WIFI and 2 did not work at all.

I am going to be leaving this laptop hard wired for a while while I work on another PC to take its place so the laptop can be mobile like it should be. That said, this issues isn't top priority right now because it will be a month or so before I get done with the other PC but I would like to figure out the slow WIFI in the meantime if possible so when I do unplug it will get the speeds it should get. This is the only device on WIFI on the network getting these slow speeds. I bocked all MAC addresses to see if it was for some reason an issue with too many devices killing the bandwidth and the WIFI speeds did not change at all.

Post Reply

Return to “Ethernet”