Ethernet only works after resuming (SOLVED)

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Sun Oct 15, 2017 8:42 pm

Ethernet only works after resuming (SOLVED)

Post by jsilv » Sun Oct 15, 2017 8:54 pm

Hi everybody,

I am using Linuxmint Mate 18.2 64bits, on ASRock N68-GS4 FX R2.0 motherboard.

After booting, ethernet doesn't connect. I have also a wifi card installed and this connects normally. But if I suspend and then resume, the ethernet connects and disable wifi as expected.

Anyone can help me to solve this problem ?

Thank you

Code: Select all

jsb@jsb-desktop ~ $ inxi -Fxz
System:    Host: jsb-desktop Kernel: 4.10.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   Mobo: ASRock model: N68-GS4 FX R2.0
           Bios: American Megatrends v: P1.00 date: 10/05/2015
CPU:       Quad core AMD FX-4300 (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 30539
           clock speeds: max: 3800 MHz 1: 2600 MHz 2: 1800 MHz 3: 1800 MHz
           4: 1800 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 02:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.79hz
           GLX Renderer: Gallium 0.4 on NV98
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card NVIDIA MCP61 High Definition Audio
           driver: snd_hda_intel bus-ID: 00:05.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-37-generic
Network:   Card-1: NVIDIA MCP61 Ethernet
           driver: forcedeth port: c080 bus-ID: 00:07.0
           IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
           driver: rtl8192ce port: e800 bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 281.1GB (29.1% used)
           ID-1: /dev/sda model: SanDisk_SDSSDA12 size: 120.0GB
           ID-2: /dev/sdb model: SAMSUNG_HD161HJ size: 160.0GB
           ID-3: USB /dev/sdc model: Flash_Disk size: 1.1GB
Partition: ID-1: / size: 32G used: 6.3G (21%) fs: ext4 dev: /dev/sda3
           ID-2: /boot size: 283M used: 121M (46%) fs: ext4 dev: /dev/sda1
           ID-3: /home size: 31G used: 28G (96%) fs: ext4 dev: /dev/sdb9
           ID-4: swap-1 size: 3.36GB used: 0.35GB (10%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 7.2C mobo: N/A gpu: 40.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 190 Uptime: 21:15 Memory: 3339.4/3933.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Last edited by jsilv on Wed Oct 18, 2017 10:04 am, edited 1 time in total.

Level 1
Level 1
Posts: 2
Joined: Sun Oct 15, 2017 8:42 pm

Re: Ethernet only works after resuming

Post by jsilv » Wed Oct 18, 2017 10:04 am

I saw a video in YouTube,, solving the problem.

There, it is indicated to edit, as superuser, three files:

- in /etc/RC.LOCAL: add a line:
modprobe forcedeth msi=0 msix=0

- in /etc/init/KMOD.CONF, add a line after the begining of the script:
exec rmmod forcedeth

- in /etc/modprobe.d/BLACKLIST.CONF, add a line:
blacklist forcedeth

After that, open a terminal as root and execute:

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get install nvidia-current
I particularly did not execute this last comand, because it would install a video driver older than the existing.

For me, it solved after the second boot.

Post Reply

Return to “Ethernet”