Ethernet randomly dropping

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
noscail
Level 1
Level 1
Posts: 11
Joined: Mon Nov 20, 2017 1:34 pm

Ethernet randomly dropping

Post by noscail » Sun Dec 24, 2017 4:13 pm

Hi! I'm having a problem where at least once or twice a day the internet will drop connection, I have to go to network settings and turn it off and back on for it to work.

Does anyone have any idea what’s going on here?

deepakdeshp
Level 11
Level 11
Posts: 3704
Joined: Sun Aug 09, 2015 10:00 am

Re: Ethernet randomly dropping

Post by deepakdeshp » Mon Dec 25, 2017 2:00 am

May be a problem with service provider, with lan port, with lan cable, or router, or Mint or computer hardware.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

noscail
Level 1
Level 1
Posts: 11
Joined: Mon Nov 20, 2017 1:34 pm

Re: Ethernet randomly dropping

Post by noscail » Mon Dec 25, 2017 6:52 am

deepakdeshp wrote:May be a problem with service provider, with lan port, with lan cable, or router, or Mint or computer hardware.
Hi deepakdeshp! Thanks for the reply.

I think it is a problem with mint as opening the network connections and unticking wired on and off solves it. Is there a command I can type to get more info about my network settings?

deepakdeshp
Level 11
Level 11
Posts: 3704
Joined: Sun Aug 09, 2015 10:00 am

Re: Ethernet randomly dropping

Post by deepakdeshp » Mon Dec 25, 2017 10:36 am

Please post output of

Code: Select all

inxi -Fxz
here in code tags.
Are you using wired or wireless net?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

noscail
Level 1
Level 1
Posts: 11
Joined: Mon Nov 20, 2017 1:34 pm

Re: Ethernet randomly dropping

Post by noscail » Mon Dec 25, 2017 8:32 pm

deepakdeshp wrote:Please post output of

Code: Select all

inxi -Fxz
here in code tags.
Are you using wired or wireless net?
I am using a wired connection.

Here are the results of inxi -Fxz

System: Host: john-desktop Kernel: 4.10.0-42-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: Mobo: ASRock model: H77M
Bios: American Megatrends v: P1.00 date: 03/06/2012
CPU: Quad core Intel Core i5-3550 (-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26338
clock speeds: max: 3700 MHz 1: 2321 MHz 2: 2662 MHz 3: 2051 MHz
4: 2686 MHz
Graphics: Card: NVIDIA GM204 [GeForce GTX 980] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1920x1080@144.00hz
GLX Renderer: GeForce GTX 980/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio: Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 NVIDIA GM204 High Definition Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1
Card-3 Logitech G430 Surround Sound Gaming Headset
driver: USB Audio usb-ID: 002-003
Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 640.2GB (10.2% used)
ID-1: /dev/sda model: WDC_WD3200AAJS size: 320.1GB
ID-2: /dev/sdb model: M4 size: 64.0GB
ID-3: /dev/sdc model: Crucial_CT256MX1 size: 256.1GB
Partition: ID-1: / size: 209G used: 54G (27%) fs: ext4 dev: /dev/sdc5
ID-2: swap-1 size: 8.55GB used: 0.00GB (0%) fs: swap dev: /dev/sdc6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 43.0C mobo: N/A gpu: 0.0:40C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 213 Uptime: 7 min Memory: 1758.5/7945.6MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

Frankus333
Level 2
Level 2
Posts: 83
Joined: Mon Jan 06, 2014 10:33 pm
Location: Brisbane Australia

Re: Ethernet randomly dropping

Post by Frankus333 » Thu Dec 28, 2017 2:55 am

G'day folks

I have noticed this problem with both wired and wireless connections to my router, on three machines, after I upgraded from LM17.3KDE to LM18KDE quite a few months back. I just put up with it, disconnecting and reconnecting the network each time.

I have just recently upgraded to LM18.3KDE, and have also been taking offered kernal updates as well over the past couple of months. The other change I have made over the same time (last couple of months) is to remove the lock from my screen saver so I don't have to keep typing my password in (I use Ctrl-Alt-L if I leave the machine). The problem has seemed to be happening less often over the last couple of months, so I am not sure if it has been fixed for good. If it comes back in the next month or so I will report here if relevant.

Cheers
Frankus333: LM18.3 KDE 64 bit; HP 250 G5 laptop as desktop, 4GB RAM, CPU Celeron dual core N3060 2.5GHz, 500GB HDD (triple boot LM18.3 XFCE, Win10 1709)

Post Reply

Return to “Ethernet”