LAN Connection Wont Connect

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Tyler2234
Level 1
Level 1
Posts: 10
Joined: Fri Jan 12, 2018 2:04 pm

LAN Connection Wont Connect

Post by Tyler2234 » Tue Jan 16, 2018 6:49 pm

Hello,

I recently installed Linux Mint 18.3 (Cinnamon) and had everything working for the most part but I decided to switch to Linux Mint 18.3 (Mate) due to my graphics card not supporting hardware acceleration. I kept getting the "software rendering mode error."

Anyway, I installed Mate and now my Ethernet wont connect. It doesn't even act like it's trying to connect. However, if I run Mate in "Live" mode off of the USB the Ethernet connects right away. I'm at a loss for why it would work in "Live" mode but not when you run the OS off of the hard drive.

I was gonna try to get some screenshots of my system info but when I plugged a USB into the machine it gave me an error. USB's seemed to work just fine with Cinnamon, but they apparently aren't liking something with Mate.

-Tyler
Attachments
IMG_2720.jpg
IMG_2719.jpg

JeremyB
Level 18
Level 18
Posts: 8865
Joined: Fri Feb 21, 2014 8:17 am

Re: LAN Connection Wont Connect

Post by JeremyB » Tue Jan 16, 2018 6:56 pm

I would try installing Linux Mint 18, not 18.? and see if it works correctly, then you can upgrade using the Update Manager to Linux Mint 18.3 and keep using the LTS 4.4 kernel. Having the 4.13 kernel might be causing the issue as Ubuntu might not have updated some of the third party modules to support 4.13 in the Xenial repositories

Tyler2234
Level 1
Level 1
Posts: 10
Joined: Fri Jan 12, 2018 2:04 pm

Re: LAN Connection Wont Connect

Post by Tyler2234 » Wed Jan 17, 2018 4:39 pm

So I installed Linux Mint 18 but it still shows I have the 4.13 kernel. Am I missing something somewhere during the install process? I am brand new to using Linux so it's possible that I am making a dumb mistake somewhere.
Attachments
IMG_2757.jpg

Tyler2234
Level 1
Level 1
Posts: 10
Joined: Fri Jan 12, 2018 2:04 pm

Re: LAN Connection Wont Connect

Post by Tyler2234 » Thu Jan 25, 2018 12:22 pm

Does anybody have any ideas as to what I'm doing wrong with this? I've tried reloading Linux Mint 18.3 (Cinnamon), 18.3 (Mate), 18.0 (Mate) and every time it starts off with the 4.13 Kernel. When I very first loaded Linux Mint 18.3 (Cinnamon) it started off with the 4.10 Kernel I believe and I upgraded to the 4.13 kernel. It seems that when I'm reloading a new version of Linux it's not completely erasing everything and keeping the 4.13 kernel.

JeremyB
Level 18
Level 18
Posts: 8865
Joined: Fri Feb 21, 2014 8:17 am

Re: LAN Connection Wont Connect

Post by JeremyB » Thu Jan 25, 2018 6:04 pm

try this in terminal

Code: Select all

sudo ifconfig eno1 up && sudo ifconfig eno2 up

Post Reply

Return to “Ethernet”