Page 1 of 1

LAN Connection Wont Connect

Posted: Tue Jan 16, 2018 6:49 pm
by Tyler2234
Hello,

I recently installed Linux Mint 18.3 (Cinnamon) and had everything working for the most part but I decided to switch to Linux Mint 18.3 (Mate) due to my graphics card not supporting hardware acceleration. I kept getting the "software rendering mode error."

Anyway, I installed Mate and now my Ethernet wont connect. It doesn't even act like it's trying to connect. However, if I run Mate in "Live" mode off of the USB the Ethernet connects right away. I'm at a loss for why it would work in "Live" mode but not when you run the OS off of the hard drive.

I was gonna try to get some screenshots of my system info but when I plugged a USB into the machine it gave me an error. USB's seemed to work just fine with Cinnamon, but they apparently aren't liking something with Mate.

-Tyler

Re: LAN Connection Wont Connect

Posted: Tue Jan 16, 2018 6:56 pm
by JeremyB
I would try installing Linux Mint 18, not 18.? and see if it works correctly, then you can upgrade using the Update Manager to Linux Mint 18.3 and keep using the LTS 4.4 kernel. Having the 4.13 kernel might be causing the issue as Ubuntu might not have updated some of the third party modules to support 4.13 in the Xenial repositories

Re: LAN Connection Wont Connect

Posted: Wed Jan 17, 2018 4:39 pm
by Tyler2234
So I installed Linux Mint 18 but it still shows I have the 4.13 kernel. Am I missing something somewhere during the install process? I am brand new to using Linux so it's possible that I am making a dumb mistake somewhere.

Re: LAN Connection Wont Connect

Posted: Thu Jan 25, 2018 12:22 pm
by Tyler2234
Does anybody have any ideas as to what I'm doing wrong with this? I've tried reloading Linux Mint 18.3 (Cinnamon), 18.3 (Mate), 18.0 (Mate) and every time it starts off with the 4.13 Kernel. When I very first loaded Linux Mint 18.3 (Cinnamon) it started off with the 4.10 Kernel I believe and I upgraded to the 4.13 kernel. It seems that when I'm reloading a new version of Linux it's not completely erasing everything and keeping the 4.13 kernel.

Re: LAN Connection Wont Connect

Posted: Thu Jan 25, 2018 6:04 pm
by JeremyB
try this in terminal

Code: Select all

sudo ifconfig eno1 up && sudo ifconfig eno2 up