LAN connection will not automatically start when set to connect to VPN automatically

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Bender72
Level 1
Level 1
Posts: 22
Joined: Mon Jul 18, 2016 8:22 pm

LAN connection will not automatically start when set to connect to VPN automatically

Post by Bender72 » Fri Jan 26, 2018 6:39 pm

I want my HTCP (which runs Mint 18.3) to automatically use my VPN.

The wired network connection auto-connects fine without VPN. Now I configured the VPN connection in the Network Manager, also works fine when I manually activate it.

The problem: when I set the wired connection to autoconnect to the VPN at startup, a popup appears asking for the password to the login keyring after each start, even though I use auto-login, and the password for the login keyring is the same as for the main user account.

The only solution I could find for this was to replace the login keyring password by an empty password. This solution (which I wasn't really happy with) solved the password request problem, but now my machine doesn't automatically connect to the wired network at all anymore, even though it is set to auto-connect to the network, and auto-connect to the VPN. I have to manually turn on the wired connection after reboot.

When I de-activate the option to auto-connect to the VPN, then the wired network is again automatically connected to.

Ideally, I'd like the VPN credentials be protected by a password, but have auto-connect to VPN without having to enter any passwords. Again, it's a HTCP in my living room and the only input device I regularly use to interact with it is an IR remote.

Thanks for any help!

Post Reply

Return to “Ethernet”