No connectivity with Realtek RTL8101 ethernet

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Pat Sanders
Level 1
Level 1
Posts: 4
Joined: Fri Feb 09, 2018 10:09 pm

No connectivity with Realtek RTL8101 ethernet

Post by Pat Sanders » Sat Feb 10, 2018 6:05 am

I've decided to give Linux a try and so far it's been a good experience. I've been able to find solutions to the various problems I've encountered but I'm completely stuck now and need some help in diagnosing this one.

My ethernet connection is not working at all. Mint installed the r8169 driver during installation. It didn't work so I downloaded and installed the r8101 driver from Realtek. Still no luck in getting it to work.

I've got a fixed ip address, no DHCP. It says that the connection is established but I'm not seeing any activity. No flickering lights on the router and I'm unable to ping the router or any external ip addresses. I've gone over the network settings numerous times but I cannot see anything wrong.

If I boot to Windows 8 there is no problem with ethernet connectivity so it's not a hardware fault.

Code: Select all

$ dmesg | grep r8101
[    2.015421] r8101: loading out-of-tree module taints kernel.
[    2.015526] r8101: module verification failed: signature and/or required key missing - tainting kernel
[    2.015944] r8101 Fast Ethernet driver 1.032.04-NAPI loaded
[    2.068232] r8101 0000:03:00.0 (unnamed net_device) (uninitialized): Invalid ether addr ff:ff:ff:ff:ff:ff
[    2.068242] r8101 0000:03:00.0 (unnamed net_device) (uninitialized): Random ether addr d0:52:3b:b5:bf:1c
[    2.119134] r8101: This product is covered by one or more of the following patents: US6,570,884, US6,115,776, and US6,327,625.
[    2.119153] r8101  Copyright (C) 2017  Realtek NIC software team <nicfae@realtek.com> 
[    2.121336] r8101 0000:03:00.0 enp3s0: renamed from eth0
[   38.196087] r8101: enp3s0: link up


$ inxi -NS
System:    Host: z-SATELLITE-NB10t-A-10F Kernel: 4.13.0-32-generic x86_64 (64 bit) Desktop: Xfce 4.12.3
           Distro: Linux Mint 18.3 Sylvia
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8101


$ ifconfig
enp3s0    Link encap:Ethernet  HWaddr d0:52:3b:b5:bf:1c  
          inet addr:192.168.1.151  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:55 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:89 Base address:0xd000 

Pat Sanders
Level 1
Level 1
Posts: 4
Joined: Fri Feb 09, 2018 10:09 pm

Re: No connectivity with Realtek RTL8101 ethernet

Post by Pat Sanders » Fri Feb 16, 2018 12:29 am

I decided to live boot Mint 17.1 (kernel 3.13) and the ethernet works. It properly detects the MAC address which failed with Mint 18.3.

I've tried installing other kernel versions in Mint 18.3 going back to 4.4 but all had the same problem. I also tried other Linux distros with various kernel versions 4.x but they didn't work so this isn't just a Mint problem.

I have to conclude that there is a problem between the driver and kernel versions 4.x, although the RealTek site says
LINUX driver for kernel up to 4.7
Anyone got any ideas how I can get the ethernet to work in Mint 18.3?

Charlie
Level 4
Level 4
Posts: 282
Joined: Sun Jul 09, 2017 10:09 am
Location: Eng-er-land

Re: No connectivity with Realtek RTL8101 ethernet

Post by Charlie » Sat Feb 17, 2018 8:37 am

I always read this site when I have a problem with Realtek.

https://sites.google.com/site/easylinux ... reserve-7

Pat Sanders
Level 1
Level 1
Posts: 4
Joined: Fri Feb 09, 2018 10:09 pm

Re: No connectivity with Realtek RTL8101 ethernet

Post by Pat Sanders » Sun Feb 18, 2018 12:20 am

So I've installed Mint 17.1 and installed numerous kernels until I found the one at which it stopped working.

Kernels up to 3.16.0-31 work.
Kernels 3.16.0-33 and above all have the problem.

Where do I go from here? Is this a kernel problem or a driver problem?

md419
Level 2
Level 2
Posts: 60
Joined: Thu Sep 22, 2011 2:34 pm

Re: No connectivity with Realtek RTL8101 ethernet

Post by md419 » Sun Feb 25, 2018 5:21 pm

Searching Google regarding this particular adapter and associated drivers turns up a lot of similar results for some Linux users.

My suggestion would be to use an external USB ethernet port with a "better compatible" Linux chipset.

Good luck!

Pat Sanders
Level 1
Level 1
Posts: 4
Joined: Fri Feb 09, 2018 10:09 pm

Re: No connectivity with Realtek RTL8101 ethernet

Post by Pat Sanders » Mon Feb 26, 2018 1:16 pm

Thanks md419
That's the same conclusion I've reached also.

Post Reply

Return to “Ethernet”