Issue with ethernet driver

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Spender411
Level 1
Level 1
Posts: 4
Joined: Sat May 05, 2018 4:03 am

Issue with ethernet driver

Post by Spender411 » Sat May 05, 2018 4:28 am

Hello, guys.

When I installed Linux Mint, I noticed that it didn't see my ethernet cable. In Network settings it was said "Cable unplugged". I have Windows 7 installed on my laptop as well, so I am 100% sure that it is not a hardware issue.
Trying to fix it, I went to realtek official website and downloaded recommended driver for my ethernet card (r8101). After installation of the driver, Linux recognized the cable. Kind of. It now goes crazy with statuses connected/cable unplugged. Connection drops and reconnects every few seconds. And when it stays connected for some time, I cannot access web or ping google (100% packets loss).

What I tried so far:
1) blacklisting r8169 driver
2) using sudo dhclient
3) trying to set manual network configuration.


I will be really helpful if someone points me where I can find a solution.
Thank you!

Code: Select all

ifconfig eth0
eth0: error fetching interface information: Device not found

Code: Select all

inxi -Fxz
System:    Host: spender-Inspiron-N5110 Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron N5110
           Mobo: Dell model: 0FXK2Y v: A09 Bios: Dell v: A09 date: 09/30/2011
CPU:       Quad core Intel Core i7-2760QM (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19155
           clock speeds: max: 3500 MHz 1: 820 MHz 2: 855 MHz 3: 801 MHz
           4: 943 MHz 5: 854 MHz 6: 815 MHz 7: 813 MHz 8: 819 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: NVIDIA GF108M [GeForce GT 525M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.99hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GF108 High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8101 v: 1.032.04-NAPI port: d000 bus-ID: 05:00.0
           IF: enp5s0 state: down mac: <filter>
           Card-2: Intel Centrino Wireless-N 1030 [Rainbow Peak]
           driver: iwlwifi bus-ID: 09:00.0
           IF: wlp9s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (3.4% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 87G used: 31G (37%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 2.04GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 240 Uptime: 30 min Memory: 1070.4/7882.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Code: Select all

ifconfig
enp5s0    Link encap:Ethernet  HWaddr 24:b6:fd:47:1e:c7  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:141 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:40 Base address:0x9000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1997 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1997 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:185956 (185.9 KB)  TX bytes:185956 (185.9 KB)

wlp9s0    Link encap:Ethernet  HWaddr 4c:eb:42:77:80:9e  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::eb0c:574e:2a83:269f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7070 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7422 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4647615 (4.6 MB)  TX bytes:950759 (950.7 KB)

Spender411
Level 1
Level 1
Posts: 4
Joined: Sat May 05, 2018 4:03 am

Re: Issue with ethernet driver

Post by Spender411 » Sat May 05, 2018 5:27 am

Small update:

I installed a newer kernel (4.4.0-122-generic), but there is no wired connection option at all.

https://i.imgur.com/wpCVSwc.png

Spender411
Level 1
Level 1
Posts: 4
Joined: Sat May 05, 2018 4:03 am

Re: Issue with ethernet driver

Post by Spender411 » Sun May 06, 2018 3:10 pm

Ok, looks like there is no answer to my issue =( I will just use wi-fi.

Maybe someone can tell me how to delete driver r8101? It causes micro freezes every now and then. So far the solution has been booting into 4.4.0 kernel, but I'd rather use the kernel that Linux Mint team wants me to use.
I tried blacklisting the driver, but driver still loads.

User avatar
AZgl1500
Level 9
Level 9
Posts: 2610
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Issue with ethernet driver

Post by AZgl1500 » Sun May 06, 2018 8:40 pm

you can use rfkill to turn it off


this will show you which one is which $ rfkill list

this will turn off 0 $ rfkill block 0


this is what 'list' shows for me:

$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Post Reply

Return to “Ethernet”