[Workaround] Network Issue With LM18.3 and Kernel 4.15.0-24

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
allanr
Level 1
Level 1
Posts: 17
Joined: Tue Feb 07, 2017 1:02 pm
Location: Scotland

[Workaround] Network Issue With LM18.3 and Kernel 4.15.0-24

Post by allanr » Wed Jul 04, 2018 6:36 am

After accepting the latest kernel 4.15.0-24 update, I realised my laptop wired Ethernet connection would not reconnect after sleep. It was ok after first boot, but failed to connect after any period of sleep.

Reverting to 4.13.0-45 restored normal operation.

I'm posting this in case it helps others. There are also Cinnamon crashing issues with kernel 4.15.0-24 and LM 18.3.
Hopefully the upgrade to LM19 (which uses kernel 4.15) won't present such problems.
Image

User avatar
catweazel
Level 17
Level 17
Posts: 7490
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: [Workaround] Network Issue With LM18.3 and Kernel 4.15.0-24

Post by catweazel » Wed Jul 04, 2018 6:53 am

allanr wrote:
Wed Jul 04, 2018 6:36 am
After accepting the latest kernel 4.15.0-24 update, I realised my laptop wired Ethernet connection would not reconnect after sleep. It was ok after first boot, but failed to connect after any period of sleep.

Reverting to 4.13.0-45 restored normal operation.

I'm posting this in case it helps others. There are also Cinnamon crashing issues with kernel 4.15.0-24 and LM 18.3.
Hopefully the upgrade to LM19 (which uses kernel 4.15) won't present such problems.
4.15.0-24 is causing problems across the board, not just with ethernet.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

JeremyB
Level 19
Level 19
Posts: 9150
Joined: Fri Feb 21, 2014 8:17 am

Re: [Workaround] Network Issue With LM18.3 and Kernel 4.15.0-24

Post by JeremyB » Wed Jul 04, 2018 7:19 am

Various issues with Linux Mint 18.x can be expected into August as I don't expect Ubuntu to update the 16.04 repositories that Mint 18 uses before then as most Ubuntu 16.04 users won't be using 4.15 before then

Post Reply

Return to “Ethernet”