Automatic network connection gradually slower (over time) to connect after restart (Qualcomm Atheros AR8151)

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
User avatar
jameskga
Level 3
Level 3
Posts: 182
Joined: Sat Jun 04, 2016 8:23 pm

Automatic network connection gradually slower (over time) to connect after restart (Qualcomm Atheros AR8151)

Post by jameskga » Wed Jul 11, 2018 3:13 am

Hello. How the hell are you guys? I have a nuanced issue that requires a bit of explanation on my part.

Why does my ethernet connection take so long to connect after booting into Mint?

I assume the ethernet port on my PC is the Qualcomm Atheros AR8151 listed in lspci below. I've noticed on clean installations of any Mint distribution, ethernet connects as soon as the desktop loads. And then gradually - over a long stretch of time - it is slower to automatically connect. It takes a few weeks for this issue to appear, and then over months it gets worse. What up w/ dat? OK, yes: It connects when I take the mouse and tell it to connect -- BUT, when I do this, my VPN doesn't stay reliably connected. It drops out and I have to manually re-enable it! And this only happens when I manually connect my home internet connection from the taskbar. If I leave it alone and don't touch connect via Network Manager, my VPN stays connected. In fact, it never fails (or disconnects). Therefore, I've learned to log into my desktop, and walk away. I will complete a short task, and then a few minutes later I can use the PC with Internet...usually takes about 5 minutes. On the Ubuntu version, this could take 10 minutes. Debian edition is way better, can't wait for 3. Bet it'll only take two minutes!

I should add that I am a lean PC user, and install no extra software than what comes with Mint. Apart from a custom desktop background, and cinnamon menu icon, my Mint installation is clean as Sheen. Wait...

More details:
I use the OpenVPN protocol that comes preinstalled with Mint. My VPN is configured (I checked a box) to connect automatically as soon as my home internet connects.

I have this issue on both LMDE2 and Ubuntu-based distributions, regardless of DE. Doesn't happen with Windows.

lspci

Code: Select all

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset Family LPC Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 770] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)
03:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 01)
05:00.0 Ethernet controller: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet (rev c0)
06:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
07:00.0 IDE interface: ASMedia Technology Inc. ASM1061 SATA IDE Controller (rev 01)
LMDE 2 Cinnamon (64-bit)
I am out there

Post Reply

Return to “Ethernet”