No ethernet connection

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
tomson
Level 1
Level 1
Posts: 2
Joined: Sat Jul 21, 2018 6:58 am

No ethernet connection

Post by tomson » Sat Jul 21, 2018 8:01 am

I have a simple home network set up over wifi router:
(1) via WiFi all the devices got connected OK
(2) via LAN one of the LinuxMint 18.3 laptops is unable to connect to network, connection status - cable is not connected
How could I resolve that connection issue?

There is 'sudo lshw -C network' response:
*-network
описание: Беспроводной интерфейс
продукт: AR9287 Wireless Network Adapter (PCI-Express)
производитель: Qualcomm Atheros
физический ID: 0
сведения о шине: pci@0000:02:00.0
логическое имя: wlp2s0
версия: 01
серийный №: 78:dd:08:cc:79:35
разрядность: 64 bits
частота: 33MHz
возможности: pm msi pciexpress bus_master cap_list ethernet physical wireless
конфигурация: broadcast=yes driver=ath9k driverversion=4.13.0-45-generic firmware=N/A ip=192.168.1.105 latency=0 link=yes multicast=yes wireless=IEEE 802.11
ресурсы: IRQ:16 память:e7a00000-e7a0ffff
*-network
описание: Ethernet interface
продукт: 88E8057 PCI-E Gigabit Ethernet Controller
производитель: Marvell Technology Group Ltd.
физический ID: 0
сведения о шине: pci@0000:04:00.0
логическое имя: enp4s0
версия: 10
серийный №: 54:42:49:0d:b0:d1
capacity: 1Gbit/s
разрядность: 64 bits
частота: 33MHz
возможности: pm msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
конфигурация: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
ресурсы: IRQ:29 память:e5220000-e5223fff ioport:a000(размер=256) память:e5200000-e521ffff

incontext
Level 1
Level 1
Posts: 2
Joined: Sun Jan 29, 2017 10:38 pm

Re: No ethernet connection

Post by incontext » Sat Jul 21, 2018 1:48 pm

I haven't got a solution but if it's the same as what has happened to me, did you do an systemd update sometime in the last few days?

The update from version 237-3ubuntu10 (bionic) to 237-3ubuntu10.2 (bionic-updates).

There appears to be a bug. They don't have an answer yet as far as I can see either. https://bugs.launchpad.net/ubuntu/+sour ... ug/1623068

I'm searching for answers, lucky I have a tablet. I have downloaded the previous version and looking for the right way to try and force the install.

I haven't translated your post yet, thought I should add, that mine is a laptop too, and it's also affecting both wifi and ethernet.

Abdullah A
Level 1
Level 1
Posts: 4
Joined: Sat Aug 11, 2018 11:31 am

Re: No ethernet connection

Post by Abdullah A » Sat Aug 11, 2018 10:59 pm

I am also having the same issue. i revently downloaded a large update for linux mint and before i was able to use my ethernet cord just fine. After the download however the ethernet cord no longer works. I know for a fact that this is a linux issue because the same cord still works with my other laptop.

kerryww4
Level 1
Level 1
Posts: 3
Joined: Sun Feb 05, 2017 5:58 pm

Re: No ethernet connection

Post by kerryww4 » Sun Aug 12, 2018 7:10 pm

I'm also having the same problem. When I click on Networks all I get is a Windows Network icon. When I click it I get a dialogue box asking me if I want to cancel. Or sometimes I get a box saying that it can't mounted. Then I rebooted,

After the reboot I clicked on the Windows Network icon it bought up a slightly larger Workgroup icon. When I clicked on that and the screen froze I then did a sudo apt-get update. and then did a restart.

When the machine rebooted I opened up the Networks folder and clicked on the Windows Network icon I again got a dialogue box saying that the network can't be mounted. Then closed the page and reopened it.

I then clicked on the Networks icon and up came the other machines on my network. It works!@##$

Well, it kind of worked. I then clicked on one of the icons and the screen froze with: -
Windows shares on workgroup is not responding.

I closed the page and opened a new Networks page and clicked on Windows Networks which then opened a page with a bigger Window Network icon. I clicked on that and the page went blank. I then......

I've now concluded that a simple USB stick and a pair of running shoes is the final solution. Problem solved.

Post Reply

Return to “Ethernet”