[Solved] Need help to get internet on Linux Mint guest on VirtualBox

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
harald12
Level 1
Level 1
Posts: 6
Joined: Mon Jul 23, 2018 7:05 am

[Solved] Need help to get internet on Linux Mint guest on VirtualBox

Post by harald12 » Mon Jul 23, 2018 7:16 am

host: Win 7
guest Linux Mint 18 Sarah

I have tried everything I found on the web but it is still not working.

I tried to set autoneg to off with ethtool, but the setting is not changing. Restarted the interface (worked with ifconfig, ifup and ifdown return 'unknown interface').
With 'sudo nano /etc/rc.local' I have set autoneg to off and speed to 100. As you can see below, it says 'Link detected yes' , but still not working.
I have switched between NAT and bridged and rebooted a lot of times , at bridged I used the option promiscuous mode off and 'allow vms'.
I have set DNS to 8.8.8.8 and 208.67.222.222 and 208.67.220.220.

Nothing of this worked, it still does not get internet.. I have ran out of ideas and would appreciate any hints what else can be tried to get the internet working on the guest VM.


Here is information about the network interface and also the output of inxi -Fxz on the guest :

/sbin/ifconfig -a

Code: Select all

enp0s3    Link encap:Ethernet  HWaddr 08:00:27:ef:d1:e4 
          inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::b9c4:5463:5b1:1650/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35 errors:0 dropped:0 overruns:0 frame:0
          TX packets:165 errors:25 dropped:0 overruns:0 carrier:4
          collisions:0 txqueuelen:1000
          RX bytes:11125 (11.1 KB)  TX bytes:49712 (49.7 KB)
          Interrupt:9 Base address:0xd020 


ethtool enp0s3:

Code: Select all

    Settings for enp0s3:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
       Advertised pause frame use: No
       Advertised auto-negotiation: Yes
       Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                            100baseT/Half 100baseT/Full
       Link partner advertised pause frame use: Symmetric
       Link partner advertised auto-negotiation: Yes
       Speed: 100Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 0
       Transceiver: internal
       Auto-negotiation: on
    Cannot get wake-on-lan settings: Operation not permitted
       Current message level: 0x00000007 (7)
                    drv probe link
       Link detected: yes




inxi -Fxz

Code: Select all

System:    Host: LinuxMint Kernel: 4.4.0-21-generic i686 (32 bit gcc: 5.3.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18 Sarah
Machine:   System: innotek (portable) product: VirtualBox v: 1.2
           Mobo: Oracle model: VirtualBox v: 1.2
           Bios: innotek v: VirtualBox date: 12/01/2006
CPU:       Single core Intel Core i5-5300U (-UP-) cache: 3072 KB
           flags: (nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3) bmips: 4589 speed: 2294 MHz (max)
Graphics:  Card: InnoTek Systemberatung VirtualBox Graphics Adapter
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.3 drivers: vboxvideo (unloaded: fbdev,vesa)
           Resolution: 1496x724@59.85hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel 82801AA AC'97 Audio Controller
           driver: snd_intel8x0 ports: d100 d200 bus-ID: 00:05.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
           driver: pcnet32 port: d020 bus-ID: 00:03.0
           IF: enp0s3 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 10.7GB (54.0% used)
           ID-1: /dev/sda model: VBOX_HARDDISK size: 10.7GB
Partition: ID-1: / size: 8.7G used: 4.4G (54%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 1.21GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 170 Uptime: 48 min Memory: 376.8/1019.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.3.1
Last edited by harald12 on Wed Jul 25, 2018 3:03 am, edited 1 time in total.

Azvareth
Level 1
Level 1
Posts: 13
Joined: Sun Aug 27, 2017 9:52 am
Location: Sweden

Re: Need help to get internet on Linux Mint guest on VirtualBox

Post by Azvareth » Mon Jul 23, 2018 6:04 pm

Note: I am no expert here so do not flame me, but I though I would try to do some logical error detection with you.

First things first

1. Your VBox is version 1.2?
Mobo: Oracle model: VirtualBox v: 1.2
Bios: innotek v: VirtualBox date: 12/01/2006
It seems a bit old? could this be an issue?

2. I know Mint is based on Ubuntu? or at least it was so. according to
https://askubuntu.com/questions/946381/ ... apter-type
they say (which also is the recommended answer there)
in your case, if you plan to run Ubuntu 17.04 as guest OS, VirtualBox should select, by default, the AMD PCNet FAST III adapter
is the Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] the same?

3. Do you have any connection out att all between the host and the client ? could you, for example FTP or ping between the two?

4. If so Is the VM blocked in Windows FW?

[Meanwhile I am downloading software to see if I got the same error]

Azvareth
Level 1
Level 1
Posts: 13
Joined: Sun Aug 27, 2017 9:52 am
Location: Sweden

Re: Need help to get internet on Linux Mint guest on VirtualBox

Post by Azvareth » Mon Jul 23, 2018 7:13 pm

Ok... I downloaded Mint and installed, please forget my other post...


I did a clean install on Windows 10x64 AMD, VBox 5.2.8
using Mint Sarah XFCE 32
I choose Bridged network during install and the data I got from Mint client is
almost the same as you have posted.

And right out of the box, the network did function.

my ifconfig output differs from yours as I have a lan and the assigned LAN adress listed there
I am using adresses on the 192.168.1.### serie

ethtool enp0s3: exactly the same output


the inxi -Fxz command tells me we are using exactly the same system (except for CPU and other irrelevant stuff)

a minor diff on the underlined part though, I do not think it matters

Network: Card: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
driver: pcnet32 port: d020 bus-ID: 00:03.0
IF: enp0s3 state: unknown speed: 100 Mbps duplex: full
mac: <filter>


So on the Linux side, it seems to be the same.... suggesting some other error?

Have you perhaps tried a live Linux version with network support to see if that works? or a new install using default settings to rule out other errors?

harald12
Level 1
Level 1
Posts: 6
Joined: Mon Jul 23, 2018 7:05 am

Re: Need help to get internet on Linux Mint guest on VirtualBox

Post by harald12 » Tue Jul 24, 2018 6:20 am

Hi and thanks a lot for the answers.

yes, the ip address seems actually good.
I tested now pinging the address from the host and have the following:
bridge - host can ping guest IP, no internet on guest. (IP of guest is different than with NAT)
- tracert shows there is only one hop (nothing in between host and guest)
NAT - host cannot ping guest IP, no internet on guest.

This is actually a clean install, I haven't installed anything else on it.

I will search what a live Linux version with network support is and maybe test it and let you know.

LE:
The extension pack for virtual box was added and now I have installed Guest additions, which brought no change.


LE2: I found out that it needs to have proxy configured. it might be that it is needed for each application separately. I found on the web instructions how to set proxy systemwide on Mint 17 , for 18 I did not find yet.. Maybe you have an idea here..

harald12
Level 1
Level 1
Posts: 6
Joined: Mon Jul 23, 2018 7:05 am

Re: Need help to get internet on Linux Mint guest on VirtualBox

Post by harald12 » Tue Jul 24, 2018 8:47 am

I tried these settings, without success: http://www.ictsteps.com/2013/10/how-to- ... -mint.html

I have used a company intern proxy.

Azvareth
Level 1
Level 1
Posts: 13
Joined: Sun Aug 27, 2017 9:52 am
Location: Sweden

Re: Need help to get internet on Linux Mint guest on VirtualBox

Post by Azvareth » Tue Jul 24, 2018 10:18 am

Hi again, as I said initially, I am no expert...

And I am not using proxy so I am more blind then ususal...

However, I did a search on the topic....

For example there is a lot of reference that the client vm browser should be using the proxy settings your main host does and these settings should be applied in the browser somewhere. have you tried that? I guess those settings override systemwide settings, if that works then you should be able to use the systemwides as well.

When using bridged mode your Linux client have a separate network adapter (or something).

How hard is the restricted networks settings to the company you work for? It may be it is blocked down the line as an unknown device? And if they are blocking not known devices, depending on the work rules in your contry, you might "go out of line".?

harald12
Level 1
Level 1
Posts: 6
Joined: Mon Jul 23, 2018 7:05 am

Re: Need help to get internet on Linux Mint guest on VirtualBox

Post by harald12 » Wed Jul 25, 2018 3:02 am

Yes, first I thought this might be the cause as well, but since Windows guests have internet, I interpreted as Linux should work as well.

I followed your advice and checked all options the browser has for proxy settings. And the setting "use system proxy settings" did it, now internet is working, thank you !

On the other hand if I ping google in a terminal there is no repsonse, so it looks like the setting is application specific.

I tested on another distribution, Manjaro as well, which showed the same behavior. Here "use system proxy settings" did not work, but instead using the same settings as the browser on the host gave the machine internet connection. I cannot explain the difference as I have deleted the proxies I have set from the link I mentioned. On the host the autodiscovery http://wpad/wpad.dat is set.

Thanks again for the hint :)

Azvareth
Level 1
Level 1
Posts: 13
Joined: Sun Aug 27, 2017 9:52 am
Location: Sweden

Re: [Solved] Need help to get internet on Linux Mint guest on VirtualBox

Post by Azvareth » Wed Jul 25, 2018 2:22 pm

Glad it helped the immidiate problem.

However, In my world if Windows guest can get system wide access to internet, the same should be possible with Mint/Linux. I can't give more help on the subject though, perhaps someone else could fill in.?

I could see some problems later on, if systemwide access is not working, that is updates and if you wish to install some application from the program installer later on.

So... na, not really solved, just a workaround.

harald12
Level 1
Level 1
Posts: 6
Joined: Mon Jul 23, 2018 7:05 am

Re: [Solved] Need help to get internet on Linux Mint guest on VirtualBox

Post by harald12 » Fri Jul 27, 2018 4:10 am

yes, I found on the web a way to set proxy for apt for example. Theoretically it should be possible to set proxy for applications.

harald12
Level 1
Level 1
Posts: 6
Joined: Mon Jul 23, 2018 7:05 am

Re: [Solved] Need help to get internet on Linux Mint guest on VirtualBox

Post by harald12 » Mon Jul 30, 2018 11:46 am

Now it does not work again on Linux Mint. On Manjaro it does and there are identical settings:

autoamtic proxy wpad/wpat.dat on the Windoes host, both set as bridge connection in VBox and autoamtic proxy wpad/wpat.dat in Firefox on guest VM.

It might also be worth metnioneing that Manjaro actually has a system utility to set up proxy, where I have set the same as above. Mint unfortunately does not have such an utility.

Post Reply

Return to “Ethernet”