(Resolved) Router wakes Computer with kernel 4.15.0-30

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
User avatar
kyphi
Level 8
Level 8
Posts: 2321
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

(Resolved) Router wakes Computer with kernel 4.15.0-30

Post by kyphi » Wed Aug 08, 2018 2:00 am

Ever since upgrading from kernel 4.15.0-23 to -24, -29, -30, I have had my router, when first powered on, also start my computer. This results in a number of internet-dependent applications having to be re-set when the Network Manager has to re-establish a connection.

There is no provision in my BIOS (American Megatrends) to circumvent this happening other than wake by keyboard or wake by mouse which are both disabled. Nor is there a setting for wake-on-lan in my router (Fritzbox 7490).

Using the ethtool, wake-on is set to d (disable) as is the setting in Network Connections and these settings are still in place after a reboot.

Although I can easily circumvent this phenomenon by reverting to kernel 4.15.0-23, I am puzzled as to 'why it is so' and would welcome suggestions for a solution.
Last edited by kyphi on Fri Aug 10, 2018 11:35 pm, edited 1 time in total.
Linux Mint 19 Cinnamon - 64bit

User avatar
kyphi
Level 8
Level 8
Posts: 2321
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Router wakes Computer with kernel 4.15.0-30

Post by kyphi » Fri Aug 10, 2018 11:34 pm

The fault is in /lib/modules/4.15.0-30-generic/kernel/drivers/net/ethernet/atheros/alx/alx.ko

Development Team is aware and working on a solution.

So, Patience Grasshopper :D
Linux Mint 19 Cinnamon - 64bit

User avatar
kyphi
Level 8
Level 8
Posts: 2321
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: (Resolved) Router wakes Computer with kernel 4.15.0-30

Post by kyphi » Sun Aug 26, 2018 3:29 am

Posted in case anyone else has experienced this problem.

The automatic wake-on-lan problem continued with kernel 4.15.0-33.

The situation was resolved by fitting a Realtek ethernet adapter card (from my spare parts box), thereby bypassing the motherboard Atheros chip (motherboard Gigabyte Z77-D3H).

Wake-on-lan is now under control.

Once again I can enjoy the security updates provided by newer kernels.
Linux Mint 19 Cinnamon - 64bit

Post Reply

Return to “Ethernet”