After using and disconnecting PPTP-VPN, my internet is down

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Sun Jun 03, 2018 9:52 am

After using and disconnecting PPTP-VPN, my internet is down

Post by mintmikey » Wed Aug 15, 2018 4:34 am

I'm kind of a newby if it gets to forums as I seldom post myself on them so I apologise upfront if I missed some rules on conduct on forums but I thought this was important enough to post so here I go... :idea:

I know we have had a major change in networking from Linux Mint 18.3 to 19.0 and here is another one of the problems it created.
In Linux Mint 18.3 I used PPTP-VPN to support some external SME-Servers and I always create small howto manuals for myself on how to get things done in Linux.
In Linux Mint 18.3 I had a working howto manual on how to setup PPTP-VPN connections to the external SME-Servers.
The major change in networking from Linux Mint 18.3 to 19.0 also touches setting up GRE passthrough.
In 18.3 I needed to open port 1723 and add the line:
-A ufw-before-input -p 47 -j ACCEPT
to /etc/ufw/before.rules.
I noticed that adding it to the bottom of /etc/ufw/before.rules did not work anymore so I moved it up just underneath:
# ufw-not-local
That made the PPTP-VPN function again but here it gets interesting.
After disconnecting the PPTP-VPN all my internet connection is gone.
I have an IP-connection, my internal DNS seems to work but my external DNS seems down.

Now, I'm still bug hunting this but I think I STUMBLED ONTO A MAJOR BUG IN NETWORKING here.

I have 2 network cards in my system, enp0s25 and enp2s0.
Only enp0s25 has a cable connection.
enp2s0 has no cable connected to it and is disabled in the network manager.

By following what happens with tail -f /var/log/syslog I found out that after disconnecting the PPTP-VPN, enp0s25 directly requests and gets a new IP-address but after that internet does not function because enp2s0 (which is disabled and not connected) is trying to get a DHCP IP-address.
It times out after a quite a while but keeps re-trying to connect.
This can only be solved by disabling enp0s25 temporarily.
After enabling enp0s25 again, this problem is solved.

Now I stumbled onto this because of my PPTP-VPN connections that I need to use but it is clear that this is not really connected only to PPTP-VPN's but I uncovered a much bigger and basic problem that disconnected network cards can provide problems while you might just be looking at another connected networkcard because you are focussed on the connection and not on an unused network card.

Has anyone stumbled on this too and does anyone know if this is already reported as a bug?
Does anyone know how to really disable enp2s0 to have a better work around for this bug?

Post Reply

Return to “Ethernet”