Mint 19 Tara avahi/mdns not working

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
betchern0t
Level 1
Level 1
Posts: 20
Joined: Sat May 26, 2012 4:34 am

Mint 19 Tara avahi/mdns not working

Post by betchern0t » Tue Sep 11, 2018 11:20 pm

Hi I am running Mint 19 Tara 64 bit in an apple centric environment. They insist that I use bonjour/avahi/zeroconf for address resolution etc. Pinging a .local name results in "name or service not known". Using wire shark internally on the box or externally sees a series of multicast packets for the name and a response for that name.

There doesn't seem to be much about avahi issues since the 16 series of ubuntu. I have tried various settings of mdns and nsswitch.conf with no luck. I see that tara is using systemd-resolved and I have enabled the mdns settings for resolved. I have run avahi-daemon from the commandline in debug mode and see it logging the lookup but no response logged - either it is not seeing it or it doesn't log it in any case.

I am not sure what to do next or what to look at.

Any help is greatly appreciated

Cheers Paul

altair4
Level 19
Level 19
Posts: 9318
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 19 Tara avahi/mdns not working

Post by altair4 » Wed Sep 12, 2018 7:07 am

I don't have a lot of experience with avahi troubleshooting because I have never had it fail except for one condition and I'm not sure if fits your symptoms.

Run the following command:

Code: Select all

host -t SOA local
It should come back with something like: Host local not found: 2(SERVFAIL) OR Host local not found: 3(NXDOMAIN)
If it comes back with something like this you have a problem: local has SOA record localhost. xxxx.yyyy.zzz.

You can fix that by changing your DNS servers to point away from the one set by your ISP. For example google. To test this you rerun the first command specifying the google dns:

Code: Select all

host -t SOA local 8.8.8.8
Then you should get the "Host local not found: 2(SERVFAIL)" response.

macOS would have the same problem but since they pretty much invented this protocol they know how to handle this automatically.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

betchern0t
Level 1
Level 1
Posts: 20
Joined: Sat May 26, 2012 4:34 am

Re: Mint 19 Tara avahi/mdns not working

Post by betchern0t » Wed Sep 12, 2018 8:25 pm

Thanks Altair. Sadly that is not my problem. The host command returns similar results to those you show as correct.

Many thanks

Paul

betchern0t
Level 1
Level 1
Posts: 20
Joined: Sat May 26, 2012 4:34 am

Re: Mint 19 Tara avahi/mdns not working

Post by betchern0t » Tue Sep 18, 2018 7:28 pm

This looks like a regression issue. Works fine in 18.3.

Cheers Paul

altair4
Level 19
Level 19
Posts: 9318
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 19 Tara avahi/mdns not working

Post by altair4 » Wed Sep 19, 2018 6:45 am

It would be interesting to see if the same thing happens to Ubuntu 18.04 ( or perhaps Xubuntu 18.04 ). You don't need to install it just run it from a Live session off the install medium.

Then you would know if it's an Ubuntu thing or a Mint thing.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

betchern0t
Level 1
Level 1
Posts: 20
Joined: Sat May 26, 2012 4:34 am

Re: Mint 19 Tara avahi/mdns not working

Post by betchern0t » Thu Oct 04, 2018 6:49 pm

Thanks Altair.

So I ran the bionic live usb sticky thing. Name resolution with avahi worked fine. I took note of the revisions of:
- avahi-daemon
- libnss-mdns
- base-files (nsswitch.conf)

i took copies of nsswitch.conf, checked for the mdns optional config file but not there, and copies of the /etc/avahi dir

Only the base-files package was different. I reverted the file to two versions either side of the version on the live cd. The actual version wasn't available. Still not working. Checked the nsswitch.conf file and altered to match. check the avahi-daemon.conf file and the other files and changed to match. Still not working

Booted into the live cd again. Did an update and upgrade. Name resolution still working.

The only thing I couldn't check was any kernel changes on the live cd.

Cheers Paul

betchern0t
Level 1
Level 1
Posts: 20
Joined: Sat May 26, 2012 4:34 am

Re: Mint 19 Tara avahi/mdns not working

Post by betchern0t » Thu Oct 04, 2018 7:25 pm

I have gone back and check kernel revisions. Again the actual kernel the live cd is running is not available. I was running a custom kernel 4.17.13. I don't remember why. I tried a standard 4.15 series and a standard 4.14 series with no change in behaviour. this thing is still broken.

Cheers Paul

Post Reply

Return to “Ethernet”