[solved][ connect 2 pc via cat5 without losing wifi internet

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
danneauxs
Level 1
Level 1
Posts: 42
Joined: Thu Apr 10, 2014 5:37 pm

[solved][ connect 2 pc via cat5 without losing wifi internet

Post by danneauxs »

Been fussing with this for a few days to the point where I've tried so much I've completely befuddled myself.

I have a windows 10 and a linux mint 18.3 Mate computer. I connected them with a cat5 cable. I edited my linux ethernet setting to give a "manual" static ip 192.168.0.33. I then went to my windows pc and mapped a drive to that ip and BAM I had super fast file transfers. It's what I want and need.

Back on the linux machine I could no longer browse the internet. I had to disable the ethernet. Ok but that's a pain so I tried to solve that. What read was I had to change the metric since the metric for the ethernet was lower than the wifi. Done, but then file transfers were taking place over the slower wifi.

I started all over again and went into ethernet advance and clicked "use this connection only for resourse on this network" but that did nothing. I tried a lot of things but nothing worked like I wanted it to. i.e. fast in network transfers and wifi internet access.

I almost could live with turning the ethernet connection on and off but that doesn't work either. After clicking disconnect, if I select the ethernet to connect I'm told it doesn't exist. I have to disable networking then enable it.

I've tried "link-locally" instead of manually assigning an ip but failed.
maybe that's due to windows problems, since I cannot see the linux pc from windows in the browse network area.

Now I've screwed with it so much it's not working at all.

Can someone give me some advice on how I should set this up? Direct connections to the router/modem are out - 2 rooms away.

I know more info is most likely need. Just not sure what is needed so just tell me and I will provide it.

EDIT: well, found one issue. I set the netmask to 225.225.225.0. More reading and it should have been 225.225.0.0. No I can connect to the internet and I can map drives on my win10 to my linux, but it's not using the netcard to transfer now. Just the wifi.

[solved] Now I can send a 20Gig file in seconds

Post Reply

Return to “Ethernet”