Page 1 of 1

[SOLVED-ish] Wired Ethernet Internet Connection Dropping

Posted: Tue Jan 28, 2020 4:23 pm
by DruKe
Hi all,

Long time user of Mint but in need of some support I cannot wrap my head around.

I rebooted my PC this morning after upgrading to the 4.15.0-76 kernel and afterwards my wired connection drops just the outbound/internet portion of my connection. This happens anywhere from 30 seconds to 10 minutes. Rebooting makes it for this time and additionally toggling the Ethernet adapter makes it start working again temporarily. I tried rebooting into the old 4.15.0-74 Kernel but it continued to act the same way. I went ahead and jumped to the Kernel however issues persist. I then went ahead and upgraded to Mint 19.3 thinking that might help but no luck. Still the same.

For grins, I went ahead and replaced the cabling with another device which hasn't had issues to no avail. I've rebooted the networking equipment as well (HP Management switch and router). Same issue.

I'm fairly certain its not hardware because as mentioned, my internal networking still works fine. I use Synergy to share the keyboard/mouse from this unit to my work laptop right next to it (on another wire) and that never stops working at all. Again, just the outbound connection to the internet.

Here's the specs:

Code: Select all

System:    Host: d01 Kernel: 5.3.0-28-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Shuttle product: SH67H v: V1.0 serial: <filter> 
           Mobo: Shuttle model: FH67H v: 1.0 serial: <filter> BIOS: American Megatrends v: 2.04 date: 04/10/2013 
Battery:   Device-1: hidpp_battery_0 model: Logitech M705 charge: 70% status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-3570K bits: 64 type: MCP arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27138 
           Speed: 1602 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1596 2: 1597 3: 1597 4: 1597 
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics vendor: Holco Enterprise Co /Shuttle driver: i915 
           v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Desktop v: 4.2 Mesa 19.2.1 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Holco Enterprise Co /Shuttle 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.3.0-28-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Holco Enterprise Co /Shuttle driver: r8169 
           v: kernel port: e000 bus ID: 05:00.0 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.39 TiB used: 397.24 GiB (27.8%) 
           ID-1: /dev/sda vendor: Western Digital model: WD1002FAEX-00Z3A0 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB 
           ID-3: /dev/sdc type: USB vendor: Western Digital model: WD2500BMVV-11A1PS0 size: 232.86 GiB 
           ID-4: /dev/sdd type: USB vendor: Transcend model: TS-RDF5 SD Transcend size: 29.18 GiB 
Partition: ID-1: / size: 220.82 GiB used: 154.68 GiB (70.0%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot size: 471.6 MiB used: 233.8 MiB (49.6%) fs: ext2 dev: /dev/sdb1 
           ID-3: swap-1 size: 7.90 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 34.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 239 Uptime: 2h 32m Memory: 7.68 GiB used: 2.22 GiB (28.9%) Init: systemd runlevel: 5 Compilers: 
           gcc: 7.4.0 clang: 6.0.0-1ubuntu2 Shell: bash v: 4.4.20 inxi: 3.0.32 
This is also not browser specific or HTTP/HTTPS specific either.

Looking for any ideas here before I nuke the install and reinstall the system.


Re: Wired Ethernet Internet Connection Dropping

Posted: Tue Jan 28, 2020 8:16 pm
by vipergg
I would change the kernal back . I had issues when I went to a new kernal .

Re: Wired Ethernet Internet Connection Dropping

Posted: Tue Jan 28, 2020 8:29 pm
by DruKe
Thanks for the reply however as I mentioned in my post, I tried going back but it still acts that way with the old kernel. Still looking. Hoping I can find some logging that will help, dmesg doesn't.

Re: Wired Ethernet Internet Connection Dropping

Posted: Thu Jan 30, 2020 5:00 pm
by DruKe
Never found an answer. It progressively got worse to the point where it would cutout every 30 seconds or so. I ended up blowing it away and reinstalling Mint 19.3 with no issues. Been running it for hours now. Super weird.