samba password

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
fredmarkle
Level 1
Level 1
Posts: 4
Joined: Mon Jul 23, 2007 9:52 am

samba password

Post by fredmarkle » Fri Aug 03, 2007 9:20 pm

I shared a folder on my mint linux pc and went to connect to it on my windows 98 laptop. It asks me for a password but I never gave samba one. where would I go to find that password or to change it? Thanks for you help.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Sat Aug 04, 2007 7:51 am

I think you are helped by this link
http://www.linuxheadquarters.com/howto/ ... amba.shtml
Note the remarks on win98
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Sun Aug 05, 2007 10:26 pm

you can either set your smb.conf file to not require any authentication or add samba users for access to the samba share.

:D
Image
Now where was i going? Oh yes, crazy!

bigphredo
Level 1
Level 1
Posts: 25
Joined: Mon Nov 19, 2007 5:50 pm

Re: samba password

Post by bigphredo » Tue Nov 27, 2007 6:00 pm

I have the same issue,I was wondering if someone could elaborate on how to make my share drives available to my windows PC. I have one XP and one 98. I have a mythbuntu computer and the share drives it setup automatically shared perfectly. Thanks for the help.

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: samba password

Post by Boo » Wed Nov 28, 2007 12:46 am

look at the smb.conf file on you mythbuntu system for the answers.
you could try copying it from your mythbuntu system to your mint system and just change the shares if needed.

:D
Image
Now where was i going? Oh yes, crazy!

felipe1982
Level 2
Level 2
Posts: 52
Joined: Sun Nov 25, 2007 6:40 pm
Location: Brisbane, Australia
Contact:

Re:

Post by felipe1982 » Wed Nov 28, 2007 12:59 pm

Boo wrote:you can either set your smb.conf file to not require any authentication or add samba users for access to the samba share.

:D
Yes please! How do I change 'smb.conf' to *not* require authentication for windows clients?

bigphredo
Level 1
Level 1
Posts: 25
Joined: Mon Nov 19, 2007 5:50 pm

Re: samba password

Post by bigphredo » Wed Nov 28, 2007 5:12 pm

I don't know where or what to modify in my smb .conf?

This seems to be one of the only areas I have found with Mint that other distros do much better. All the other distros I have used in the past have had some sort of Samba config software, is there something like that for mint that I am missing?

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: samba password

Post by Boo » Wed Nov 28, 2007 10:31 pm

Image
Now where was i going? Oh yes, crazy!

bigphredo
Level 1
Level 1
Posts: 25
Joined: Mon Nov 19, 2007 5:50 pm

Re: samba password

Post by bigphredo » Thu Nov 29, 2007 2:11 pm

Boo wrote:here is the info you need:
http://www.debuntu.org/guest-file-sharing-with-samba

:D
I found a easy way to fix this issue, it had something to do with a package I downloaded. I will post some screenshots and instructions shortly. Thanks for all the suggestions and help with updating the config. I just found this program last night.

bigphredo
Level 1
Level 1
Posts: 25
Joined: Mon Nov 19, 2007 5:50 pm

Re: samba password

Post by bigphredo » Thu Nov 29, 2007 5:17 pm

here is what I did:

In the packaging manager, I searched for samba

Installed system-config-samba = GUI for managing samba shares and users

After I installed that I want to the administration area in the in the mint menu, click on the new item Samba

Once in there you can add a share drive, but the main thing you need to do is go to the preference/server settings at the top and change to the security tab. Change the authentication Mode to share. That should be it.

felipe1982
Level 2
Level 2
Posts: 52
Joined: Sun Nov 25, 2007 6:40 pm
Location: Brisbane, Australia
Contact:

Re: samba password

Post by felipe1982 » Fri Nov 30, 2007 12:04 am

I can't make a public share. Please help! I have poured through several hours of reading forums and g00gle. I'm not a complete 'noob.'

I do not want 'security = share'. It indeed works, but it isn't the goal. I will continue to use 'security = user'

My GNU system account name is 'felipe' . As root I typed 'smbpasswd -a felipe' and created a simple password. I edited smb.conf and added to [global] section 'guest account = felipe' (don't flame -- this setting was for testing purposes only).

When I connect to this share, windows xp asks for user/pass, and it always fails, even though I type in 'felipe' and password. It also fails when I leave the boxes empty and press OK, and when i click cancel.

I tried the cute (crapy?) little GUI for configuring smb.conf. That also failed to establish a public share. Yes - i know about 'sudo /etc/init.d/samba reload'. Please don't suggest that I use 'security = share'. I won't do it.

edit: I will use 'security = share' if doing so allows me to make ALL my shares, by default, secure and require a username and password, and just adding 'public = yes' to the shares I want to make public.

Code: Select all

##-------smb.conf------------
[global]
	workgroup = workgroup
	server string = %h server (Samba, Ubuntu)
	obey pam restrictions = Yes
	passdb backend = tdbsam
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
	syslog = 0
	log file = /var/log/samba/log.%m
	max log size = 1000
	dns proxy = No
	panic action = /usr/share/samba/panic-action %d
	invalid users = root
[Public]
	#The following share has permissions 777
	path = /home/felipe/Public
	;public = yes
	#above and below are equivalent
	guest ok = Yes
##-------end-------------------

felipe1982
Level 2
Level 2
Posts: 52
Joined: Sun Nov 25, 2007 6:40 pm
Location: Brisbane, Australia
Contact:

Re: samba password

Post by felipe1982 » Fri Nov 30, 2007 12:39 am

am I confusing myself?

THis is what i've gathered so far (Correct me if I am wrong):
'security = user' in [global] will not allow me to have a public share. I can only have a public share with 'security = share' in my [global] section.

What I want is ALL shares to be 'private' shares (requires user/pass). I want to have ONE public share (*NO* user/pass) too. I've g00gled enough and my brain hurts.....

edit: I've read up on samba, and tried to copy/paste the config that I found here. I chaged the 'workgroup' name, and the details of the share. /home/felipe/Public has permissions 777

When connecting with windows xp, it still asks for user/pass. I tried 'sudo smbpasswd -x felipe' to remove the user I had previously added. This did not solve the problem. Please help.

Code: Select all

[global]
	server string = Samba %v on (%L)
	workgroup = WORKGROUP

[Public]
	path = /home/felipe/Public
	writeable = yes
	guest ok = yes
Last edited by felipe1982 on Fri Nov 30, 2007 1:02 am, edited 1 time in total.

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Re: samba password

Post by Boo » Fri Nov 30, 2007 12:46 am

samba is an all or nothing authentication system.
either everyone authenticates (user/password) or none at all (share).
so what you do is essentially have a guest account that everyone can use.

:D
Image
Now where was i going? Oh yes, crazy!

felipe1982
Level 2
Level 2
Posts: 52
Joined: Sun Nov 25, 2007 6:40 pm
Location: Brisbane, Australia
Contact:

Re: samba password

Post by felipe1982 » Fri Nov 30, 2007 1:06 am

Boo wrote:samba is an all or nothing authentication system.
either everyone authenticates (user/password) or none at all (share).
so what you do is essentially have a guest account that everyone can use.
That isn't what I understand from this:
http://www.oreilly.com wrote:You may have noticed that we set the guest ok parameter to yes. While this isn't very security-conscious, there are some password issues that we need to understand before setting up individual users and authentication. For the moment, this will sidestep those issues and let anyone connect to the share. [cite]

Post Reply

Return to “Ethernet”