Page 1 of 1

Network problem in kdeCE

Posted: Mon Aug 27, 2007 5:30 am
by Flint
I recently installed Mint kdeCE. My internet provider gave me settings for the connection (ip, gate, mask and dns) to enter in the pc. Everything was going well. But my ethernet adapter broke down so I had to replace it.
So, I replaced it, entered my settings from the provider and... nada. Not working. I can't open web pages, can't log in to skype - nothing.
My old adapter was assigned as "eth0". When I changed the new one (in the same PCI slot) it was "eth2". I tought that this might be the problem. Looked around the web and found out hot to assign it as eth0. But it still doesn't work...
So any help? :D

Posted: Wed Aug 29, 2007 6:12 pm
by Husse
I don't think it matters wether it's eth0 or eth2 - it's not supposed to....
What type of connection do you use? ADSL? Cable?

Posted: Fri Aug 31, 2007 2:36 am
by Boo
I would remove the network card
remove all entries except lo in /etc/network/interfaces.
remove all network settings from administration/network gui.
power off
insert card, boot.

hopefully it is all better now.


Posted: Mon Sep 03, 2007 3:32 am
by Flint
I use cable connection with static IP

I will try what Boo suggests later today and will post what happens :)

Posted: Mon Sep 03, 2007 5:34 am
by Flint
Well, I tried this but nothing happens. I still don't have i-net under Mint :?
I tried even putting the ethernet adapter into a different slot but still nothing...

Posted: Mon Sep 03, 2007 5:47 am
by Husse
This is odd... But changing equipment like that can be a problem as the new one might need some different "hardware setting" and is not sufficiently different for Mint to notice that.
Tell us what kind of internet connection you have and if you use a broadband router of some kind. If so can you ping that router
I have experienced more than once that you get as far as to the router, but not further

Posted: Mon Sep 03, 2007 7:12 am
by Flint
So this is the internet connection at my workplace, which is a construction site. It's a sattelite dish, pointing to a near town. This is how it works, so I'm not sure what type it is. But when the people from the provider fixed the dish, they left me a note with the settings - I have to enter manually the IP address, mask, gateway and 2 DNS addresses.
Another thing I tried is that I booted from the LiveCD and tried to enter the settings and I still don't get internet connection. It was OK when I first installed it though :?

Posted: Mon Sep 03, 2007 8:14 am
by Husse
So it's a radio link. I gather you don't use a router.
Can you ping an IP address? The IP should always be up and answering to a ping (it's one of the DNS servers a t Open DNS)
You find ping in the control center under Networking>Networking tools
The answer to the "ping question" helps pinpointing the problem

Posted: Tue Sep 04, 2007 5:07 am
by Flint
Husse wrote:You find ping in the control center under Networking>Networking tools
I think this is in GNOME. I'm not sure where it is in KDE, but when I type


in the terminal, it says smth. like

ping: pingmsg: operation not permitted


Posted: Tue Sep 04, 2007 8:33 am
by Husse
Seems like an error - you should be able to ping from the terminal - I just logged in to Cassandra KDE and pinged that IP
Any other oddities?
I don't understand why a change of network card would have that effect and I don't think that's the reason.

Posted: Tue Sep 04, 2007 11:19 am
by Flint
I don't know what's the problem either :?

Under windows I had no problem - after I changed the net card, I just entered my new settings and it was all well. In Linux however I did the same - no internet at all.
The worst thing is, as I mantioned - I tried to boot from the Live CD and enter the settings to see if it works - no, it doesn't....