Don't configure net interface on boot![solved]

Questions about cabled networking
Forum rules
Before you post please read how to get help
Post Reply
sonicbhoc
Level 1
Level 1
Posts: 26
Joined: Mon Aug 06, 2007 9:47 pm

Don't configure net interface on boot![solved]

Post by sonicbhoc » Wed Aug 29, 2007 10:02 am

My computer keeps trying to connect network interfaces at boot, and it makes boot take about 2x as long as it has to. It's really annoying. How do I tell it not to configure internet interfaces at boot?
Last edited by sonicbhoc on Wed Aug 29, 2007 10:34 pm, edited 1 time in total.

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Wed Aug 29, 2007 9:07 pm

you can turn off networking under services.

In KDE control Center-->sysadmin-->system services
choose admin mode (button at bottom)
change it to run level 5, turn off networking at boot.


:D
Image
Now where was i going? Oh yes, crazy!

sonicbhoc
Level 1
Level 1
Posts: 26
Joined: Mon Aug 06, 2007 9:47 pm

Post by sonicbhoc » Wed Aug 29, 2007 9:46 pm

That's the problem. It's already set not to start with boot, but yet when I boot up my computer, it always says "configuring network interfaces" and stays there forever until it fails to connect.

This is one of the reasons I've always liked Gentoo. The init system wasn't such a pain, it had a command line configuration, and when ifplugd was installed it would skip this step and leave it to the daemon. And baselayout-2 was FAST. But I gave that up because in college I won't have time to mess with gentoo all of the time.

I'll try installing ifplud and seeing if that does anything. I hope it works.

EDIT: Nope. I guess I'll have to deal with a slow boot-up because Ubuntu can't pass up the chance to try and fail to configure both of my internet connections.

Here's a better question: Can I make Mint not load the modules for any network-based device and load them myself when I need them?

EDIT2: Ah ha! It turns out that the problem was the network start script in /etc/rcS.d/ which isn't shown in GUI configurations because it's for system RC configurations. Well, I just used my trusty command line skills and read the readme, renaming the network file to have a K in the beginning instead of an S, which disabled network from being auto-configured on boot. Which is OK, because NetworkManager handles that just fine. ;)

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Thu Aug 30, 2007 3:10 am

that seems completely spastic!

I would have thought /etc/rcS.d/ is single user mode same as /etc/rc1.d/
the only thing started in there should be the keyboard/mouse.

so the /etc/rcS.d/ is a start up area.
it is run for every runlevel even single user.
this is crap! :evil:
look in /etc/events.d/rc-default and the rest if you want.
this is bad programing/scripting.

I may change this for Celena. well at least for single user mode.
some serious investigation is needed.

:D
Image
Now where was i going? Oh yes, crazy!

sonicbhoc
Level 1
Level 1
Posts: 26
Joined: Mon Aug 06, 2007 9:47 pm

Post by sonicbhoc » Fri Aug 31, 2007 8:23 pm

Boo wrote:that seems completely spastic!

I would have thought /etc/rcS.d/ is single user mode same as /etc/rc1.d/
the only thing started in there should be the keyboard/mouse.

so the /etc/rcS.d/ is a start up area.
it is run for every runlevel even single user.
this is crap! :evil:
look in /etc/events.d/rc-default and the rest if you want.
this is bad programing/scripting.

I may change this for Celena. well at least for single user mode.
some serious investigation is needed.

:D
One of the reasons I highly prefer Gentoo's init system. ;)

I don't think the S is for single - I think it's for System. Network shouldn't start every time you turn on your system. What if you're trying to make a system that doesn't have internet access on purpose?

Plus, it just takes longer to start that way.

Thanks for looking into it, Boo.

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Sun Sep 02, 2007 9:59 pm

the rsS is for startup, sort of like rc.local.

but rc.local is run after all the rcN stuff and the rcS stuff is run before the rcN stuff.

now upstart is event based so the files in /etc/event.d/ are like one big config file and so working out what is happening can be painful at times.

BTW if you create an /etc/inittab file upstart will use it instead of the /etc/event.d/ files. back to a init system...

:D
Image
Now where was i going? Oh yes, crazy!

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Mon Sep 03, 2007 1:49 am

well an update if you really want to know...

the init system was replaced by upstart but init still starts and manages processes (like an upstart alias).

upstart/init is in a transitional stage at the moment from what i can tell.
a lot of the init file structure is still there so as to not scare everyone with a sudden change but remember all those rc?.d/* are just a bunch of directories and links to init.d/*.

Some facts (to scare you).
Upstart is event based. eg system starts, Ctl-alt-del pressed, some process stopped, flag set to...

event files are located in /etc/event.d/

upstart does not have or know about runlevels. ie there are no run levels any more.

Ubuntu/Mint OS's now run in "runlevel" 2. not runlevel 5 as we are all use to. but remember there are no run levels any more so who cares what it is called. this also means you could delete rc3.d, rc4.d and rc5.d and not harm your system. well it has not hurt mine yet.

run levels, and so /etc/rc?.d could be replaced with events:
runlevel 0 = rc0.d = shutdown system
runlevel 1 = rc1.d = system maintenance mode
runlevel 2 = rc2.d = run system
runlevel 6 = rc6.d = reboot system
maybe they should be called major events?

there is a new event level S or Startup that runs all sorts of stuff at boot and before any other runlevel. found in /etc/rsS.d/.

well more later

:D
Image
Now where was i going? Oh yes, crazy!

Post Reply

Return to “Ethernet”