Page 1 of 1

bad interface configuration: eth0 is not IP

Posted: Fri Jun 11, 2010 7:42 am
by psylent
Hi, been using Mint 9 64 bit for a bit now and am having no luck with some network tools, i can connect to the net just fine, and do most things without a problem, however when i run scanssh (with args) i keep getting this error
scanssh -p -i eth0 ***.***.***.***/***
scanssh: interface_new: bad interface configuration: eth0 is not IP

i have replaced the IP with *'s for privacy :) , i installed scanssh from the repository and it all seemed to go well , the program executes all good, just that it cant actually function on the network. I have tried specifying eth0 as the interface with scanssh -p -i eth0 , but i still get the same error, any help is appreciated, if more information is needed just let me know what you need. I have been using linux for a while but am by no means a guru or even what i would call an "advanced" user.

Re: bad interface configuration: eth0 is not IP

Posted: Fri Jun 11, 2010 11:16 am
by DrHu
  • Is eth0 on your system a real connection to the outside world (Internet) or only a device name that starts when you start the system..
  • If you have ufw running, or IPTABLES (it runs by default)
    --they will be denying all access from external ports, unless you opened those ports
    --some applications like skype will automatically (by themselves) punch those ports open for access..
Usually port or network scanners/sniffers require a network connection to be in promiscuous mode, that is not the normal connection
  • --in order to be able to capture data coming through that device
Sometimes, you have to run a sniffer as a root user, since it (as above) can require extra or more control of the device interface ..

Read their documentation for some insight to their methods..
http://monkey.org/~provos/scanssh/
--one pdf file is available right there..

Re: bad interface configuration: eth0 is not IP

Posted: Sun Jun 13, 2010 11:18 pm
by psylent
all good thanks for help, i ended up scrapping scanssh since there was nothing on google or the home site that related to my particular error, everyone talked like it had never been seen anywhere else, W.I.N.E to the rescue again :)
Ended up running a similar program with windows emu.