Page 1 of 1

No network connection

Posted: Sun Jul 25, 2010 11:53 pm
by bin4ry
Hello,

I have just started getting into Linux Mint. I did a full install, but I can't seem to connect to the internet. I've done about 2 hours worth of searching on the internet, but nothing seems to work. I tried searching for a linux driver (Realtek RTL8111/8168B), and installed it successfully, but it still isn't working. If I knew it would be this much of a pain in the ass, I should've stuck to windows :D.

Here's where I downloaded the driver from: Realtek: LINUX driver for kernel 2.6.x and 2.4.x (Support x86 and x64)

Whenever I try connecting, it tries finding a connection, then returns saying it cannot connect.

Here's some data (some people asked for this in other posts I was reading..)
ifconfig

Code: Select all

eth0      Link encap:Ethernet  HWaddr 00:1a:92:e3:7c:39  
          inet6 addr: fe80::21a:92ff:fee3:7c39/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31183 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1906626 (1.9 MB)  TX bytes:2304 (2.3 KB)
          Interrupt:28 Base address:0xe000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:76 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5120 (5.1 KB)  TX bytes:5120 (5.1 KB)

lshw

Code: Select all

  *-network               
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 01
       serial: 00:1a:92:e3:7c:39
       size: 10MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=yes multicast=yes port=MII speed=10MB/s
       resources: irq:28 ioport:b800(size=256) memory:ff9ff000-ff9fffff memory:ff9c0000-ff9dffff(prefetchable)

lspci

Code: Select all

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
	Subsystem: ASUSTeK Computer Inc. Device 81aa
	Flags: bus master, fast devsel, latency 0, IRQ 28
	I/O ports at b800 [size=256]
	Memory at ff9ff000 (64-bit, non-prefetchable) [size=4K]
	Expansion ROM at ff9c0000 [disabled] [size=128K]
	Capabilities: [40] Power Management version 2
	Capabilities: [48] Vital Product Data <?>
	Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
	Capabilities: [60] Express Endpoint, MSI 00
	Capabilities: [84] Vendor Specific Information <?>
	Capabilities: [100] Advanced Error Reporting <?>
	Capabilities: [12c] Virtual Channel <?>
	Capabilities: [148] Device Serial Number 68-81-ec-10-00-00-00-1a
	Capabilities: [154] Power Budgeting <?>
	Kernel driver in use
nm-tool

Code: Select all

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             disconnected
  Default:           no
  HW Address:        00:1A:92:E3:7C:39

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         on

Help!

Re: No network connection

Posted: Mon Jul 26, 2010 5:19 pm
by remoulder

Re: No network connection

Posted: Tue Jul 27, 2010 7:48 pm
by bin4ry
Thanks for the reply. I tried it and still nothing works, even after a reboot.

Re: No network connection

Posted: Wed Jul 28, 2010 8:12 am
by remoulder
Please post the output of lsmod

Re: No network connection

Posted: Tue Aug 31, 2010 12:19 pm
by ColJep
I have found that if you right click on the network icon after booting and disable networking for about 30 seconds then re enable it, a connection will be made.

My motherboard is Asus M4A785TD-EVO

Re: No network connection

Posted: Wed Sep 01, 2010 7:48 am
by k_sroy
Team Linux Mint,

Since beginning of my computer knowledge I was always very fond of Linux due to its strong Security feature. But always unable to run the OS due to Driver problem. Recently I had come to know about Linux-Mint and I installed Linux Mint9-KDE Amd 64 full version in my Windows7 partition. Everything (Graphics, Sound, DVDWriter) are working properly except Internet connection. I am using Cable BroadBand connection. I had configured the Network Connection as the same way I did in Win7. A small Ethernet connection icon is also showing connected. But Firefox is unable to connect. I had also tried the other browser which comes with this package, but the result was same. :(
By going through the Forum on problems, I was unable to found similar problem. Hence requesting you help. I had also spoke with the HelpLine of Internet Service Provider, though they are not expert in Linux but said I need to install the Driver of Ethernet Adopter. Installing with I will be able to view MyNetwork Connection(Windows) like Icon, and by configuring that will solve my problem.
Please find below my ispci and inxi -N status and attached screen shot of my Network Connection.

atom@mint ~ $ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 LPC Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d0)
atom@mint ~ $ inxi -N
Network: Card nVidia MCP61 Ethernet driver forcedeth